summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 16:29:30 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 16:29:30 +0000
commit77c0d41462e6695a8a921a11e46dcb6729f94b05 (patch)
tree514d3024f65b03f518d4faa7a11cd14b30c5e3c6 /sys-apps/file
parentUses static and build now instead of build-static (diff)
downloadgentoo-2-77c0d41462e6695a8a921a11e46dcb6729f94b05.tar.gz
gentoo-2-77c0d41462e6695a8a921a11e46dcb6729f94b05.tar.bz2
gentoo-2-77c0d41462e6695a8a921a11e46dcb6729f94b05.zip
Replaced manual install with DESTDIR=${D} method
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-3.33-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/file/file-3.33-r2.ebuild b/sys-apps/file/file-3.33-r2.ebuild
new file mode 100644
index 000000000000..06f0a17bc4d8
--- /dev/null
+++ b/sys-apps/file/file-3.33-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33-r2.ebuild,v 1.1 2001/02/27 16:29:30 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patters"
+#unfortunately, this ftp site doesn't support passive ftp
+#maybe we can find an alternative for those behind firewalls, or mirror
+#on cvs.gentoo.org
+SRC_URI="ftp://ftp.astron.com/pub/file/${A}"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/misc --host=${CHOST}
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ if [ -z "`use build`" ]
+ then
+ dodoc LEGAL.NOTICE MAINT README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+
+}
+
+
+