summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-14 04:44:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-14 04:44:00 +0000
commit25edb23782d61d7e10960b54df18e4b0e59ff7b8 (patch)
tree1c8da0c7aa7800ccbd1a8703cf3c04281dd5fb7f /sys-apps/file
parentNew ncurses seems to be slightly incompatible ... (diff)
downloadgentoo-2-25edb23782d61d7e10960b54df18e4b0e59ff7b8.tar.gz
gentoo-2-25edb23782d61d7e10960b54df18e4b0e59ff7b8.tar.bz2
gentoo-2-25edb23782d61d7e10960b54df18e4b0e59ff7b8.zip
Fix building with people who set LD_LIBRARY_PATH to retarded values #99593.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog6
-rw-r--r--sys-apps/file/file-4.15.ebuild5
-rw-r--r--sys-apps/file/files/file-4.15-libtool.patch19
3 files changed, 27 insertions, 3 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 98eaa624ea25..9ebcef158f45 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.87 2005/08/18 22:27:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.88 2005/09/14 04:44:00 vapier Exp $
+
+ 14 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/file-4.15-libtool.patch, file-4.15.ebuild:
+ Fix building with people who set LD_LIBRARY_PATH to retarded values #99593.
*file-4.15 (18 Aug 2005)
diff --git a/sys-apps/file/file-4.15.ebuild b/sys-apps/file/file-4.15.ebuild
index dfb663b811bb..7cf2e2471e78 100644
--- a/sys-apps/file/file-4.15.ebuild
+++ b/sys-apps/file/file-4.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.15.ebuild,v 1.2 2005/08/19 16:08:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.15.ebuild,v 1.3 2005/09/14 04:44:00 vapier Exp $
inherit distutils libtool
@@ -20,7 +20,8 @@ src_unpack() {
unpack ${P}.tar.gz
cd "${S}"
- uclibctoolize
+ epatch "${FILESDIR}"/${P}-libtool.patch #99593
+ elibtoolize
# make sure python links against the current libmagic #54401
sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
diff --git a/sys-apps/file/files/file-4.15-libtool.patch b/sys-apps/file/files/file-4.15-libtool.patch
new file mode 100644
index 000000000000..c41c8fec297d
--- /dev/null
+++ b/sys-apps/file/files/file-4.15-libtool.patch
@@ -0,0 +1,19 @@
+Fix build time issues with tools who like to export LD_LIBRARY_PATH
+to retarded values.
+
+http://bugs.gentoo.org/99593
+
+--- ltmain.sh
++++ ltmain.sh
+@@ -5085,6 +5085,11 @@
+ $echo >> $output "\
+ if test \"\$libtool_execute_magic\" != \"$magic\"; then
+ # Run the actual program with our arguments.
++
++ # Make sure env LD_LIBRARY_PATH does not mess us up
++ if test -n \"\${LD_LIBRARY_PATH+set}\"; then
++ export LD_LIBRARY_PATH=\$progdir:\$LD_LIBRARY_PATH
++ fi
+ "
+ case $host in
+ # Backslashes separate directories on plain windows