summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-12-22 05:29:35 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-12-22 05:29:35 +0000
commit721a4c73b529905cf6f00024a05f7b9b0ea95307 (patch)
tree8035605f799542eb3d10ee0f81e338956f5ab30a /sys-apps/dmapi/dmapi-2.0.1_p20020330.ebuild
parentsmall fix0rs (diff)
downloadgentoo-2-721a4c73b529905cf6f00024a05f7b9b0ea95307.tar.gz
gentoo-2-721a4c73b529905cf6f00024a05f7b9b0ea95307.tar.bz2
gentoo-2-721a4c73b529905cf6f00024a05f7b9b0ea95307.zip
fixing XFS-related CVS snapshot versioning policy violations, which caused
an old version to be considered newer than the new version. 20020330 -> 2.0.x_p20020330 fixed things.
Diffstat (limited to 'sys-apps/dmapi/dmapi-2.0.1_p20020330.ebuild')
-rw-r--r--sys-apps/dmapi/dmapi-2.0.1_p20020330.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-2.0.1_p20020330.ebuild b/sys-apps/dmapi/dmapi-2.0.1_p20020330.ebuild
new file mode 100644
index 000000000000..4da9394fef89
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.0.1_p20020330.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.0.1_p20020330.ebuild,v 1.1 2002/12/22 05:29:35 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+OPV=20020330
+DESCRIPTION="XFS data management API library"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${OPV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+KEYWORDS="x86 ppc sparc "
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/xfsprogs"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}