summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-05-13 18:34:05 +0000
committerThilo Bangert <bangert@gentoo.org>2002-05-13 18:34:05 +0000
commit0e08032a37cc815dcda0287fa0eee05abad61dec (patch)
treea1439724e2fae0e1b7160de6c1d6c66103773204 /sys-apps/cronbase
parentcosmetic fix (diff)
downloadgentoo-2-0e08032a37cc815dcda0287fa0eee05abad61dec.tar.gz
gentoo-2-0e08032a37cc815dcda0287fa0eee05abad61dec.tar.bz2
gentoo-2-0e08032a37cc815dcda0287fa0eee05abad61dec.zip
added LICENSE + header fixes
Diffstat (limited to 'sys-apps/cronbase')
-rw-r--r--sys-apps/cronbase/cronbase-0.01.ebuild34
-rw-r--r--sys-apps/cronbase/files/README2
-rw-r--r--sys-apps/cronbase/files/run-crons2
3 files changed, 20 insertions, 18 deletions
diff --git a/sys-apps/cronbase/cronbase-0.01.ebuild b/sys-apps/cronbase/cronbase-0.01.ebuild
index 81d99f11cec5..3e141a25649a 100644
--- a/sys-apps/cronbase/cronbase-0.01.ebuild
+++ b/sys-apps/cronbase/cronbase-0.01.ebuild
@@ -1,34 +1,36 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
# Author: Thilo Bangert <bangert@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cronbase/cronbase-0.01.ebuild,v 1.4 2002/04/27 21:46:45 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cronbase/cronbase-0.01.ebuild,v 1.5 2002/05/13 18:34:05 bangert Exp $
DESCRIPTION="The is the base for all cron ebuilds."
+HOMEPAGE="http://www.gentoo.org/"
+LICENSE="GPL-2"
#adds ".keep" files so that dirs aren't auto-cleaned
keepdir() {
- dodir $*
- local x
- for x in $*
- do
- touch ${D}/${x}/.keep
- done
+ dodir $*
+ local x
+ for x in $*
+ do
+ touch ${D}/${x}/.keep
+ done
}
src_install () {
- exeinto /usr/sbin
- doexe ${FILESDIR}/run-crons
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/run-crons
- diropts -m0750; keepdir /etc/cron.hourly
- diropts -m0750; keepdir /etc/cron.daily
- diropts -m0750; keepdir /etc/cron.weekly
- diropts -m0750; keepdir /etc/cron.monthly
+ diropts -m0750; keepdir /etc/cron.hourly
+ diropts -m0750; keepdir /etc/cron.daily
+ diropts -m0750; keepdir /etc/cron.weekly
+ diropts -m0750; keepdir /etc/cron.monthly
- diropts -m0750 -o root -g cron; keepdir /var/spool/cron
+ diropts -m0750 -o root -g cron; keepdir /var/spool/cron
- diropts -m0750; keepdir /var/spool/cron/lastrun
+ diropts -m0750; keepdir /var/spool/cron/lastrun
- dodoc ${FILESDIR}/README
+ dodoc ${FILESDIR}/README
}
diff --git a/sys-apps/cronbase/files/README b/sys-apps/cronbase/files/README
index 12875b25182a..1fe75ce7282f 100644
--- a/sys-apps/cronbase/files/README
+++ b/sys-apps/cronbase/files/README
@@ -1,5 +1,5 @@
-$ Header: $
+$Header: /var/cvsroot/gentoo-x86/sys-apps/cronbase/files/README,v 1.5 2002/05/13 18:34:05 bangert Exp $
22 Apr 2oo2; Thilo Bangert <bangert@gentoo.org>
diff --git a/sys-apps/cronbase/files/run-crons b/sys-apps/cronbase/files/run-crons
index 45c34210aa8d..01aa11c088d3 100644
--- a/sys-apps/cronbase/files/run-crons
+++ b/sys-apps/cronbase/files/run-crons
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $ Header: $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cronbase/files/run-crons,v 1.3 2002/05/13 18:34:05 bangert Exp $
#
# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> run-crons:
#