summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-15 12:11:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-15 12:11:32 +0000
commit1aceaf301c941964e5ed42056a1d7574d1171b9b (patch)
tree56a54228f02a00db5e290f888425b4d9dcb9fb54 /sys-apps/cpuid
parentRe-add support for Bash versions < 4.2 (the manuals tend not to be clear abou... (diff)
downloadgentoo-2-1aceaf301c941964e5ed42056a1d7574d1171b9b.tar.gz
gentoo-2-1aceaf301c941964e5ed42056a1d7574d1171b9b.tar.bz2
gentoo-2-1aceaf301c941964e5ed42056a1d7574d1171b9b.zip
Initial commit. Bug #179805
(Portage version: 2.2.0_alpha39/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/ChangeLog11
-rw-r--r--sys-apps/cpuid/cpuid-20110305.ebuild30
-rw-r--r--sys-apps/cpuid/files/cpuid-20110305-Makefile.patch30
-rw-r--r--sys-apps/cpuid/metadata.xml12
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/cpuid/ChangeLog b/sys-apps/cpuid/ChangeLog
new file mode 100644
index 000000000000..d87d21159e9f
--- /dev/null
+++ b/sys-apps/cpuid/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/cpuid
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/ChangeLog,v 1.1 2011/06/15 12:11:32 hwoarang Exp $
+
+*cpuid-20110305 (15 Jun 2011)
+
+ 15 Jun 2011; Markos Chandras <hwoarang@gentoo.org> +cpuid-20110305.ebuild,
+ +files/cpuid-20110305-Makefile.patch, +metadata.xml:
+ Initial commit of cpuid. Thanks to Ivan Yosifov <iyosifov@gmail.com> for the
+ initial ebuild. Bug #179805
+
diff --git a/sys-apps/cpuid/cpuid-20110305.ebuild b/sys-apps/cpuid/cpuid-20110305.ebuild
new file mode 100644
index 000000000000..468c3ccce7d9
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20110305.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/cpuid-20110305.ebuild,v 1.1 2011/06/15 12:11:32 hwoarang Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}
diff --git a/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch b/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
new file mode 100644
index 000000000000..a3aab8a50f66
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
@@ -0,0 +1,30 @@
+Index: cpuid-20110305/Makefile
+===================================================================
+--- cpuid-20110305.orig/Makefile
++++ cpuid-20110305/Makefile
+@@ -1,7 +1,3 @@
+-CFLAGS=-g
+-ifneq (,$(findstring arch=i386,$(CFLAGS)))
+-CISA=-m32
+-endif
+ CFL=$(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+
+ PACKAGE=cpuid
+@@ -36,14 +32,14 @@ BUILDROOT=
+ default: $(PROG) $(PROG).man.gz
+
+ $(PROG): cpuid.c Makefile
+- $(CC) $(CFL) -o $@ cpuid.c
++ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+
+ $(PROG).man.gz: $(PROG).man
+ gzip < $< > $@
+
+ install: $(PROG) $(PROG).man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
diff --git a/sys-apps/cpuid/metadata.xml b/sys-apps/cpuid/metadata.xml
new file mode 100644
index 000000000000..87afd6e36004
--- /dev/null
+++ b/sys-apps/cpuid/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+