summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-17 19:17:45 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-17 19:17:45 +0000
commit9cb533b4bc8eedf43d7c56b4cb134b6731b73cef (patch)
tree7285e4c26162625d3ea31948d9cea84756e846a5 /sys-apps/collectl
parentUpdated live ebuild, Bug #327823. (diff)
downloadgentoo-2-9cb533b4bc8eedf43d7c56b4cb134b6731b73cef.tar.gz
gentoo-2-9cb533b4bc8eedf43d7c56b4cb134b6731b73cef.tar.bz2
gentoo-2-9cb533b4bc8eedf43d7c56b4cb134b6731b73cef.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/collectl')
-rw-r--r--sys-apps/collectl/ChangeLog8
-rw-r--r--sys-apps/collectl/collectl-3.4.1.ebuild41
-rw-r--r--sys-apps/collectl/files/collectl-3.4.1-install.patch22
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-apps/collectl/ChangeLog b/sys-apps/collectl/ChangeLog
index 4709c95a81cf..7dfdcb681891 100644
--- a/sys-apps/collectl/ChangeLog
+++ b/sys-apps/collectl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/collectl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/collectl/ChangeLog,v 1.9 2010/01/08 12:42:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/collectl/ChangeLog,v 1.10 2010/07/17 19:17:45 vapier Exp $
+
+*collectl-3.4.1 (17 Jul 2010)
+
+ 17 Jul 2010; Mike Frysinger <vapier@gentoo.org> +collectl-3.4.1.ebuild,
+ +files/collectl-3.4.1-install.patch:
+ Version bump.
08 Jan 2010; Mike Frysinger <vapier@gentoo.org> files/collectl.initd:
Add a "flush" init.d operation #292864#18 by Mark Seger.
diff --git a/sys-apps/collectl/collectl-3.4.1.ebuild b/sys-apps/collectl/collectl-3.4.1.ebuild
new file mode 100644
index 000000000000..e1a1049a640e
--- /dev/null
+++ b/sys-apps/collectl/collectl-3.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/collectl/collectl-3.4.1.ebuild,v 1.1 2010/07/17 19:17:45 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="light-weight performance monitoring tool capable of reporting interactively as well as logging to disk"
+HOMEPAGE="http://collectl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/collectl/${P}.src.tar.gz"
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8.8
+ virtual/perl-Time-HiRes
+ >=dev-perl/Archive-Zip-1.20
+ sys-apps/ethtool
+ sys-apps/pciutils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4.1-install.patch
+ sed -i \
+ -e "/^DOCDIR/s:doc/collectl:doc/${PF}:" \
+ INSTALL || die
+}
+
+src_install() {
+ DESTDIR=${D} bash -ex ./INSTALL || die
+
+ rm "${D}"/etc/init.d/* || die
+ newinitd "${FILESDIR}"/collectl.initd collectl
+
+ cd "${D}"/usr/share/doc/${PF}
+ dohtml * || die
+ rm -f ARTISTIC GPL COPYING *.html *.jpg *.css || die
+ prepalldocs
+}
diff --git a/sys-apps/collectl/files/collectl-3.4.1-install.patch b/sys-apps/collectl/files/collectl-3.4.1-install.patch
new file mode 100644
index 000000000000..2d230513b719
--- /dev/null
+++ b/sys-apps/collectl/files/collectl-3.4.1-install.patch
@@ -0,0 +1,22 @@
+DESTDIR doesnt require clean up of things outside of DESTDIR
+
+--- INSTALL
++++ INSTALL
+@@ -7,7 +7,7 @@
+ SHRDIR=$DESTDIR/usr/share/collectl
+ MANDIR=$DESTDIR/usr/share/man/man1
+ ETCDIR=$DESTDIR/etc
+-INITDIR=$DESTDIR/$ETCDIR/init.d
++INITDIR=$ETCDIR/init.d
+
+ mkdir -p $BINDIR
+ mkdir -p $DOCDIR
+@@ -46,6 +46,8 @@
+ chmod 755 $SHRDIR/util/*
+ chmod 444 $SHRDIR/formatit.ph $SHRDIR/*expr.ph $SHRDIR/vmstat.ph
+
++[[ ${DESTDIR} != "/" ]] && exit 0
++
+ # remove any stale versions in case the names/numbers used have changed.
+ # on new ROCKS installion 'rm' isn't there yet! [thanks roy]
+ if [ -x /bin/rm ] ; then