summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-15 17:17:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-15 17:17:48 +0000
commit71ae60b7b57f7acb16c28ad7dc1731e29a66c1ff (patch)
tree0b0c359d95599cdc886e06be4cced0eb8b43209c /sys-apps/attr
parentRevision bump: port to EAPI=4, drop prepalldocs, add static-libs USE flag, dr... (diff)
downloadgentoo-2-71ae60b7b57f7acb16c28ad7dc1731e29a66c1ff.tar.gz
gentoo-2-71ae60b7b57f7acb16c28ad7dc1731e29a66c1ff.tar.bz2
gentoo-2-71ae60b7b57f7acb16c28ad7dc1731e29a66c1ff.zip
Revision bump: port to EAPI=4, drop prepalldocs, add static-libs USE flag, drop .la files if static-libs are disabled.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/ChangeLog10
-rw-r--r--sys-apps/attr/attr-2.4.44-r1.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index cf6eb046fba8..0ac20b69c251 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/attr
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.124 2010/12/05 16:07:43 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.125 2011/04/15 17:17:48 flameeyes Exp $
+
+*attr-2.4.44-r1 (15 Apr 2011)
+
+ 15 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org> +attr-2.4.44-r1.ebuild:
+ Revision bump: port to EAPI=4, drop prepalldocs, add static-libs USE flag,
+ drop .la files if static-libs are disabled.
05 Dec 2010; Raúl Porcel <armin76@gentoo.org> attr-2.4.44.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #346455
diff --git a/sys-apps/attr/attr-2.4.44-r1.ebuild b/sys-apps/attr/attr-2.4.44-r1.ebuild
new file mode 100644
index 000000000000..d97d351852ad
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.44-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.44-r1.ebuild,v 1.1 2011/04/15 17:17:48 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://savannah.nongnu.org/projects/attr"
+SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.44-gettext.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ strip-linguas po
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --enable-shared $(use_enable static-libs static) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-lib install-dev || die
+ use static-libs || find "${D}" -name '*.la' -delete
+ # the man-pages packages provides the man2 files
+ rm -r "${D}"/usr/share/man/man2
+
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+}