summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-17 14:37:54 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-17 14:37:54 +0000
commit724f141c9dc7f9034f23b431fe4fc351d6d80521 (patch)
treeb6acb443ebcf748109696952c76ce3ac7addc350 /sys-apps/attr/attr-2.4.43.ebuild
parentold (diff)
downloadgentoo-2-724f141c9dc7f9034f23b431fe4fc351d6d80521.tar.gz
gentoo-2-724f141c9dc7f9034f23b431fe4fc351d6d80521.tar.bz2
gentoo-2-724f141c9dc7f9034f23b431fe4fc351d6d80521.zip
Version bump #231274 by Conrad Kostecki.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-apps/attr/attr-2.4.43.ebuild')
-rw-r--r--sys-apps/attr/attr-2.4.43.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/attr/attr-2.4.43.ebuild b/sys-apps/attr/attr-2.4.43.ebuild
new file mode 100644
index 000000000000..740921343e46
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.43.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.43.ebuild,v 1.1 2008/08/17 14:37:53 vapier Exp $
+
+inherit eutils autotools toolchain-funcs
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.4.39-gettext.patch
+ epatch "${FILESDIR}"/${PN}-2.4.43-linguas.patch #205948
+ epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ # libtool will clobber install-sh which is really a custom file
+ mv install-sh acl.install-sh || die
+ AT_M4DIR="m4" eautoreconf
+ mv acl.install-sh install-sh || die
+ strip-linguas po
+}
+
+src_compile() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-lib install-dev || die
+ # the man-pages packages provides the man2 files
+ rm -r "${D}"/usr/share/man/man2
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libattr.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libattr.so
+}