summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2007-06-08 18:04:35 +0000
committerJoe Peterson <lavajoe@gentoo.org>2007-06-08 18:04:35 +0000
commit4ad2bee38456896c8a724ffa7abb849429873b2b (patch)
tree1a0c19ed8ec617ddc89d5fa6baeda2323ee705a1 /sys-apps/915resolution/915resolution-0.5.3-r1.ebuild
parentRevision bump fixes security bug 181214 (diff)
downloadgentoo-2-4ad2bee38456896c8a724ffa7abb849429873b2b.tar.gz
gentoo-2-4ad2bee38456896c8a724ffa7abb849429873b2b.tar.bz2
gentoo-2-4ad2bee38456896c8a724ffa7abb849429873b2b.zip
Port to ~x86-fbsd, keyword this arch only, fix init.d file (bug #175500)
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-apps/915resolution/915resolution-0.5.3-r1.ebuild')
-rw-r--r--sys-apps/915resolution/915resolution-0.5.3-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/915resolution/915resolution-0.5.3-r1.ebuild b/sys-apps/915resolution/915resolution-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..cbdf019b18b5
--- /dev/null
+++ b/sys-apps/915resolution/915resolution-0.5.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/915resolution/915resolution-0.5.3-r1.ebuild,v 1.1 2007/06/08 18:04:35 lavajoe Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Utility to patch VBIOS of Intel 855 / 865 / 915 chipsets"
+HOMEPAGE="http://www.geocities.com/stomljen/"
+SRC_URI="http://www.geocities.com/stomljen/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-freebsd.patch"
+}
+
+src_compile() {
+ filter-flags -O -O1 -O2 -O3 -Os
+ emake clean
+ emake CFLAGS="${CFLAGS}" || die "Compiliation failed."
+}
+
+src_install() {
+ dosbin ${PN}
+ newconfd "${FILESDIR}/confd" ${PN}
+ newinitd "${FILESDIR}/initd-r1" ${PN}
+ dodoc README.txt changes.log chipset_info.txt dump_bios
+}
+
+pkg_postinst() {
+ elog
+ elog "${PN} alters your video BIOS in a non-permanent way, this means"
+ elog "that there is no risk of permanent damage to your video card, but"
+ elog "it also means that it must be run at every boot. To set it up, "
+ elog "edit /etc/conf.d/${PN} to add your configuration and type the"
+ elog "following command to add it the your defautl runlevel:"
+ elog
+ elog " \"rc-update add ${PN} default\""
+ elog
+}