summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-07-10 02:34:32 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-07-10 02:34:32 +0000
commit619adb73b92c75f77db5624d188f5c9f76ff22e1 (patch)
tree20609b8a27b42a59dc78601cfb2f28ced3c7c24a /sec-policy
parentBump to r18 addresses openrc, portage on NFS, firefox plugins, postgres, sysl... (diff)
downloadgentoo-2-619adb73b92c75f77db5624d188f5c9f76ff22e1.tar.gz
gentoo-2-619adb73b92c75f77db5624d188f5c9f76ff22e1.tar.bz2
gentoo-2-619adb73b92c75f77db5624d188f5c9f76ff22e1.zip
Support proxy plugins and tor
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sec-policy')
-rw-r--r--sec-policy/selinux-mozilla/ChangeLog8
-rw-r--r--sec-policy/selinux-mozilla/files/fix-apps-mozilla-r3.patch74
-rw-r--r--sec-policy/selinux-mozilla/selinux-mozilla-2.20101213-r3.ebuild15
3 files changed, 96 insertions, 1 deletions
diff --git a/sec-policy/selinux-mozilla/ChangeLog b/sec-policy/selinux-mozilla/ChangeLog
index 3014c9f2224d..1c826d20f297 100644
--- a/sec-policy/selinux-mozilla/ChangeLog
+++ b/sec-policy/selinux-mozilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sec-policy/selinux-mozilla
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-mozilla/ChangeLog,v 1.4 2011/06/04 17:20:00 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-mozilla/ChangeLog,v 1.5 2011/07/10 02:34:32 blueness Exp $
+
+*selinux-mozilla-2.20101213-r3 (10 Jul 2011)
+
+ 10 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
+ +files/fix-apps-mozilla-r3.patch, +selinux-mozilla-2.20101213-r3.ebuild:
+ Support proxy plugins and tor
04 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
-selinux-mozilla-2.20101213.ebuild, -selinux-mozilla-2.20101213-r1.ebuild:
diff --git a/sec-policy/selinux-mozilla/files/fix-apps-mozilla-r3.patch b/sec-policy/selinux-mozilla/files/fix-apps-mozilla-r3.patch
new file mode 100644
index 000000000000..04d667d6bbf2
--- /dev/null
+++ b/sec-policy/selinux-mozilla/files/fix-apps-mozilla-r3.patch
@@ -0,0 +1,74 @@
+--- apps/mozilla.te 2010-12-13 15:11:01.000000000 +0100
++++ apps/mozilla.te 2011-07-03 12:35:17.181000404 +0200
+@@ -33,6 +33,10 @@
+ files_tmpfs_file(mozilla_tmpfs_t)
+ ubac_constrained(mozilla_tmpfs_t)
+
++type mozilla_tmp_t;
++files_tmp_file(mozilla_tmp_t)
++ubac_constrained(mozilla_tmp_t)
++
+ ########################################
+ #
+ # Local policy
+@@ -68,6 +72,10 @@
+ manage_sock_files_pattern(mozilla_t, mozilla_tmpfs_t, mozilla_tmpfs_t)
+ fs_tmpfs_filetrans(mozilla_t, mozilla_tmpfs_t, { file lnk_file sock_file fifo_file })
+
++manage_files_pattern(mozilla_t, mozilla_tmp_t, mozilla_tmp_t)
++manage_dirs_pattern(mozilla_t, mozilla_tmp_t, mozilla_tmp_t)
++files_tmp_filetrans(mozilla_t, mozilla_tmp_t, { file dir } )
++
+ kernel_read_kernel_sysctls(mozilla_t)
+ kernel_read_network_state(mozilla_t)
+ # Access /proc, sysctl
+@@ -89,15 +97,18 @@
+ corenet_raw_sendrecv_generic_node(mozilla_t)
+ corenet_tcp_sendrecv_http_port(mozilla_t)
+ corenet_tcp_sendrecv_http_cache_port(mozilla_t)
++corenet_tcp_sendrecv_tor_port(mozilla_t)
+ corenet_tcp_sendrecv_ftp_port(mozilla_t)
+ corenet_tcp_sendrecv_ipp_port(mozilla_t)
+ corenet_tcp_connect_http_port(mozilla_t)
+ corenet_tcp_connect_http_cache_port(mozilla_t)
++corenet_tcp_connect_tor_port(mozilla_t)
+ corenet_tcp_connect_ftp_port(mozilla_t)
+ corenet_tcp_connect_ipp_port(mozilla_t)
+ corenet_tcp_connect_generic_port(mozilla_t)
+ corenet_tcp_connect_soundd_port(mozilla_t)
+ corenet_sendrecv_http_client_packets(mozilla_t)
++corenet_sendrecv_tor_client_packets(mozilla_t)
+ corenet_sendrecv_http_cache_client_packets(mozilla_t)
+ corenet_sendrecv_ftp_client_packets(mozilla_t)
+ corenet_sendrecv_ipp_client_packets(mozilla_t)
+@@ -143,6 +154,7 @@
+
+ userdom_use_user_ptys(mozilla_t)
+
++
+ xserver_user_x_domain_template(mozilla, mozilla_t, mozilla_tmpfs_t)
+ xserver_dontaudit_read_xdm_tmp_files(mozilla_t)
+ xserver_dontaudit_getattr_xdm_tmp_sockets(mozilla_t)
+@@ -266,3 +278,7 @@
+ optional_policy(`
+ thunderbird_domtrans(mozilla_t)
+ ')
++
++optional_policy(`
++ alsa_read_rw_config(mozilla_t)
++')
+--- apps/mozilla.fc 2010-08-03 15:11:03.000000000 +0200
++++ apps/mozilla.fc 2011-01-02 22:23:34.407000019 +0100
+@@ -27,3 +27,12 @@
+ /usr/lib(64)?/[^/]*firefox[^/]*/firefox-bin -- gen_context(system_u:object_r:mozilla_exec_t,s0)
+ /usr/lib/[^/]*firefox[^/]*/firefox -- gen_context(system_u:object_r:mozilla_exec_t,s0)
+ /usr/lib64/[^/]*firefox[^/]*/firefox -- gen_context(system_u:object_r:mozilla_exec_t,s0)
++
++ifdef(`distro_gentoo',`
++/usr/bin/firefox-bin -- gen_context(system_u:object_r:mozilla_exec_t,s0)
++/opt/firefox/libxul\.so -- gen_context(system_u:object_r:textrel_shlib_t,s0)
++/opt/firefox/firefox -- gen_context(system_u:object_r:mozilla_exec_t,s0)
++/opt/firefox/run-mozilla.sh -- gen_context(system_u:object_r:mozilla_exec_t,s0)
++/opt/firefox/firefox-bin -- gen_context(system_u:object_r:mozilla_exec_t,s0)
++/opt/firefox/plugin-container -- gen_context(system_u:object_r:mozilla_exec_t,s0)
++')
diff --git a/sec-policy/selinux-mozilla/selinux-mozilla-2.20101213-r3.ebuild b/sec-policy/selinux-mozilla/selinux-mozilla-2.20101213-r3.ebuild
new file mode 100644
index 000000000000..882a163e2ff4
--- /dev/null
+++ b/sec-policy/selinux-mozilla/selinux-mozilla-2.20101213-r3.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-mozilla/selinux-mozilla-2.20101213-r3.ebuild,v 1.1 2011/07/10 02:34:32 blueness Exp $
+
+IUSE=""
+
+MODS="mozilla"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for general applications"
+
+KEYWORDS="~amd64 ~x86"
+
+POLICY_PATCH="${FILESDIR}/fix-apps-mozilla-r3.patch"