summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-08 22:02:03 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-08 22:02:03 +0000
commit7475353363a6955159d3ceefd2af9d4c5fdb2a76 (patch)
tree3a69eccd77c50f99c79eaa2f8f96b5fce8ee659b /sci-visualization
parentMarking subversion-1.6.4 ppc64 for bug 280494 (diff)
downloadgentoo-2-7475353363a6955159d3ceefd2af9d4c5fdb2a76.tar.gz
gentoo-2-7475353363a6955159d3ceefd2af9d4c5fdb2a76.tar.bz2
gentoo-2-7475353363a6955159d3ceefd2af9d4c5fdb2a76.zip
Fix building with GLIBC 2.10+ wrt #277574.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/xgraph/ChangeLog8
-rw-r--r--sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch29
-rw-r--r--sci-visualization/xgraph/xgraph-12.1-r2.ebuild3
3 files changed, 37 insertions, 3 deletions
diff --git a/sci-visualization/xgraph/ChangeLog b/sci-visualization/xgraph/ChangeLog
index 1ff00c09882b..117140c6d49c 100644
--- a/sci-visualization/xgraph/ChangeLog
+++ b/sci-visualization/xgraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/xgraph
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/ChangeLog,v 1.9 2009/02/01 12:50:16 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/ChangeLog,v 1.10 2009/08/08 22:02:03 ssuominen Exp $
+
+ 08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> xgraph-12.1-r2.ebuild,
+ +files/xgraph-12.1-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #277574.
*xgraph-12.1-r2 (01 Feb 2009)
diff --git a/sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch b/sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch
new file mode 100644
index 000000000000..e2514083c1d4
--- /dev/null
+++ b/sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch
@@ -0,0 +1,29 @@
+diff -ur xgraph-12.1.orig/dialog.c xgraph-12.1/dialog.c
+--- xgraph-12.1.orig/dialog.c 2009-08-09 01:02:01.000000000 +0300
++++ xgraph-12.1/dialog.c 2009-08-09 01:02:40.000000000 +0300
+@@ -775,7 +775,7 @@
+ memset(new_info->lines, 0, sizeof(Window) * E_LINES);
+
+ lineptr = text;
+- while (getline(&lineptr, line)) {
++ while (get_line(&lineptr, line)) {
+ if (new_info->num_lines >= new_info->alloc_lines) {
+ int old_alloc_lines_size = new_info->alloc_lines * sizeof(Window);
+ new_info->alloc_lines *= 2;
+@@ -886,7 +886,7 @@
+
+
+ int
+-getline(tptr, lptr)
++get_line(tptr, lptr)
+ char **tptr;
+ char *lptr;
+
+diff -ur xgraph-12.1.orig/dialog.h xgraph-12.1/dialog.h
+--- xgraph-12.1.orig/dialog.h 2009-08-09 01:02:01.000000000 +0300
++++ xgraph-12.1/dialog.h 2009-08-09 01:02:43.000000000 +0300
+@@ -1,3 +1,3 @@
+ extern void msg_box(char *, char *);
+-extern int getline(char **, char *);
++extern int get_line(char **, char *);
+ extern void do_error(char *);
diff --git a/sci-visualization/xgraph/xgraph-12.1-r2.ebuild b/sci-visualization/xgraph/xgraph-12.1-r2.ebuild
index b68b1e7494d1..0ae6d6e13f5f 100644
--- a/sci-visualization/xgraph/xgraph-12.1-r2.ebuild
+++ b/sci-visualization/xgraph/xgraph-12.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/xgraph-12.1-r2.ebuild,v 1.1 2009/02/01 12:50:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/xgraph-12.1-r2.ebuild,v 1.2 2009/08/08 22:02:03 ssuominen Exp $
EAPI=2
inherit eutils autotools
@@ -21,6 +21,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
eautoreconf
}