summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-19 11:52:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-19 11:52:12 +0000
commit759bc974e7b40cc44dd8f111b1ca9400c2117dea (patch)
tree3fa1b16d3222ce5bac2196f9d6bc2b1f71139f4d /sci-visualization/labplot
parentstable x86, bug 227107 (diff)
downloadgentoo-2-759bc974e7b40cc44dd8f111b1ca9400c2117dea.tar.gz
gentoo-2-759bc974e7b40cc44dd8f111b1ca9400c2117dea.tar.bz2
gentoo-2-759bc974e7b40cc44dd8f111b1ca9400c2117dea.zip
Added a patch to make it work when audiofile is not selected (bug #228165) and an init patch from Debian. Removed older versions
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-visualization/labplot')
-rw-r--r--sci-visualization/labplot/ChangeLog9
-rw-r--r--sci-visualization/labplot/files/labplot-1.6.0.1-audiofile.patch40
-rw-r--r--sci-visualization/labplot/files/labplot-1.6.0.1-init-smg.patch25
-rw-r--r--sci-visualization/labplot/labplot-1.5.1.6-r1.ebuild84
-rw-r--r--sci-visualization/labplot/labplot-1.6.0.1-r1.ebuild4
-rw-r--r--sci-visualization/labplot/labplot-1.6.0.1.ebuild104
6 files changed, 76 insertions, 190 deletions
diff --git a/sci-visualization/labplot/ChangeLog b/sci-visualization/labplot/ChangeLog
index 33b0a0ceaf2e..2bf8d1907b2e 100644
--- a/sci-visualization/labplot/ChangeLog
+++ b/sci-visualization/labplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/labplot
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/ChangeLog,v 1.20 2008/03/17 17:51:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/ChangeLog,v 1.21 2008/06/19 11:52:11 bicatali Exp $
+
+ 19 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/labplot-1.6.0.1-audiofile.patch,
+ +files/labplot-1.6.0.1-init-smg.patch, -labplot-1.5.1.6-r1.ebuild,
+ -labplot-1.6.0.1.ebuild, labplot-1.6.0.1-r1.ebuild:
+ Added a patch to make it work when audiofile is not selected (bug #228165)
+ and an init patch from Debian. Removed older versions
*labplot-1.6.0.1-r1 (17 Mar 2008)
diff --git a/sci-visualization/labplot/files/labplot-1.6.0.1-audiofile.patch b/sci-visualization/labplot/files/labplot-1.6.0.1-audiofile.patch
new file mode 100644
index 000000000000..c36420a17335
--- /dev/null
+++ b/sci-visualization/labplot/files/labplot-1.6.0.1-audiofile.patch
@@ -0,0 +1,40 @@
+--- src/ExportDialog.cc.orig 2008-06-19 12:01:25.000000000 +0100
++++ src/ExportDialog.cc 2008-06-19 12:02:44.000000000 +0100
+@@ -28,7 +28,9 @@
+ #ifdef HAVE_NETCDF
+ #include <netcdf.h>
+ #endif
++#ifdef HAVE_AUDIOFILE
+ #include <audiofile.h>
++#endif
+ #ifdef HAVE_MAGICK
+ #include <Magick++.h>
+ using namespace Magick;
+--- src/LabPlotDialog.cc.orig 2007-10-27 15:18:59.000000000 +0100
++++ src/LabPlotDialog.cc 2008-06-19 12:08:11.000000000 +0100
+@@ -14,7 +14,9 @@
+ #include <jasper/jas_config.h>
+ #endif
+
++#ifdef HAVE_AUDIOFILE
+ #include <audiofile.h>
++#endif
+
+ #ifdef HAVE_GSL
+ #include <gsl/gsl_version.h>
+@@ -186,11 +188,15 @@
+ // audiofile
+ hb = new QHBox(vbox);
+ new QLabel(i18n("audiofile library : "),hb);
++#ifdef HAVE_AUDIOFILE
+ st = QString::number(LIBAUDIOFILE_MAJOR_VERSION)+'.'+QString::number(LIBAUDIOFILE_MINOR_VERSION);
+ #ifdef LIBAUDIOFILE_MICRO_VERSION
+ st += '.'+QString::number(LIBAUDIOFILE_MICRO_VERSION);
+ #endif
+ tmp = new QLabel(st,hb);
++#else
++ tmp = new QLabel("no",hb);
++#endif
+ tmp->setAlignment(Qt::AlignRight);
+
+ // R
diff --git a/sci-visualization/labplot/files/labplot-1.6.0.1-init-smg.patch b/sci-visualization/labplot/files/labplot-1.6.0.1-init-smg.patch
new file mode 100644
index 000000000000..00bf0e7c331f
--- /dev/null
+++ b/sci-visualization/labplot/files/labplot-1.6.0.1-init-smg.patch
@@ -0,0 +1,25 @@
+--- src/MainWin.cc.orig
++++ src/MainWin.cc
+@@ -218,11 +218,6 @@ MainWin::MainWin(const char *name, const char *filen, bool is_part)
+ readScript(fn);
+ #endif
+
+- if(QFile::exists(fn) && fn.contains(".lpl"))
+- openLPL(fn);
+- else if(QFile::exists(fn) && ( fn.contains(".lml") || fn.contains(".xml") ))
+- openXML(fn);
+-
+ modified = false;
+ is_fullscreen=false;
+
+@@ -231,6 +226,10 @@ MainWin::MainWin(const char *name, const char *filen, bool is_part)
+ smg = new QSignalMapper(this);
+ connect(smg,SIGNAL(mapped(int)),this,SLOT(changeGraph(int)));
+
++ if(QFile::exists(fn) && fn.contains(".lpl"))
++ openLPL(fn);
++ else if(QFile::exists(fn) && ( fn.contains(".lml") || fn.contains(".xml") ))
++ openXML(fn);
+ }
+
+ MainWin::~MainWin() {
diff --git a/sci-visualization/labplot/labplot-1.5.1.6-r1.ebuild b/sci-visualization/labplot/labplot-1.5.1.6-r1.ebuild
deleted file mode 100644
index b3061da9199a..000000000000
--- a/sci-visualization/labplot/labplot-1.5.1.6-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.5.1.6-r1.ebuild,v 1.3 2008/03/07 03:02:44 bicatali Exp $
-
-inherit eutils kde
-
-PV_BUGFIX="${PV/?.?.?/}"
-MY_PV="${PV%${PV_BUGFIX}}"
-MY_P="LabPlot-${MY_PV}"
-S="${WORKDIR}/${MY_P}"
-
-BUGFIX="LabPlot-${MY_PV}_${PV}.diff"
-
-DESCRIPTION="LabPlot is a KDE application for data plotting and function analysis."
-HOMEPAGE="http://labplot.sourceforge.net/"
-SRC_URI="mirror://sourceforge/labplot/${MY_P}.tar.gz"
-[[ -n PV_BUGFIX ]] && SRC_URI="${SRC_URI} mirror://sourceforge/labplot/${BUGFIX}.gz"
-
-LICENSE="GPL-2"
-
-KEYWORDS="~x86 ~amd64"
-SLOT="0"
-IUSE="bindist cdf fftw imagemagick jpeg2k kexi opengl tiff"
-
-DEPEND="bindist? ( <sci-libs/gsl-1.10 )
- !bindist? ( sci-libs/gsl )
- media-gfx/pstoedit
- sci-libs/netcdf
- <sci-libs/liborigin-20080225
- virtual/ghostscript
- x11-libs/qwtplot3d-qt3
- media-libs/audiofile
- fftw? ( >=sci-libs/fftw-3 )
- imagemagick? ( media-gfx/imagemagick )
- jpeg2k? ( media-libs/jasper )
- tiff? ( media-libs/tiff )
- opengl? ( virtual/opengl )
- kexi? ( || ( app-office/kexi app-office/koffice ) )
- cdf? ( sci-libs/cdf )"
-
-RDEPEND="${DEPEND}"
-
-need-kde 3.5
-
-[[ -n PV_BUGFIX ]] && PATCHES="${WORKDIR}/${BUGFIX}"
-
-src_unpack() {
- kde_src_unpack
-
- # let's make sure we don't use included libs
- echo "# Using shared libs!" >| netcdf/netcdf.h
- echo "# Using shared libs!" >| qwtplot3d/qwt3d_plot.h
- echo "# Using shared libs!" >| audiofile/audiofile.h
-
- # sed for qwtplot3d, qt3 version (gentoo-specific)
- # (gone in versions > 2.0, with qt4)
- sed -i \
- -e 's:-lqwtplot3d:-lqwtplot3d-qt3:g' \
- -e 's:include/qwtplot3d:include/qwtplot3d-qt3:g' \
- -e 's:AC_CHECK_LIB(qwtplot3d,:AC_CHECK_LIB(qwtplot3d-qt3,:' \
- configure configure.in || die
-}
-
-src_compile() {
- export QTDIR="/usr/qt/3"
- export QWT3D_PATH="/usr"
- export KEXIDB_DIR="/usr"
-
- # texvc not in Portage and I'm not keen maintaining it
- # qsa ebuilds in bad shape atm.
- local myconf="--disable-fftw --enable-gsl --enable-ps2eps \
- --disable-texvc --disable-ocaml --enable-netcdf --enable-audiofile \
- --enable-system-qwtplot3d --enable-libundo --disable-qsa"
-
- myconf="${myconf} \
- $(use_enable fftw fftw3) \
- $(use_enable imagemagick ImageMagick) \
- $(use_enable jpeg2k jasper) \
- $(use_enable tiff) \
- $(use_enable kexi KexiDB) \
- $(use_enable opengl) \
- $(use_enable cdf)"
- kde_src_compile
-}
diff --git a/sci-visualization/labplot/labplot-1.6.0.1-r1.ebuild b/sci-visualization/labplot/labplot-1.6.0.1-r1.ebuild
index 98a22e413223..25da57c243ab 100644
--- a/sci-visualization/labplot/labplot-1.6.0.1-r1.ebuild
+++ b/sci-visualization/labplot/labplot-1.6.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.6.0.1-r1.ebuild,v 1.1 2008/03/17 17:51:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.6.0.1-r1.ebuild,v 1.2 2008/06/19 11:52:11 bicatali Exp $
inherit eutils kde multilib
@@ -37,6 +37,8 @@ RDEPEND="media-gfx/pstoedit
DEPEND="${RDEPEND}"
PATCHES="${FILESDIR}/${P}-linkexec.patch
${FILESDIR}/${P}-desktop.patch
+ ${FILESDIR}/${P}-audiofile.patch
+ ${FILESDIR}/${P}-init-smg.patch
${FILESDIR}/${P}-liborigin.patch"
need-kde 3.5
diff --git a/sci-visualization/labplot/labplot-1.6.0.1.ebuild b/sci-visualization/labplot/labplot-1.6.0.1.ebuild
deleted file mode 100644
index 0256c86cc614..000000000000
--- a/sci-visualization/labplot/labplot-1.6.0.1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.6.0.1.ebuild,v 1.3 2008/03/07 03:02:44 bicatali Exp $
-
-inherit eutils kde multilib
-
-MY_P="LabPlot-${PV}"
-
-DESCRIPTION="KDE application for data plotting and function analysis."
-HOMEPAGE="http://labplot.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="audiofile bindist cdf fftw hdf5 gsl imagemagick jpeg2k kexi
- netcdf opengl qhull R tiff"
-
-RDEPEND="media-gfx/pstoedit
- <sci-libs/liborigin-20080225
- virtual/ghostscript
- gsl? ( bindist? ( <sci-libs/gsl-1.10 ) !bindist? ( sci-libs/gsl ) )
- audiofile? ( media-libs/audiofile )
- fftw? ( >=sci-libs/fftw-3 )
- imagemagick? ( media-gfx/imagemagick )
- jpeg2k? ( media-libs/jasper )
- tiff? ( media-libs/tiff )
- opengl? ( virtual/opengl x11-libs/qwtplot3d-qt3 )
- kexi? ( || ( app-office/kexi app-office/koffice ) )
- cdf? ( sci-libs/cdf )
- netcdf? ( sci-libs/netcdf )
- hdf5? ( sci-libs/hdf5 )
- qhull? ( media-libs/qhull )
- R? ( dev-lang/R )"
-
-DEPEND="${RDEPEND}"
-PATCHES="${FILESDIR}/${P}-linkexec.patch ${FILESDIR}/${P}-desktop.patch"
-
-need-kde 3.5
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- kde_src_unpack
-
- cd "${S}"
- # let's make sure we don't use included libs
- echo "# Using shared libs!" >| netcdf/netcdf.h
- echo "# Using shared libs!" >| qwtplot3d/qwt3d_plot.h
- echo "# Using shared libs!" >| liborigin*/OPJFile.h
-
- # sed for qwtplot3d, qt3 version (gentoo-specific)
- # (should be gone when labplot using qt4)
- sed -i \
- -e 's:-lqwtplot3d:-lqwtplot3d-qt3:g' \
- -e 's:include/qwtplot3d:include/qwtplot3d-qt3:g' \
- -e 's:AC_CHECK_LIB(qwtplot3d,:AC_CHECK_LIB(qwtplot3d-qt3,:' \
- configure || die
-}
-
-src_compile() {
- export QTDIR="/usr/qt/3"
- export QWT3D_PATH="/usr"
- export KEXIDB_DIR="/usr"
- use R && export R_HOME=/usr/$(get_libdir)/R
-
- # reasons for disabling options:
- # - fftw is fftw2, so we prefer fftw3
- # - texvc external would need mediawiki (big), internal conflicts with it
- # - ocaml: only used to compile internal texvc
- # - qsa in portage tree is too buggy
- # file a bug if you have workarounds
- local myconf="
- --disable-fftw
- --disable-texvc
- --disable-ocaml
- --disable-qsa
- --enable-ps2eps
- --enable-system-liborigin
- $(use_enable audiofile)
- $(use_enable fftw fftw3)
- $(use_enable gsl)
- $(use_enable imagemagick ImageMagick)
- $(use_enable jpeg2k jasper)
- $(use_enable tiff)
- $(use_enable kexi KexiDB)
- $(use_enable cdf)
- $(use_enable hdf5)
- $(use_enable netcdf)
- $(use_enable netcdf system-netcdf)
- $(use_enable opengl gl)
- $(use_enable opengl system-qwtplot3d)
- $(use_enable qhull)
- $(use_enable R)"
-
- kde_src_compile
-}
-
-src_install() {
- kde_src_install
- dodoc BUGS* WISHLIST CHANGES FEATURES \
- TIPS PLAN CREDITS || die
-}