summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-13 16:01:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-13 16:01:30 +0000
commit1fad0bfe3decf4943f45dc716d03e35be8e5e251 (patch)
tree19b76a24ef1f31f757bf7da6e44bf9fc4babc5aa /sci-visualization/gwyddion
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-1fad0bfe3decf4943f45dc716d03e35be8e5e251.tar.gz
gentoo-2-1fad0bfe3decf4943f45dc716d03e35be8e5e251.tar.bz2
gentoo-2-1fad0bfe3decf4943f45dc716d03e35be8e5e251.zip
Version bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/gwyddion')
-rw-r--r--sci-visualization/gwyddion/ChangeLog8
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.12.ebuild4
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.14.ebuild74
-rw-r--r--sci-visualization/gwyddion/metadata.xml30
4 files changed, 99 insertions, 17 deletions
diff --git a/sci-visualization/gwyddion/ChangeLog b/sci-visualization/gwyddion/ChangeLog
index 23d0eafb0338..8f555c913367 100644
--- a/sci-visualization/gwyddion/ChangeLog
+++ b/sci-visualization/gwyddion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/gwyddion
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.16 2009/02/01 12:16:54 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.17 2009/04/13 16:01:30 bicatali Exp $
+
+*gwyddion-2.14 (13 Apr 2009)
+
+ 13 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ gwyddion-2.12.ebuild, +gwyddion-2.14.ebuild:
+ Version bump
*gwyddion-2.12 (30 Jan 2009)
diff --git a/sci-visualization/gwyddion/gwyddion-2.12.ebuild b/sci-visualization/gwyddion/gwyddion-2.12.ebuild
index 1fea918cc2cd..872f65a1df6b 100644
--- a/sci-visualization/gwyddion/gwyddion-2.12.ebuild
+++ b/sci-visualization/gwyddion/gwyddion-2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.12.ebuild,v 1.2 2009/02/01 21:25:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.12.ebuild,v 1.3 2009/04/13 16:01:30 bicatali Exp $
EAPI=2
inherit fdo-mime gnome2-utils
@@ -12,7 +12,7 @@ SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc fftw gnome kde nls opengl perl python ruby sourceview tiff xml"
+IUSE="doc fftw gnome kde nls opengl perl python ruby sourceview tiff xml X"
RDEPEND=">=x11-libs/gtk+-2.8
x11-libs/cairo
diff --git a/sci-visualization/gwyddion/gwyddion-2.14.ebuild b/sci-visualization/gwyddion/gwyddion-2.14.ebuild
new file mode 100644
index 000000000000..7710cdf13c03
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.14.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.14.ebuild,v 1.1 2009/04/13 16:01:30 bicatali Exp $
+
+EAPI=2
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="A software framework for SPM data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fftw gnome kde nls opengl perl python ruby sourceview tiff xml X"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/libXmu
+ fftw? ( >=sci-libs/fftw-3 )
+ gnome? ( gnome-base/gconf )
+ kde? ( >=kde-base/kdelibs-4 )
+ opengl? ( virtual/opengl x11-libs/gtkglext )
+ perl? ( dev-lang/perl )
+ python? ( dev-python/pygtk )
+ ruby? ( dev-ruby/narray )
+ sourceview? ( >=x11-libs/gtksourceview-2 )
+ tiff? ( media-libs/tiff )
+ xml? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --disable-desktop-file-update \
+ --disable-rpath \
+ --enable-library-bloat \
+ --enable-plugin-proxy \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls) \
+ $(use_enable python pygwy) \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with ruby) \
+ $(use_with fftw fftw3) \
+ $(use_with opengl gl) \
+ $(use_with sourceview gtksourceview) \
+ $(use_with tiff) \
+ $(use_with xml spml) \
+ $(use_with X x) \
+ $(use_with kde kde4-thumbnailer)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ use python && dodoc modules/pygwy/README.pygwy
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-visualization/gwyddion/metadata.xml b/sci-visualization/gwyddion/metadata.xml
index 9c631024fce7..f394568ab5a9 100644
--- a/sci-visualization/gwyddion/metadata.xml
+++ b/sci-visualization/gwyddion/metadata.xml
@@ -1,18 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>cryos@gentoo.org</email>
- </maintainer>
- <longdescription>
- Gwyddion is a modular program for SPM data analysis. Primarily it is
- supposed to be used for analysis of height fields obtained by means of
- scanning probe microscopy techniques (AFM, MFM, STM, NSOM), but
- generally it can be used for any other height field analysis or
- image analysis.
- </longdescription>
- <use>
- <flag name="sourceview">Enable support for <pkg>x11-libs/gtksourceview</pkg></flag>
- </use>
+<herd>sci</herd>
+<maintainer>
+ <email>cryos@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ Gwyddion is a modular program for SPM data analysis. Primarily it is
+ supposed to be used for analysis of height fields obtained by means of
+ scanning probe microscopy techniques (AFM, MFM, STM, NSOM), but
+ generally it can be used for any other height field analysis or
+ image analysis.
+</longdescription>
+<use>
+ <flag name="sourceview">
+ Enable support for <pkg>x11-libs/gtksourceview</pkg>
+ </flag>
+</use>
</pkgmetadata>