summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-17 14:37:32 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-17 14:37:32 +0000
commit96acca1190cf5d9b1c8b5968ffd04f2c5b81e289 (patch)
tree5b92c92338ac20328de75ebad1eae5f2b9072721 /sci-visualization/gle
parentBumping to rev14, initial release to support /run directories (diff)
downloadgentoo-2-96acca1190cf5d9b1c8b5968ffd04f2c5b81e289.tar.gz
gentoo-2-96acca1190cf5d9b1c8b5968ffd04f2c5b81e289.tar.bz2
gentoo-2-96acca1190cf5d9b1c8b5968ffd04f2c5b81e289.zip
sci-visualization/gle: Fix for gcc-4.7, #426978
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/gle')
-rw-r--r--sci-visualization/gle/ChangeLog6
-rw-r--r--sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch62
-rw-r--r--sci-visualization/gle/gle-4.2.4b.ebuild6
3 files changed, 71 insertions, 3 deletions
diff --git a/sci-visualization/gle/ChangeLog b/sci-visualization/gle/ChangeLog
index e8d2db174aa2..aee77bcdd52e 100644
--- a/sci-visualization/gle/ChangeLog
+++ b/sci-visualization/gle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/gle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.19 2012/03/10 21:00:53 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.20 2012/07/17 14:37:31 jlec Exp $
+
+ 17 Jul 2012; Justin Lecher <jlec@gentoo.org> gle-4.2.4b.ebuild,
+ +files/gle-4.2.4b-gcc-4.7.patch:
+ Fix for gcc-4.7, #426978
10 Mar 2012; Andrey Grozin <grozin@gentoo.org> -gle-4.2.4.ebuild,
-files/gle-4.2.4-parallel.patch, -files/gle-4.2.4-qt-4.8.patch,
diff --git a/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch b/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch
new file mode 100644
index 000000000000..1a0c3a4f42c5
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch
@@ -0,0 +1,62 @@
+ src/gle/gle-interface/gle-base.h | 4 ++--
+ src/gle/tokens/RefCount.h | 2 +-
+ src/gle/tokens/StringKeyHash.h | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/gle/gle-interface/gle-base.h b/src/gle/gle-interface/gle-base.h
+index 26ce8f3..686c2df 100644
+--- a/src/gle/gle-interface/gle-base.h
++++ b/src/gle/gle-interface/gle-base.h
+@@ -130,7 +130,7 @@ inline GLERefCountObject* GLE_SET_RC(GLERefCountObject* rc, GLERefCountObject* v
+
+ template <class T> class GLERCVector : public vector< GLERC<T> > {
+ public:
+- inline void add(T* elem) { push_back(GLERC<T>(elem)); }
++ inline void add(T* elem) { this->push_back(GLERC<T>(elem)); }
+ inline T* get(int i) { return (*this)[i].get(); }
+ };
+
+@@ -147,7 +147,7 @@ public:
+ }
+ void deleteAll() {
+ for (typename vector<T*>::size_type i = 0; i < vector<T*>::size(); i++) {
+- T* elem = at(i);
++ T* elem = this->at(i);
+ if (elem != NULL) delete elem;
+ }
+ }
+diff --git a/src/gle/tokens/RefCount.h b/src/gle/tokens/RefCount.h
+index eef1824..d43540b 100644
+--- a/src/gle/tokens/RefCount.h
++++ b/src/gle/tokens/RefCount.h
+@@ -125,7 +125,7 @@ public:
+ template <class T> class MutableRefCountPtr : public RefCountPtr<T> {
+ public:
+ inline RefCountPtr<T>& operator =(RefCountPtr<T> src) {
+- setPtr(src.get()); return *this;
++ this->setPtr(src.get()); return *this;
+ };
+ };
+
+diff --git a/src/gle/tokens/StringKeyHash.h b/src/gle/tokens/StringKeyHash.h
+index 7db46c3..0966676 100644
+--- a/src/gle/tokens/StringKeyHash.h
++++ b/src/gle/tokens/StringKeyHash.h
+@@ -254,7 +254,7 @@ public:
+ return i->second;
+ } else {
+ ElemType nelem(key);
+- insert(StringKeyPair<ElemType>(key, nelem));
++ this->insert(StringKeyPair<ElemType>(key, nelem));
+ return nelem;
+ }
+ }
+@@ -309,7 +309,7 @@ public:
+ }
+
+ void add_item(int key, ElemType elem) {
+- insert(IntKeyPair<ElemType>(key, elem));
++ this->insert(IntKeyPair<ElemType>(key, elem));
+ }
+ };
+
diff --git a/sci-visualization/gle/gle-4.2.4b.ebuild b/sci-visualization/gle/gle-4.2.4b.ebuild
index 663b8331fb18..706018b943d9 100644
--- a/sci-visualization/gle/gle-4.2.4b.ebuild
+++ b/sci-visualization/gle/gle-4.2.4b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.4b.ebuild,v 1.1 2012/03/09 08:24:20 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.4b.ebuild,v 1.2 2012/07/17 14:37:31 jlec Exp $
EAPI=4
inherit eutils elisp-common qt4-r2 flag-o-matic autotools
@@ -33,7 +33,9 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/${MY_P}
src_prepare() {
- epatch "${FILESDIR}"/${P}-parallel.patch
+ epatch \
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
eaclocal
eautoconf
}