summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-08 17:32:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-08 17:32:24 +0000
commite5bb05a015e798be9e9252f0d00aab4fe11c872f (patch)
treefcccf9dc49d627a825c39c412f28bb9268794cd1 /sci-physics
parentSet SUPPORT_PYTHON_ABIS (bug #353762). Fix dependencies. Fix installation wit... (diff)
downloadgentoo-2-e5bb05a015e798be9e9252f0d00aab4fe11c872f.tar.gz
gentoo-2-e5bb05a015e798be9e9252f0d00aab4fe11c872f.tar.bz2
gentoo-2-e5bb05a015e798be9e9252f0d00aab4fe11c872f.zip
Added LD_LIBRARY_PATH for the tests to make sure it loads the correct library
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/ChangeLog5
-rw-r--r--sci-physics/pythia/pythia-8.1.45.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index b39bda76e730..3251b7c87e1d 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.33 2011/01/18 17:08:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.34 2011/02/08 17:32:24 bicatali Exp $
+
+ 08 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> pythia-8.1.45.ebuild:
+ Added LD_LIBRARY_PATH for the tests to make sure it loads the correct library
18 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> -pythia-6.4.23.ebuild,
-pythia-8.1.08-r1.ebuild, -pythia-8.1.42.ebuild:
diff --git a/sci-physics/pythia/pythia-8.1.45.ebuild b/sci-physics/pythia/pythia-8.1.45.ebuild
index df37efcf3c07..c27cb1b13d05 100644
--- a/sci-physics/pythia/pythia-8.1.45.ebuild
+++ b/sci-physics/pythia/pythia-8.1.45.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.45.ebuild,v 1.1 2010/11/20 08:25:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.45.ebuild,v 1.2 2011/02/08 17:32:24 bicatali Exp $
EAPI=2
@@ -52,12 +52,15 @@ src_test() {
$(ls main0{1..9}*.cc | sed -e 's/.cc//') \
|| die "emake tests failed"
for i in main0{1..9}*.exe; do
- ./${i} > ${i}.out || die "test ${i} failed"
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./${i} > ${i}.out || die "test ${i} failed"
done
if use hepmc; then
emake main31 main32 || die "emake tests for hepmc failed"
- ./main31.exe > main31.exe.out || die
- ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./main31.exe > main31.exe.out || die
+ LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
fi
emake clean && rm -f main*out
}