summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-06-24 04:13:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-06-24 04:13:58 +0000
commit9705306d96f266f4c107cabb73410ee854dea8dd (patch)
tree96a6b1fe60a1963ad02b6b7e578247656d67b67f /sci-physics
parentVersion bump. (diff)
downloadgentoo-2-9705306d96f266f4c107cabb73410ee854dea8dd.tar.gz
gentoo-2-9705306d96f266f4c107cabb73410ee854dea8dd.tar.bz2
gentoo-2-9705306d96f266f4c107cabb73410ee854dea8dd.zip
Version bump, thanks Ben Bannier for testing, closing bug #274969
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/ChangeLog8
-rw-r--r--sci-physics/pythia/pythia-8.1.25.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 9b802064c264..79946fcd6dcc 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.11 2009/05/05 19:42:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.12 2009/06/24 04:13:58 bicatali Exp $
+
+*pythia-8.1.25 (24 Jun 2009)
+
+ 24 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +pythia-8.1.25.ebuild:
+ Version bump, thanks Ben Bannier for testing, closing bug #274969
05 May 2009; Christian Faulhammer <fauli@gentoo.org>
pythia-8.1.08-r1.ebuild:
diff --git a/sci-physics/pythia/pythia-8.1.25.ebuild b/sci-physics/pythia/pythia-8.1.25.ebuild
new file mode 100644
index 000000000000..2b324db1c3c9
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.25.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.25.ebuild,v 1.1 2009/06/24 04:13:58 bicatali Exp $
+
+EAPI=1
+
+inherit eutils versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples +hepmc"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION=/usr
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk && touch config.mk
+ emake SHAREDLIBS=yes LDFLAGSSHARED="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ cd "${S}"/examples
+ # use emake for parallel instead of long runmains
+ emake \
+ $(ls main0{1..9}*.cc main1{0..5}*.cc | sed -e 's/.cc//') \
+ || die "emake tests failed"
+ for i in main0{1..9}*.exe main1{0..5}*.exe; do
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31 main32 || die "emake tests for hepmc failed"
+ ./main31.exe > main31.exe.out || die
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so || die "shared lib install failed"
+ dolib.a lib/archive/* || die "static lib install failed"
+
+ insinto /usr/include/${PN}
+ doins include/* || die "headers install failed"
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc || die "xmldoc install failed"
+ echo PYTHIA8DATA=/usr/share/${PN}/xmldoc >> 99pythia8
+ doenvd 99pythia8
+
+ insinto /usr/share/doc/${PF}
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ doins worksheet.pdf || die "doc install failed"
+ mv htmldoc html
+ doins -r html || die "html doc install failed"
+ fi
+ if use examples; then
+ doins -r examples || die "examples install failed"
+ fi
+}