summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-10-30 17:17:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-10-30 17:17:34 +0000
commit6434a2b752f211a01538933d0e19ce653e0d30a3 (patch)
treee8188360b8fb5cea4e0532bfecfa6cf3c8269fad /sci-physics
parentVersion bump, switch to EAPI5 and python-r1, fixing bug #488698 (diff)
downloadgentoo-2-6434a2b752f211a01538933d0e19ce653e0d30a3.tar.gz
gentoo-2-6434a2b752f211a01538933d0e19ce653e0d30a3.tar.bz2
gentoo-2-6434a2b752f211a01538933d0e19ce653e0d30a3.zip
Major version bump
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lhapdf/ChangeLog7
-rw-r--r--sci-physics/lhapdf/lhapdf-6.0.4.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index baa1debf2956..41ffbd6b821b 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/lhapdf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.22 2013/10/30 17:16:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.23 2013/10/30 17:17:34 bicatali Exp $
+
+*lhapdf-6.0.4 (30 Oct 2013)
+
+ 30 Oct 2013; Sébastien Fabbro <bicatali@gentoo.org> +lhapdf-6.0.4.ebuild:
+ Major version bump
*lhapdf-5.9.1 (30 Oct 2013)
diff --git a/sci-physics/lhapdf/lhapdf-6.0.4.ebuild b/sci-physics/lhapdf/lhapdf-6.0.4.ebuild
new file mode 100644
index 000000000000..b699cae0809a
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-6.0.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-6.0.4.ebuild,v 1.1 2013/10/30 17:17:34 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit versionator autotools-utils distutils-r1
+
+MY_PV=$(get_version_component_range 1-3 ${PV})
+MY_PF=LHAPDF-${MY_PV}
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://projects.hepforge.org/lhapdf/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost
+ dev-cpp/yaml-cpp
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )"
+
+S="${WORKDIR}/${MY_PF}"
+
+src_configure() {
+ autotools-utils_src_configure $(use_enable python)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo doxy)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ autotools-utils_src_compile -C tests
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r doc/doxygen/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cc
+ fi
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_install
+ fi
+}
+
+
+pkg_postinst() {
+ elog "To install data files, download them into ${EROOT%/}/usr/share/LHAPDF:"
+ elog "http://www.hepforge.org/archive/${PN}/pdfsets/${PV}"
+}