summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-07 19:34:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-07 19:34:02 +0000
commitd89e1528d63999eefaa837995d26bdca6599802e (patch)
tree43949f41c385fe1e6d1fe4e918f8d573b6941b7e /sci-physics/hepmc
parentStable for HPPA PPC (bug #353652). (diff)
downloadgentoo-2-d89e1528d63999eefaa837995d26bdca6599802e.tar.gz
gentoo-2-d89e1528d63999eefaa837995d26bdca6599802e.tar.bz2
gentoo-2-d89e1528d63999eefaa837995d26bdca6599802e.zip
Version bum with prefixazation
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/ChangeLog7
-rw-r--r--sci-physics/hepmc/hepmc-2.06.04.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
index 48040833b434..6f8c4b18921b 100644
--- a/sci-physics/hepmc/ChangeLog
+++ b/sci-physics/hepmc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/hepmc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.20 2011/01/18 16:45:55 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.21 2011/02/07 19:34:02 bicatali Exp $
+
+*hepmc-2.06.04 (07 Feb 2011)
+
+ 07 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +hepmc-2.06.04.ebuild:
+ Version bum with prefixazation
18 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> -hepmc-2.06.01.ebuild,
hepmc-2.06.03.ebuild:
diff --git a/sci-physics/hepmc/hepmc-2.06.04.ebuild b/sci-physics/hepmc/hepmc-2.06.04.ebuild
new file mode 100644
index 000000000000..d09a675c1ef9
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.06.04.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.04.ebuild,v 1.1 2011/02/07 19:34:02 bicatali Exp $
+
+EAPI=3
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://savannah.cern.ch/projects/hepmc/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples gev cm static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ # use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ econf \
+ --with-length=${length_conf} \
+ --with-momentum=${momentum_conf} \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd doc
+ doxygen doxygen.conf || die "doc building failed"
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ INSTALLDIR="${EPREFIX}/usr/share/doc/${PF}/examples" \
+ doc_installdir="${EPREFIX}/usr/share/doc/${PF}" \
+ install || die "emake install failed"
+
+ dodoc README AUTHORS ChangeLog
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r doc/html doc/*.pdf || die
+ else
+ rm -f "${ED}"/usr/share/doc/${PF}/*pdf
+ fi
+ use examples || rm -rf "${ED}"/usr/share/doc/${PF}/examples
+}