summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-30 21:59:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-30 21:59:52 +0000
commitd81599f57b2c0d249848bae3b589c7572c0b8394 (patch)
treee5f9715ca780e45822fce399bae4bd3fa3683aee /sci-physics/clhep
parentStable for amd64, wrt bug #445095 (diff)
downloadgentoo-2-d81599f57b2c0d249848bae3b589c7572c0b8394.tar.gz
gentoo-2-d81599f57b2c0d249848bae3b589c7572c0b8394.tar.bz2
gentoo-2-d81599f57b2c0d249848bae3b589c7572c0b8394.zip
Version bump. Fixed parallel doc building (bug #437482) and doc installation directory
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics/clhep')
-rw-r--r--sci-physics/clhep/ChangeLog9
-rw-r--r--sci-physics/clhep/clhep-2.1.2.4.ebuild10
-rw-r--r--sci-physics/clhep/clhep-2.1.3.1.ebuild (renamed from sci-physics/clhep/clhep-2.1.2.3.ebuild)12
3 files changed, 27 insertions, 4 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index e4866d29e5c7..669e19af0b79 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.43 2012/08/14 20:17:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.44 2012/11/30 21:59:52 bicatali Exp $
+
+*clhep-2.1.3.1 (30 Nov 2012)
+
+ 30 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> +clhep-2.1.3.1.ebuild,
+ -clhep-2.1.2.3.ebuild, clhep-2.1.2.4.ebuild:
+ Version bump. Fixed parallel doc building (bug #437482) and doc installation
+ directory
14 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+files/clhep-2.1.2.4-lsb-whitespace.patch, clhep-2.1.2.4.ebuild:
diff --git a/sci-physics/clhep/clhep-2.1.2.4.ebuild b/sci-physics/clhep/clhep-2.1.2.4.ebuild
index 495d8601f355..adc252072fd5 100644
--- a/sci-physics/clhep/clhep-2.1.2.4.ebuild
+++ b/sci-physics/clhep/clhep-2.1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.1.2.4.ebuild,v 1.2 2012/08/14 20:17:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.1.2.4.ebuild,v 1.3 2012/11/30 21:59:52 bicatali Exp $
EAPI=4
@@ -25,6 +25,14 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-lsb-whitespace.patch
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # no batch mode to allow parallel building (bug #437482)
+ sed -i \
+ -e 's:-interaction=batchmode::g' \
+ cmake/Modules/ClhepBuildTex.cmake || die
+ # gentoo doc directory
+ sed -i \
+ -e "/DESTINATION/s:doc:share/doc/${PF}:" \
+ cmake/Modules/ClhepBuildTex.cmake */doc/CMakeLists.txt || die
# dont build test if not asked
if ! use test; then
sed -i \
diff --git a/sci-physics/clhep/clhep-2.1.2.3.ebuild b/sci-physics/clhep/clhep-2.1.3.1.ebuild
index 9760f1fcd507..bbe047cccbc3 100644
--- a/sci-physics/clhep/clhep-2.1.2.3.ebuild
+++ b/sci-physics/clhep/clhep-2.1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.1.2.3.ebuild,v 1.1 2012/06/28 00:31:06 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.1.3.1.ebuild,v 1.1 2012/11/30 21:59:52 bicatali Exp $
EAPI=4
@@ -21,9 +21,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
- epatch "${FILESDIR}"/${P}-libdir.patch
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # no batch mode to allow parallel building (bug #437482)
+ sed -i \
+ -e 's:-interaction=batchmode::g' \
+ cmake/Modules/ClhepBuildTex.cmake || die
+ # gentoo doc directory
+ sed -i \
+ -e "/DESTINATION/s:doc:share/doc/${PF}:" \
+ cmake/Modules/ClhepBuildTex.cmake */doc/CMakeLists.txt || die
# dont build test if not asked
if ! use test; then
sed -i \
@@ -38,6 +45,7 @@ src_configure() {
$(cmake-utils_use doc CLHEP_BUILD_DOCS)
)
DESTDIR="${ED}" cmake-utils_src_configure
+ use doc && MAKEOPTS+=" -j1"
}
src_install() {