summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-07-10 13:14:38 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-07-10 13:14:38 +0000
commitf7d8ea6fb4bc445ad4bcbafc8dc08953faeadd6d (patch)
tree40ff7f3d6482a9f922437f4ec083003a30f853a3 /sci-misc
parentMark 1.0.1 stable on ia64 (diff)
downloadgentoo-2-f7d8ea6fb4bc445ad4bcbafc8dc08953faeadd6d.tar.gz
gentoo-2-f7d8ea6fb4bc445ad4bcbafc8dc08953faeadd6d.tar.bz2
gentoo-2-f7d8ea6fb4bc445ad4bcbafc8dc08953faeadd6d.zip
Version bump, closes bug 135309.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog7
-rw-r--r--sci-misc/boinc/boinc-5.5.6.ebuild93
-rw-r--r--sci-misc/boinc/files/digest-boinc-4.72.20050813-r32
-rw-r--r--sci-misc/boinc/files/digest-boinc-5.2.144
-rw-r--r--sci-misc/boinc/files/digest-boinc-5.5.63
5 files changed, 108 insertions, 1 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index b213e9162b62..10319eeb07ff 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.21 2006/04/23 03:14:58 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.22 2006/07/10 13:14:38 cryos Exp $
+
+*boinc-5.5.6 (10 Jul 2006)
+
+ 10 Jul 2006; Marcus D. Hanwell <cryos@gentoo.org> +boinc-5.5.6.ebuild:
+ Version bump, closes bug 135309.
23 Apr 2006; Thomas Cort <tcort@gentoo.org> boinc-4.72.20050813-r3.ebuild:
Added ~alpha keyword wrt Bug #103250.
diff --git a/sci-misc/boinc/boinc-5.5.6.ebuild b/sci-misc/boinc/boinc-5.5.6.ebuild
new file mode 100644
index 000000000000..67ca9816f9f6
--- /dev/null
+++ b/sci-misc/boinc/boinc-5.5.6.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.1 2006/07/10 13:14:38 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="mirror://gentoo//${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X"
+
+RDEPEND="sys-libs/zlib
+ >=net-misc/curl-7.15.0
+ >=dev-libs/openssl-0.9.7
+ X? ( >=x11-libs/wxGTK-2.6.2 )
+ server? ( net-www/apache
+ >=dev-db/mysql-4.0.24
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.59
+ >=sys-devel/automake-1.9.3
+ X? ( || ( ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto )
+ virtual/x11 )
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # point to a proper mouse device
+ sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
+}
+
+src_compile() {
+ ./_autosetup || die "autosetup failed."
+ econf \
+ --enable-client \
+ --disable-static-client \
+ --with-wx-config=$(which wx-config-2.6) \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ # Make it link to the compiled libs, not the installed ones
+ sed -e "s|LDFLAGS = |LDFLAGS = -L../lib |g" -i */Makefile || \
+ die "sed failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ einfo "If you need to use the graphical client the password is in "
+ einfo "/var/lib/boinc/gui_rpc_auth.cfg which is randomly generated "
+ einfo "by BOINC. You can change this to something more memorable."
+ echo
+}
diff --git a/sci-misc/boinc/files/digest-boinc-4.72.20050813-r3 b/sci-misc/boinc/files/digest-boinc-4.72.20050813-r3
index 0a456c0d3bf4..55e46bfc29ab 100644
--- a/sci-misc/boinc/files/digest-boinc-4.72.20050813-r3
+++ b/sci-misc/boinc/files/digest-boinc-4.72.20050813-r3
@@ -1 +1,3 @@
MD5 af114631d61e117de9bafa197864a8ff boinc_public-cvs-2005-08-13.tar.gz 6054534
+RMD160 2585effd13c1b6e093141dbc34bebd770c6041be boinc_public-cvs-2005-08-13.tar.gz 6054534
+SHA256 3a8b7f3d462a0fa5f1d0ad14c77f790a3cf12b1237a09636cd82b9bfefc2afb7 boinc_public-cvs-2005-08-13.tar.gz 6054534
diff --git a/sci-misc/boinc/files/digest-boinc-5.2.14 b/sci-misc/boinc/files/digest-boinc-5.2.14
index 4836dea7c99a..9ff48b3a72b0 100644
--- a/sci-misc/boinc/files/digest-boinc-5.2.14
+++ b/sci-misc/boinc/files/digest-boinc-5.2.14
@@ -1,2 +1,6 @@
MD5 96ba7e3382b64cf80f6713abe0c6b60a boinc-5.2.14-patches.tar.bz2 8906
+RMD160 9cf31b1cb2f9744aaf931fd718349b8e9d2c9434 boinc-5.2.14-patches.tar.bz2 8906
+SHA256 b70fbb66d24226f59c0f97456bc5d264a22cd20295c320b0f5f33a712ef4aee6 boinc-5.2.14-patches.tar.bz2 8906
MD5 538f67a6c1343b13537a066664f210d7 boinc-5.2.14.tar.bz2 6493301
+RMD160 e5a87514c9a1062d5b777c2ab008b3d253ccfe80 boinc-5.2.14.tar.bz2 6493301
+SHA256 54625d44535534094e85d41172c3c30a12d114f074ac8dcbca07372c4d7c484d boinc-5.2.14.tar.bz2 6493301
diff --git a/sci-misc/boinc/files/digest-boinc-5.5.6 b/sci-misc/boinc/files/digest-boinc-5.5.6
new file mode 100644
index 000000000000..ca9c6f9c0bf7
--- /dev/null
+++ b/sci-misc/boinc/files/digest-boinc-5.5.6
@@ -0,0 +1,3 @@
+MD5 ac4eac82918a2697c0757adda2a8fbda boinc-5.5.6.tar.bz2 9211643
+RMD160 f1fc9405184146bce972002332b6271ab6940849 boinc-5.5.6.tar.bz2 9211643
+SHA256 a23b01016c3c6664ad1ec21b8731a4a2648b47a8ceac8bcc13f09f86af017194 boinc-5.5.6.tar.bz2 9211643