summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-19 07:49:23 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-19 07:49:23 +0000
commitb7d11b2adb63808341f8413c44e7c3d7934965b1 (patch)
tree8f18e007c76bb13a6f5deca8de194e8ad7f4ae68 /sci-misc
parentVersion bump. (diff)
downloadgentoo-2-b7d11b2adb63808341f8413c44e7c3d7934965b1.tar.gz
gentoo-2-b7d11b2adb63808341f8413c44e7c3d7934965b1.tar.bz2
gentoo-2-b7d11b2adb63808341f8413c44e7c3d7934965b1.zip
Use wxwidgets.eclass.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog7
-rw-r--r--sci-misc/boinc/boinc-4.72.20050813-r3.ebuild14
-rw-r--r--sci-misc/boinc/boinc-5.2.14.ebuild18
-rw-r--r--sci-misc/boinc/boinc-5.4.11.ebuild18
-rw-r--r--sci-misc/boinc/boinc-5.5.6.ebuild18
-rw-r--r--sci-misc/boinc/boinc-5.8.15.ebuild19
6 files changed, 73 insertions, 21 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 272ef95c3a05..285ecc2e69ce 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.31 2007/03/27 05:29:11 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.32 2007/05/19 07:49:23 dirtyepic Exp $
+
+ 19 May 2007; Ryan Hill <dirtyepic@gentoo.org>
+ boinc-4.72.20050813-r3.ebuild, boinc-5.2.14.ebuild, boinc-5.4.11.ebuild,
+ boinc-5.5.6.ebuild, boinc-5.8.15.ebuild:
+ Use wxwidgets.eclass.
*boinc-5.8.15 (27 Mar 2007)
diff --git a/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
index c9bb104f2ebe..8d09bcf82816 100644
--- a/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
+++ b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild,v 1.6 2007/03/13 00:34:19 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild,v 1.7 2007/05/19 07:49:23 dirtyepic Exp $
-inherit eutils
+inherit eutils wxwidgets
MY_PN="boinc_public-cvs"
MY_PV="2005-08-13"
@@ -18,7 +18,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE="server X"
RDEPEND="sys-libs/zlib
- X? ( >=x11-libs/wxGTK-2.6.1 )
+ X? ( =x11-libs/wxGTK-2.6* )
server? ( net-www/apache
>=virtual/mysql-4.0
virtual/php
@@ -50,10 +50,16 @@ src_unpack() {
}
src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ need-wxwidgets gtk2
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
econf \
--enable-client \
--disable-static-client \
- --with-wx-config=$(type -P wx-config-2.6) \
+ ${wxconf} \
$(use_enable server) \
$(use_with X x) || die "econf failed"
emake || die "emake failed"
diff --git a/sci-misc/boinc/boinc-5.2.14.ebuild b/sci-misc/boinc/boinc-5.2.14.ebuild
index cd634c07bde8..47e446ece7c0 100644
--- a/sci-misc/boinc/boinc-5.2.14.ebuild
+++ b/sci-misc/boinc/boinc-5.2.14.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.8 2007/03/13 00:34:19 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.9 2007/05/19 07:49:23 dirtyepic Exp $
-inherit eutils
+inherit eutils wxwidgets
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
@@ -17,7 +17,7 @@ IUSE="server X unicode"
RDEPEND="sys-libs/zlib
>=net-misc/curl-7.15.0
>=dev-libs/openssl-0.9.7
- X? ( >=x11-libs/wxGTK-2.6.2 )
+ X? ( =x11-libs/wxGTK-2.6* )
server? ( net-www/apache
>=virtual/mysql-4.0
virtual/php
@@ -51,10 +51,20 @@ src_unpack() {
}
src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
econf \
--enable-client \
--disable-static-client \
- --with-wx-config=$(type -P wx-config-2.6) \
+ ${wxconf} \
$(use_enable unicode) \
$(use_enable server) \
$(use_with X x) || die "econf failed"
diff --git a/sci-misc/boinc/boinc-5.4.11.ebuild b/sci-misc/boinc/boinc-5.4.11.ebuild
index 44698fbf2f65..c900787e0af2 100644
--- a/sci-misc/boinc/boinc-5.4.11.ebuild
+++ b/sci-misc/boinc/boinc-5.4.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.4.11.ebuild,v 1.3 2007/03/13 00:34:19 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.4.11.ebuild,v 1.4 2007/05/19 07:49:23 dirtyepic Exp $
-inherit eutils
+inherit eutils wxwidgets
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
@@ -16,7 +16,7 @@ IUSE="server X unicode"
RDEPEND="sys-libs/zlib
>=net-misc/curl-7.15.0
>=dev-libs/openssl-0.9.7
- X? ( >=x11-libs/wxGTK-2.6.2 )
+ X? ( =x11-libs/wxGTK-2.6* )
server? ( net-www/apache
>=virtual/mysql-4.0
virtual/php
@@ -47,10 +47,20 @@ src_unpack() {
}
src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
econf \
--enable-client \
--disable-static-client \
- --with-wx-config=$(type -P wx-config-2.6) \
+ ${wxconf} \
$(use_enable unicode) \
$(use_enable server) \
$(use_with X x) || die "econf failed"
diff --git a/sci-misc/boinc/boinc-5.5.6.ebuild b/sci-misc/boinc/boinc-5.5.6.ebuild
index 221266e7e29c..dcc07174f423 100644
--- a/sci-misc/boinc/boinc-5.5.6.ebuild
+++ b/sci-misc/boinc/boinc-5.5.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.6 2007/03/13 00:34:19 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.7 2007/05/19 07:49:23 dirtyepic Exp $
-inherit eutils
+inherit eutils wxwidgets
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
@@ -16,7 +16,7 @@ IUSE="server X unicode"
RDEPEND="sys-libs/zlib
>=net-misc/curl-7.15.0
>=dev-libs/openssl-0.9.7
- X? ( >=x11-libs/wxGTK-2.6.2 )
+ X? ( =x11-libs/wxGTK-2.6* )
server? ( net-www/apache
>=virtual/mysql-4.0
virtual/php
@@ -47,6 +47,16 @@ src_unpack() {
}
src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
# Just run the necessary tools directly
einfo "Running necessary autotools..."
aclocal -I m4 || die "aclocal failed."
@@ -56,7 +66,7 @@ src_compile() {
econf \
--enable-client \
--disable-static-client \
- --with-wx-config=$(type -P wx-config-2.6) \
+ ${wxconf} \
$(use_enable unicode) \
$(use_enable server) \
$(use_with X x) || die "econf failed"
diff --git a/sci-misc/boinc/boinc-5.8.15.ebuild b/sci-misc/boinc/boinc-5.8.15.ebuild
index 55a0ca5e112b..f33b9bc16d38 100644
--- a/sci-misc/boinc/boinc-5.8.15.ebuild
+++ b/sci-misc/boinc/boinc-5.8.15.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.8.15.ebuild,v 1.1 2007/03/27 05:29:11 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.8.15.ebuild,v 1.2 2007/05/19 07:49:23 dirtyepic Exp $
-inherit flag-o-matic
+inherit flag-o-matic wxwidgets
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
@@ -16,7 +16,7 @@ IUSE="server X unicode"
RDEPEND="sys-libs/zlib
>=net-misc/curl-7.15.5
>=dev-libs/openssl-0.9.7
- X? ( >=x11-libs/wxGTK-2.6.2 )
+ X? ( =x11-libs/wxGTK-2.6* )
server? ( net-www/apache
>=virtual/mysql-4.0
virtual/php
@@ -45,6 +45,17 @@ src_unpack() {
src_compile() {
append-flags -O3 -funroll-loops -fforce-addr -ffast-math
+
+ if use X; then
+ WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
# Just run the necessary tools directly
#einfo "Running necessary autotools..."
#aclocal -I m4 || die "aclocal failed."
@@ -55,7 +66,7 @@ src_compile() {
--enable-client \
--disable-static-client \
--with-ssl \
- --with-wx-config=$(type -P wx-config-2.6) \
+ ${wxconf} \
$(use_enable unicode) \
$(use_enable server) \
$(use_with X x) || die "econf failed"