summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2005-12-04 21:14:52 +0000
committerMarkus Dittrich <markusle@gentoo.org>2005-12-04 21:14:52 +0000
commit74b467102b6dcebba050c05b33ad2d06c63a2970 (patch)
tree092c6d2c07781f8c34dc5c64a5bd509f2c68eb15 /sci-misc
parentInitial import (bug #70892). (diff)
downloadgentoo-2-74b467102b6dcebba050c05b33ad2d06c63a2970.tar.gz
gentoo-2-74b467102b6dcebba050c05b33ad2d06c63a2970.tar.bz2
gentoo-2-74b467102b6dcebba050c05b33ad2d06c63a2970.zip
Bumped gato to latest version; this fixes bug #74580. Removed old ebuild.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/gato/ChangeLog9
-rw-r--r--sci-misc/gato/Manifest5
-rw-r--r--sci-misc/gato/files/digest-gato-0.98i1
-rw-r--r--sci-misc/gato/files/digest-gato-0.98p2
-rw-r--r--sci-misc/gato/files/gato-python2.4-gentoo.patch180
-rw-r--r--sci-misc/gato/gato-0.98i.ebuild32
-rw-r--r--sci-misc/gato/gato-0.98p.ebuild59
7 files changed, 252 insertions, 36 deletions
diff --git a/sci-misc/gato/ChangeLog b/sci-misc/gato/ChangeLog
index f1f59bbc07aa..1ecc0d13ed35 100644
--- a/sci-misc/gato/ChangeLog
+++ b/sci-misc/gato/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-misc/gato
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.4 2005/05/06 18:48:27 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.5 2005/12/04 21:14:52 markusle Exp $
+
+*gato-0.98p (04 Dec 2005)
+
+ 04 Dec 2005; Markus Dittrich <markusle@gentoo.org>
+ +files/gato-python2.4-gentoo.patch, -gato-0.98i.ebuild,
+ +gato-0.98p.ebuild:
+ Bumped gato to latest version; this fixes bug #74580. Removed old ebuild.
06 May 2005; David Holm <dholm@gentoo.org> gato-0.98i.ebuild:
Added to ~ppc.
diff --git a/sci-misc/gato/Manifest b/sci-misc/gato/Manifest
index 9f3e03e71b16..7accfb19c5f9 100644
--- a/sci-misc/gato/Manifest
+++ b/sci-misc/gato/Manifest
@@ -1,4 +1,5 @@
+MD5 880173ce1ce29e195689acf2098d2173 gato-0.98p.ebuild 1403
MD5 4b1b278926350661dc59dbdf192fa66d ChangeLog 728
-MD5 81e40ca94d0b20e7d0bfa235bdbcfe66 gato-0.98i.ebuild 766
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 b4f7fc39383244105cafd3b73f8516d8 files/digest-gato-0.98i 59
+MD5 19dad5f80fc7e3667037999fca784ac2 files/digest-gato-0.98p 128
+MD5 796946a23554105785f59fa99c4a460f files/gato-python2.4-gentoo.patch 6372
diff --git a/sci-misc/gato/files/digest-gato-0.98i b/sci-misc/gato/files/digest-gato-0.98i
deleted file mode 100644
index 3d1f7d6f4d0d..000000000000
--- a/sci-misc/gato/files/digest-gato-0.98i
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3ca25213e6f392f0722451e2d97b903d Gato-0.98I.tar 651264
diff --git a/sci-misc/gato/files/digest-gato-0.98p b/sci-misc/gato/files/digest-gato-0.98p
new file mode 100644
index 000000000000..44d3c7cfbdd6
--- /dev/null
+++ b/sci-misc/gato/files/digest-gato-0.98p
@@ -0,0 +1,2 @@
+MD5 983fa4ba4581a7cb786903fff040dcd6 Gato-0.98P.tar.gz 178368
+MD5 15a4387363c161cb8287352916ba0b0c Gato-Doc-0.98P.tar.gz 169996
diff --git a/sci-misc/gato/files/gato-python2.4-gentoo.patch b/sci-misc/gato/files/gato-python2.4-gentoo.patch
new file mode 100644
index 000000000000..744b3d661a96
--- /dev/null
+++ b/sci-misc/gato/files/gato-python2.4-gentoo.patch
@@ -0,0 +1,180 @@
+diff -Naur Gato/Embedder.py Gato-patched/Embedder.py
+--- Gato/Embedder.py 2005-05-28 10:36:48.000000000 +0000
++++ Gato-patched/Embedder.py 2005-12-04 20:24:05.000000000 +0000
+@@ -59,14 +59,14 @@
+ theGraphEditor.G.yCoord[v], 1)
+
+ #----------------------------------------------------------------------
+-import whrandom
++import random
+
+ def RandomCoords(G):
+ G.xCoord={}
+ G.yCoord={}
+ for v in G.vertices:
+- G.xCoord[v]=whrandom.randint(10,990)
+- G.yCoord[v]=whrandom.randint(10,990)
++ G.xCoord[v]=random.randint(10,990)
++ G.yCoord[v]=random.randint(10,990)
+ return 1
+
+ class RandomEmbedder(Embedder):
+@@ -454,7 +454,7 @@
+ for d in list.values():
+ Coord2=500-(len(d)-1)*yDist/2
+ for v in d:
+- G.xCoord[v]=Coord1+whrandom.randint(-20,20)
++ G.xCoord[v]=Coord1+random.randint(-20,20)
+ G.yCoord[v]=Coord2
+ Coord2=Coord2+yDist
+ Coord1=Coord1-xDist
+diff -Naur Gato/Gato.py Gato-patched/Gato.py
+--- Gato/Gato.py 2005-05-28 10:36:48.000000000 +0000
++++ Gato-patched/Gato.py 2005-12-04 20:24:05.000000000 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python2.4
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
+@@ -40,7 +40,7 @@
+ import traceback
+ import os
+ import bdb
+-import whrandom
++import random
+ import re
+ import string
+ import StringIO
+@@ -1588,7 +1588,7 @@
+
+ if v == None:
+ if default == None:
+- v = whrandom.choice(self.graph.vertices)
++ v = random.choice(self.graph.vertices)
+ else:
+ v = default
+ if visual is not None:
+@@ -1613,7 +1613,7 @@
+
+ if e == None:
+ if default == None:
+- e = whrandom.choice(self.graph.Edges())
++ e = random.choice(self.graph.Edges())
+ else:
+ e = default
+
+diff -Naur Gato/GatoFile.py Gato-patched/GatoFile.py
+--- Gato/GatoFile.py 2005-05-28 10:36:48.000000000 +0000
++++ Gato-patched/GatoFile.py 2005-12-04 20:24:05.000000000 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python2.4
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
+diff -Naur Gato/GraphCreator.py Gato-patched/GraphCreator.py
+--- Gato/GraphCreator.py 2005-05-28 10:36:48.000000000 +0000
++++ Gato-patched/GraphCreator.py 2005-12-04 20:24:05.000000000 +0000
+@@ -36,7 +36,7 @@
+
+ from Graph import *
+ from Embedder import *
+-import whrandom
++import random
+
+ class Creator:
+ """ This class provides an abstract Creator as
+@@ -202,7 +202,7 @@
+
+ m=2
+ while index < n:
+- e=Edges[whrandom.randint(0,m-1)]
++ e=Edges[random.randint(0,m-1)]
+ v=G.vertices[index]
+ index=index+1
+
+@@ -297,7 +297,7 @@
+ Edges=CompleteEdges(G,n,direction)
+
+ for i in range(0,m):
+- pos=whrandom.randint(0,len(Edges)-1)
++ pos=random.randint(0,len(Edges)-1)
+ G.AddEdge(Edges[pos][0],Edges[pos][1])
+ del Edges[pos]
+
+@@ -386,7 +386,7 @@
+ Edges=MaximalPlanarEdges(G,n,direction)
+
+ for i in range(0,m):
+- pos=whrandom.randint(0,len(Edges)-1)
++ pos=random.randint(0,len(Edges)-1)
+ G.AddEdge(Edges[pos][0],Edges[pos][1])
+ del Edges[pos]
+
+@@ -578,7 +578,7 @@
+ if direction==0:
+ G.AddEdge(v,new_v)
+ else:
+- if whrandom.randint(0,1):
++ if random.randint(0,1):
+ G.AddEdge(v,new_v)
+ else:
+ G.AddEdge(new_v,v)
+@@ -640,9 +640,9 @@
+ float((float(degree)**(height-h)-1)/
+ (degree-1))))
+ max_nodes=min(n-G.Order()-height+h+1,len(nodes[h])*degree)
+- nodes_nr=whrandom.randint(min_nodes,max_nodes)
++ nodes_nr=random.randint(min_nodes,max_nodes)
+ for i in range(0,nodes_nr):
+- pos=whrandom.randint(0,len(nodes[h])-1)
++ pos=random.randint(0,len(nodes[h])-1)
+ v=nodes[h][pos]
+ children_nr[v]=children_nr[v]+1
+ if children_nr[v]==degree:
+@@ -652,7 +652,7 @@
+ if direction==0:
+ G.AddEdge(v,new_v)
+ else:
+- if whrandom.randint(0,1):
++ if random.randint(0,1):
+ G.AddEdge(v,new_v)
+ else:
+ G.AddEdge(new_v,v)
+diff -Naur Gato/Gred.py Gato-patched/Gred.py
+--- Gato/Gred.py 2005-05-28 10:36:48.000000000 +0000
++++ Gato-patched/Gred.py 2005-12-04 20:24:05.000000000 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python2.4
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
+@@ -50,7 +50,7 @@
+ from tkFileDialog import askopenfilename, asksaveasfilename
+ from tkMessageBox import askokcancel
+ import tkSimpleDialog
+-import whrandom
++import random
+ import string
+ import sys
+ import os
+@@ -768,7 +768,7 @@
+ for e in self.G.Edges():
+ for i in xrange(count):
+ if d.result[i][0] == 1:
+- val = whrandom.uniform(d.result[i][1],d.result[i][2])
++ val = random.uniform(d.result[i][1],d.result[i][2])
+ if self.G.edgeWeights[i].QInteger():
+ self.G.edgeWeights[i][e] = round(int(val))
+ else:
+diff -Naur Gato/TextTreeWidget.py Gato-patched/TextTreeWidget.py
+--- Gato/TextTreeWidget.py 2005-05-28 10:36:48.000000000 +0000
++++ Gato-patched/TextTreeWidget.py 2005-12-04 20:24:05.000000000 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python2.4
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
diff --git a/sci-misc/gato/gato-0.98i.ebuild b/sci-misc/gato/gato-0.98i.ebuild
deleted file mode 100644
index dbb570b71c7e..000000000000
--- a/sci-misc/gato/gato-0.98i.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.98i.ebuild,v 1.3 2005/05/06 18:48:27 dholm Exp $
-
-DESCRIPTION="Graph Animation Toolbox"
-HOMEPAGE="http://www.zpr.uni-koeln.de/~gato/"
-SRC_URI="http://www.zpr.uni-koeln.de/~gato/Download/Gato-0.98I.tar"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE=""
-
-DEPEND=""
-RDEPEND="dev-lang/python
- dev-lang/tk"
-
-S=${WORKDIR}/Gato
-
-src_install() {
-
- insinto /usr/lib/${PN}
- doins *.py
- fperms 755 /usr/lib/${PN}/Gato.py /usr/lib/${PN}/Gred.py
-
- dodir /usr/bin
- dosym /usr/lib/${PN}/Gato.py /usr/bin/gato
- dosym /usr/lib/${PN}/Gred.py /usr/bin/gred
-
- insinto /usr/share/${PN}
- doins BFS.* DFS.* sample.cat
-}
diff --git a/sci-misc/gato/gato-0.98p.ebuild b/sci-misc/gato/gato-0.98p.ebuild
new file mode 100644
index 000000000000..45adebb592af
--- /dev/null
+++ b/sci-misc/gato/gato-0.98p.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.98p.ebuild,v 1.1 2005/12/04 21:14:52 markusle Exp $
+
+inherit eutils
+
+MY_P="Gato"
+MY_PV="0.98P"
+
+DESCRIPTION="Graph Animation Toolbox"
+LICENSE="LGPL-2"
+HOMEPAGE="http://gato.sourceforge.net/"
+SRC_URI="http://gato.sourceforge.net/Download/${MY_P}-${MY_PV}.tar.gz
+ doc? ( http://gato.sourceforge.net/Download/${MY_P}-Doc-${MY_PV}.tar.gz )"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ dev-lang/tk"
+
+S="${WORKDIR}"/Gato
+GATO_DOC="${WORKDIR}"/Doc
+
+src_unpack() {
+ unpack ${A}
+
+ # convert to python2.4
+ epatch "${FILESDIR}"/gato-python2.4-gentoo.patch
+
+ cd "${S}"
+ # change TKinter call to avoid crashing of X
+ sed -e "s:self.overrideredirect(1):self.overrideredirect(0):" \
+ -i GatoDialogs.py || die "failed to patch GatoDialogs.py"
+}
+
+src_install() {
+
+ # install python code
+ insinto /usr/lib/${PN}
+ doins *.py || die "Failed to install python files"
+ fperms 755 /usr/lib/${PN}/Gato.py /usr/lib/${PN}/Gred.py
+
+ # create symlinks
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/Gato.py /usr/bin/gato
+ dosym /usr/lib/${PN}/Gred.py /usr/bin/gred
+
+ # install data files
+ insinto /usr/share/${PN}
+ doins BFS.* DFS.* sample.cat || die "failed to data files"
+
+ # install docs
+ if use doc; then
+ dohtml -r ${GATO_DOC}/*
+ fi
+}