summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-01-07 17:07:48 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-01-07 17:07:48 +0000
commite926232fa1d6c42b32d6f6f700eb82a90e1bbebc (patch)
treeb7d76552c6137ff53c22ad9b33b2e6e79cf89203 /sci-mathematics
parentstable x86, bug 285475 (diff)
downloadgentoo-2-e926232fa1d6c42b32d6f6f700eb82a90e1bbebc.tar.gz
gentoo-2-e926232fa1d6c42b32d6f6f700eb82a90e1bbebc.tar.bz2
gentoo-2-e926232fa1d6c42b32d6f6f700eb82a90e1bbebc.zip
Initial import
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/fricas/ChangeLog10
-rw-r--r--sci-mathematics/fricas/files/64fricas-gentoo.el4
-rw-r--r--sci-mathematics/fricas/fricas-1.0.8.ebuild86
-rw-r--r--sci-mathematics/fricas/metadata.xml26
4 files changed, 126 insertions, 0 deletions
diff --git a/sci-mathematics/fricas/ChangeLog b/sci-mathematics/fricas/ChangeLog
new file mode 100644
index 000000000000..028125f58b0b
--- /dev/null
+++ b/sci-mathematics/fricas/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/fricas
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.1 2010/01/07 17:07:46 grozin Exp $
+
+*fricas-1.0.8 (07 Jan 2010)
+
+ 07 Jan 2010; Andrey Grozin <grozin@gentoo.org> +files/64fricas-gentoo.el,
+ +fricas-1.0.8.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/sci-mathematics/fricas/files/64fricas-gentoo.el b/sci-mathematics/fricas/files/64fricas-gentoo.el
new file mode 100644
index 000000000000..bd0f2c1b6656
--- /dev/null
+++ b/sci-mathematics/fricas/files/64fricas-gentoo.el
@@ -0,0 +1,4 @@
+;; site-init for sci-mathematics/fricas
+(add-to-list 'load-path "/usr/share/emacs/site-lisp/fricas")
+(setq auto-mode-alist (cons '("\\.fri" . fricas-mode) auto-mode-alist))
+;(require 'fricas)
diff --git a/sci-mathematics/fricas/fricas-1.0.8.ebuild b/sci-mathematics/fricas/fricas-1.0.8.ebuild
new file mode 100644
index 000000000000..ea81c4e1ae07
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.0.8.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/fricas-1.0.8.ebuild,v 1.1 2010/01/07 17:07:47 grozin Exp $
+EAPI=2
+inherit elisp-common
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+# Supported lisps, number 0 is the default
+LISPS=( sbcl cmucl gcl ecl clisp clozurecl )
+# . means just dev-lisp/${LISP}
+# package-x.y.z means >=dev-lisp/package-x.y.z
+DEPS=( . . . ecls-9 . . )
+# command name: . means just ${LISP}
+COMMAND=( . lisp . . . ccl )
+
+IUSE="${LISPS[*]} X emacs"
+RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( virtual/emacs )"
+
+# Generating lisp deps
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ LISP=${LISPS[$n]}
+ DEP=${DEPS[$n]}
+ if [ "${DEP}" = "." ]; then
+ DEP="dev-lisp/${LISP}"
+ else
+ DEP=">=dev-lisp/${DEP}"
+ fi
+ RDEPEND="${RDEPEND} ${LISP}? ( ${DEP} ) !${LISP}? ("
+done
+RDEPEND="${RDEPEND} dev-lisp/${LISPS[0]}"
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ RDEPEND="${RDEPEND} )"
+done
+
+DEPEND="${RDEPEND}"
+
+# necessary for gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP n
+ LISP=sbcl
+ n=${#LISPS[*]}
+ for ((n--; n > 0; n--)); do
+ if use ${LISPS[$n]}; then
+ LISP=${COMMAND[$n]}
+ if [ "${LISP}" = "." ]; then
+ LISP=${LISPS[$n]}
+ fi
+ fi
+ done
+ einfo "Using lisp: ${LISP}"
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'emake install failed'
+ dodoc README FAQ || die "dodoc failed"
+
+ if use emacs; then
+ elisp-install ${PN} "${D}"/usr/lib/${PN}/emacs/*.el
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/lib/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/fricas/metadata.xml b/sci-mathematics/fricas/metadata.xml
new file mode 100644
index 000000000000..128f19c5c089
--- /dev/null
+++ b/sci-mathematics/fricas/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<longdescription lang="en">
+FriCAS is a fork of Axiom computer algebra system.
+</longdescription>
+<use>
+ <flag name='clisp'>Add support for GNU CLISP
+ (<pkg>dev-lisp/clisp</pkg>)</flag>
+ <flag name='cmucl'>Add support for CMU Common Lisp
+ (<pkg>dev-lisp/cmucl</pkg>)</flag>
+ <flag name='gcl'>Add support for GNU Common Lisp
+ (<pkg>dev-lisp/gcl</pkg>)</flag>
+ <flag name='sbcl'>Add support for Steel Bank Common Lisp
+ (<pkg>dev-lisp/sbcl</pkg>)</flag>
+ <flag name='ecl'>Add support for Embeddable Common Lisp
+ (<pkg>dev-lisp/ecls</pkg>)</flag>
+ <flag name='clozurecl'>Add support for Clozure Common Lisp
+ (<pkg>dev-lisp/closurecl</pkg>)</flag>
+</use>
+</pkgmetadata>