summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-08-10 18:00:17 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-08-10 18:00:17 +0000
commitc0346443b94b382ac31d2ae6738a01c64d0e4684 (patch)
tree67ed2765c58fe70273ed4f3d9cd42ec6b822cd01 /sci-mathematics
parentalpha stable wrt #184462 (diff)
downloadgentoo-2-c0346443b94b382ac31d2ae6738a01c64d0e4684.tar.gz
gentoo-2-c0346443b94b382ac31d2ae6738a01c64d0e4684.tar.bz2
gentoo-2-c0346443b94b382ac31d2ae6738a01c64d0e4684.zip
Version bump (see bug #187921).
(Portage version: 2.1.3.3)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/yacas/ChangeLog7
-rw-r--r--sci-mathematics/yacas/files/digest-yacas-1.1.03
-rw-r--r--sci-mathematics/yacas/yacas-1.1.0.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index 227843cea9c6..69155b720cc6 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.16 2007/07/18 02:16:06 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.17 2007/08/10 18:00:16 markusle Exp $
+
+*yacas-1.1.0 (10 Aug 2007)
+
+ 10 Aug 2007; Markus Dittrich <markusle@gentoo.org> +yacas-1.1.0.ebuild:
+ Version bump (see bug #187921).
18 Jul 2007; Marcus D. Hanwell <cryos@gentoo.org> -yacas-1.0.62.ebuild,
yacas-1.0.63.ebuild:
diff --git a/sci-mathematics/yacas/files/digest-yacas-1.1.0 b/sci-mathematics/yacas/files/digest-yacas-1.1.0
new file mode 100644
index 000000000000..b7221a082a7a
--- /dev/null
+++ b/sci-mathematics/yacas/files/digest-yacas-1.1.0
@@ -0,0 +1,3 @@
+MD5 47b58afdea57c2915a7ce34af8f46bc0 yacas-1.1.0.tar.gz 1918265
+RMD160 8dbec2086fd9fffb5c1abfa7bcfde7c30318e6b0 yacas-1.1.0.tar.gz 1918265
+SHA256 c55e2d58fca55beac12c31e2499dd2dcaa1e3b6a47a0645778825226d121d981 yacas-1.1.0.tar.gz 1918265
diff --git a/sci-mathematics/yacas/yacas-1.1.0.ebuild b/sci-mathematics/yacas/yacas-1.1.0.ebuild
new file mode 100644
index 000000000000..c3daf81d74a2
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.1.0.ebuild,v 1.1 2007/08/10 18:00:16 markusle Exp $
+
+inherit autotools eutils flag-o-matic
+
+IUSE="glut server"
+
+DESCRIPTION="very powerful general purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4
+ dev-lang/perl
+ glut? ( virtual/glut )
+ www-client/lynx"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use glut; then
+ sed -e 's:opengl::g' -i plugins/Makefile.am || \
+ die "sed (opengl) failed"
+ sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
+ manmake/Makefile.am || die 'sed (manmake) failed'
+ fi
+
+ epatch "${FILESDIR}"/${PN}-1.0.63-as-needed.patch
+ eautoreconf
+}
+
+src_compile() {
+ # Filter -Os due to reported issues with it in bug 126779.
+ replace-flags -Os -O2
+
+ local myconf="--with-numlib=native"
+
+ if use server; then
+ myconf="${myconf} --enable-server"
+ fi
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ cd "${S}"
+ make DESTDIR="${D}" install-strip || die
+
+ dodoc AUTHORS INSTALL NEWS README TODO
+ mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
+ rmdir "${D}"/usr/include/
+ rm "${D}"/usr/share/${PN}/include/win32*
+ sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
+ -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
+ -i "${D}"/usr/share/${PN}/yacasinit.ys || die
+}