summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2005-11-08 14:46:51 +0000
committerGeorge Shapovalov <george@gentoo.org>2005-11-08 14:46:51 +0000
commitaa48fe5022949820d0d013c3540d724f9ec842cf (patch)
tree57821651017dea33bf082cb87c64c1e4afd1f8de /sci-mathematics
parentremoved old version (diff)
downloadgentoo-2-aa48fe5022949820d0d013c3540d724f9ec842cf.tar.gz
gentoo-2-aa48fe5022949820d0d013c3540d724f9ec842cf.tar.bz2
gentoo-2-aa48fe5022949820d0d013c3540d724f9ec842cf.zip
optimization fixes + adjusted -fPIC fix for amd64
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/ChangeLog6
-rw-r--r--sci-mathematics/pari/Manifest2
-rw-r--r--sci-mathematics/pari/pari-2.1.6.ebuild18
3 files changed, 17 insertions, 9 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index 83bf7d7613d1..f653d9223215 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.17 2005/11/08 14:01:07 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.18 2005/11/08 14:46:51 george Exp $
+
+ 08 Nov 2005; George Shapovalov <george@gentoo.org> pari-2.1.6.ebuild:
+ no-optimization fixes were neede for this version as well, also
+ adjusted -fPIC fix as in 2.1.5
08 Nov 2005; George Shapovalov <george@gentoo.org> pari-2.1.5-r4.ebuild:
fixed no-optimization-given issue (#79278), also added -fPIC fix to this version
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index 1159b66e1578..4939d5e4835d 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -6,4 +6,4 @@ MD5 dccf7ef464f99fa750a5c7fc3ec67e8f files/wrong_functype-r1.patch 1498
MD5 cbd309a01e2fee1a5ba6cb3a93ba5708 files/wrong_functype.patch 1946
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 c49cfeebeab95672f9d228b76c63522b pari-2.1.5-r4.ebuild 2520
-MD5 b280810de2c9996b6da854bc3a813bc7 pari-2.1.6.ebuild 2240
+MD5 e8705ee7fbd424ee0c342567bef34919 pari-2.1.6.ebuild 2312
diff --git a/sci-mathematics/pari/pari-2.1.6.ebuild b/sci-mathematics/pari/pari-2.1.6.ebuild
index b77b4828e5b8..a7cd904d7029 100644
--- a/sci-mathematics/pari/pari-2.1.6.ebuild
+++ b/sci-mathematics/pari/pari-2.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.12 2005/07/07 13:18:46 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.13 2005/11/08 14:46:51 george Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -26,6 +26,15 @@ src_compile() {
# Fix usage of toolchain
tc-getAS; tc-getLD; tc-getCC; tc-getCXX
+ #need to force optimization here, as it breaks without
+ if is-flag -O0; then
+ replace-flags -O0 -O2
+ elif ! is-flag -O?; then
+ append-flags -O2
+ fi
+ #we also need to force -fPIC on amd64
+ if [ "${ARCH}" = "amd64" ] && ! is-flag -fPIC; then append-flags -fPIC; fi
+
./Configure \
--host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
--prefix=/usr \
@@ -50,12 +59,7 @@ src_compile() {
emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
einfo "Building executables..."
- #-fPIC seems to be needed here as well on amd64
- if [ "${ARCH}" = "amd64" ]; then
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" gp ../gp || die "Building executables failed!"
- else
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
- fi
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
use doc || rm -rf doc/*.tex
use doc && emake doc