summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-11 20:51:09 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-11 20:51:09 +0000
commit926622bf44ab377593158d4edb3ce489168c6da7 (patch)
treeb1d42a2231bf01771050cc0d72074fefbcbd3700 /sci-mathematics
parentFix underlinking, bug 371743 (diff)
downloadgentoo-2-926622bf44ab377593158d4edb3ce489168c6da7.tar.gz
gentoo-2-926622bf44ab377593158d4edb3ce489168c6da7.tar.bz2
gentoo-2-926622bf44ab377593158d4edb3ce489168c6da7.zip
Added upstream patch to work around kdelibs focus stealing, bug 375829
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rkward/ChangeLog8
-rw-r--r--sci-mathematics/rkward/files/rkward-0.5.6-focus.patch13
-rw-r--r--sci-mathematics/rkward/rkward-0.5.6-r1.ebuild31
3 files changed, 51 insertions, 1 deletions
diff --git a/sci-mathematics/rkward/ChangeLog b/sci-mathematics/rkward/ChangeLog
index b5ce8e6c0c3a..59efbf5bef53 100644
--- a/sci-mathematics/rkward/ChangeLog
+++ b/sci-mathematics/rkward/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/rkward
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/ChangeLog,v 1.29 2011/07/26 15:55:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/ChangeLog,v 1.30 2011/08/11 20:51:09 dilfridge Exp $
+
+*rkward-0.5.6-r1 (11 Aug 2011)
+
+ 11 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +rkward-0.5.6-r1.ebuild, +files/rkward-0.5.6-focus.patch:
+ Added upstream patch to work around kdelibs focus stealing, bug 375829
*rkward-0.5.6 (26 Jul 2011)
diff --git a/sci-mathematics/rkward/files/rkward-0.5.6-focus.patch b/sci-mathematics/rkward/files/rkward-0.5.6-focus.patch
new file mode 100644
index 000000000000..e36d25b19d8b
--- /dev/null
+++ b/sci-mathematics/rkward/files/rkward-0.5.6-focus.patch
@@ -0,0 +1,13 @@
+--- trunk/rkward/rkward/windows/rkhtmlwindow.cpp 2011/06/01 07:54:54 3658
++++ trunk/rkward/rkward/windows/rkhtmlwindow.cpp 2011/06/01 11:02:00 3659
+@@ -62,6 +62,10 @@
+ khtmlpart = new KHTMLPart (this, 0, KHTMLPart::BrowserViewGUI);
+ setPart (khtmlpart);
+ fixupPartGUI ();
++// WORKAROUND for annoying kdelibs bug in KDE 4.6: https://sourceforge.net/tracker/?func=detail&atid=459007&aid=3310106&group_id=50231
++ QAction *action = khtmlpart->action ("findAheadText");
++ if (action) action->setShortcutContext (Qt::WidgetWithChildrenShortcut);
++// WORKAROUND end
+ initializeActivationSignals ();
+ RKXMLGUISyncer::self()->registerChangeListener (khtmlpart, this, SLOT (fixupPartGUI()));
+ khtmlpart->setSelectable (true);
diff --git a/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild b/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild
new file mode 100644
index 000000000000..eda388953826
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild,v 1.1 2011/08/11 20:51:09 dilfridge Exp $
+
+EAPI=4
+
+KDE_DOC_DIRS="doc"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="ca cs da de el es fr it lt pl tr zh_CN"
+inherit kde4-base
+
+DESCRIPTION="An IDE/GUI for the R-project"
+HOMEPAGE="http://rkward.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rkward/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/R"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.6-focus.patch" )
+
+src_install() {
+ kde4-base_src_install
+ # avoid file collisions
+ rm -f "${ED}"/usr/$(get_libdir)/R/library/R.css
+ rm -f "${ED}"/usr/share/apps/katepart/syntax/r.xml
+}