summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-05-18 16:32:15 +0000
committerThomas Kahle <tomka@gentoo.org>2012-05-18 16:32:15 +0000
commit8fd594bda57ebc18102df1d4755e0193280cd260 (patch)
tree37049885681e21d3df85a8c78fbcaab6b8d305d0 /sci-mathematics
parentAdd two variables for non native and native subdirs and define it in only one... (diff)
downloadgentoo-2-8fd594bda57ebc18102df1d4755e0193280cd260.tar.gz
gentoo-2-8fd594bda57ebc18102df1d4755e0193280cd260.tar.bz2
gentoo-2-8fd594bda57ebc18102df1d4755e0193280cd260.zip
Fix direct g++ calls and CXXFLAGS (bug 415975). x86 stable.
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/frobby/ChangeLog7
-rw-r--r--sci-mathematics/frobby/files/frobby-latex.patch21
-rw-r--r--sci-mathematics/frobby/files/frobby-useless-checks.patch74
-rw-r--r--sci-mathematics/frobby/frobby-0.8.2-r1.ebuild50
-rw-r--r--sci-mathematics/frobby/frobby-0.9.0.ebuild12
5 files changed, 14 insertions, 150 deletions
diff --git a/sci-mathematics/frobby/ChangeLog b/sci-mathematics/frobby/ChangeLog
index b9ef0ef8ee8c..900c103a2e72 100644
--- a/sci-mathematics/frobby/ChangeLog
+++ b/sci-mathematics/frobby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/frobby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.10 2012/05/18 08:05:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.11 2012/05/18 16:32:13 tomka Exp $
+
+ 18 May 2012; Thomas Kahle <tomka@gentoo.org> -files/frobby-latex.patch,
+ -files/frobby-useless-checks.patch, -frobby-0.8.2-r1.ebuild,
+ frobby-0.9.0.ebuild:
+ Fix direct g++ calls and CXXFLAGS (bug 415975). x86 stable.
18 May 2012; Agostino Sarubbo <ago@gentoo.org> frobby-0.9.0.ebuild:
Stable for amd64, wrt bug #415975
diff --git a/sci-mathematics/frobby/files/frobby-latex.patch b/sci-mathematics/frobby/files/frobby-latex.patch
deleted file mode 100644
index 546841fe03cd..000000000000
--- a/sci-mathematics/frobby/files/frobby-latex.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile 2009-07-07 05:40:18.000000000 +0200
-+++ Makefile.docfix 2009-11-25 00:47:33.000000000 +0100
-@@ -241,15 +241,15 @@
- docPs:
- rm -rf bin/doc
- mkdir bin/doc
-- for i in 1 2 3; do latex doc/manual.tex -output-directory=bin/doc/; done
-+ for i in 1 2 3; do latex -output-directory=bin/doc/ doc/manual.tex; done
- cd bin; dvips doc/manual.dvi
- docPdf:
- rm -rf bin/doc
- mkdir bin/doc
-- for i in 1 2 3; do pdflatex doc/manual.tex -output-directory=bin/doc/; done
-+ for i in 1 2 3; do pdflatex -output-directory=bin/doc/ doc/manual.tex; done
- mv bin/doc/manual.pdf bin
- docDviOnce: # Useful to view changes when writing the manual
-- latex doc/manual.tex -output-directory=bin/doc
-+ latex -output-directory=bin/doc doc/manual.tex
-
- # It may seem wasteful to run doxygen three times to generate three
- # kinds of output. However, the latex output for creating a pdf file
diff --git a/sci-mathematics/frobby/files/frobby-useless-checks.patch b/sci-mathematics/frobby/files/frobby-useless-checks.patch
deleted file mode 100644
index 2c0dc08a901b..000000000000
--- a/sci-mathematics/frobby/files/frobby-useless-checks.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/DebugAllocator.cpp frobby_v0.8.2/src/DebugAllocator.cpp
---- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/DebugAllocator.cpp 2009-07-06 22:40:18.000000000 -0500
-+++ frobby_v0.8.2/src/DebugAllocator.cpp 2009-10-20 16:58:39.000000000 -0500
-@@ -40,6 +40,7 @@
- reportError("Could not open file \"" + _inputFile + "\" for input.");
- }
-
-+#if 0
- /** @todo consider off-by-one conditions on the allocation limit
- conditions in this method.
-
-@@ -197,6 +198,8 @@
- _limitAllocation = false;
- }
-
-+#endif
-+
- void* DebugAllocator::allocate(size_t size) {
- return allocate(size, 0, 0);
- }
-diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/test/TestSuite.cpp frobby_v0.8.2/src/test/TestSuite.cpp
---- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/test/TestSuite.cpp 2009-07-06 22:40:18.000000000 -0500
-+++ frobby_v0.8.2/src/test/TestSuite.cpp 2009-10-20 16:58:39.000000000 -0500
-@@ -15,6 +15,7 @@
- along with this program. If not, see http://www.gnu.org/licenses/.
- */
- #include "stdinc.h"
-+#include <algorithm>
- #include "TestSuite.h"
-
- #include "TestVisitor.h"
-@@ -40,7 +41,7 @@
- }
-
- void TestSuite::sortTests() {
-- sort(begin(), end(), comparePointedToValue);
-+ std::sort(begin(), end(), comparePointedToValue);
- }
-
- TestSuite::TestIterator TestSuite::begin() {
-diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/help-noparam.err frobby_v0.8.2/test/error/help-noparam.err
---- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/help-noparam.err 2009-07-06 22:40:19.000000000 -0500
-+++ frobby_v0.8.2/test/error/help-noparam.err 2009-10-20 16:58:39.000000000 -0500
-@@ -1,4 +1,4 @@
--Frobby version 0.8.1 Copyright (C) 2007 Bjarke Hammersholt Roune
-+Frobby version 0.8.2 Copyright (C) 2007 Bjarke Hammersholt Roune
- Frobby performs a number of computations related to monomial ideals. You
- run it by typing `frobby ACTION', where ACTION is one of the following.
-
-diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/runtests frobby_v0.8.2/test/error/runtests
---- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/runtests 2009-07-06 22:40:19.000000000 -0500
-+++ frobby_v0.8.2/test/error/runtests 2009-10-20 16:59:53.000000000 -0500
-@@ -85,8 +85,8 @@
- $t latformat "blah" latformat-unknownOutput $* -oformat unknownFormat
- if [ $? != 0 ]; then exit 1; fi
-
--$t genideal "blah" genideal-tooLargeBoard $* -type king -varCount 100000
--if [ $? != 0 ]; then exit 1; fi
-+# $t genideal "blah" genideal-tooLargeBoard $* -type king -varCount 100000
-+# if [ $? != 0 ]; then exit 1; fi
-
-
- #######################################
-@@ -203,8 +203,8 @@
- $t transform "1 1" 4ti2-noInteger $* -iformat 4ti2
- if [ $? != 0 ]; then exit 1; fi
-
--$t transform "1 1234567890123456" 4ti2-tooLarge $* -iformat 4ti2
--if [ $? != 0 ]; then exit 1; fi
-+# $t transform "1 1234567890123456" 4ti2-tooLarge $* -iformat 4ti2
-+# if [ $? != 0 ]; then exit 1; fi
-
- $t hilbert "R=QQ[a];I=monomialIdeal(" m2-noIdentifier $* -iformat m2
- if [ $? != 0 ]; then exit 1; fi
diff --git a/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild b/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild
deleted file mode 100644
index 035581619694..000000000000
--- a/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild,v 1.7 2011/11/14 11:26:47 flameeyes Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="Frobby is a software system and project for computations with monomial ideals"
-HOMEPAGE="http://www.broune.com/frobby/"
-SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-RDEPEND="dev-libs/gmp[cxx]"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base )"
-
-S="${WORKDIR}/frobby_v${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-latex.patch"
- epatch "${FILESDIR}/${PN}-useless-checks.patch"
- epatch "${FILESDIR}/${PN}-cflags-no-strip.patch"
-}
-
-src_compile() {
- emake || die "compile failed"
- emake library || die "making libfrobby failed"
- if use doc; then
- # latex loops don't parallelize well
- emake -j1 doc || die "failed creating documentation"
- fi
-}
-
-src_install() {
- dobin bin/frobby || die
- dolib.a bin/libfrobby.a || die
- insinto /usr/include
- doins src/frobby.h || die
- dodir /usr/include/"${PN}" || die
- insinto /usr/include/"${PN}"
- doins src/stdinc.h || die
- if use doc; then
- dodoc bin/manual.pdf || die
- fi
-}
diff --git a/sci-mathematics/frobby/frobby-0.9.0.ebuild b/sci-mathematics/frobby/frobby-0.9.0.ebuild
index 3516c15083fc..dffd4e08483f 100644
--- a/sci-mathematics/frobby/frobby-0.9.0.ebuild
+++ b/sci-mathematics/frobby/frobby-0.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.9.0.ebuild,v 1.3 2012/05/18 08:05:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.9.0.ebuild,v 1.4 2012/05/18 16:32:13 tomka Exp $
EAPI=4
@@ -12,7 +12,7 @@ SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="doc"
RDEPEND="dev-libs/gmp[cxx]"
@@ -23,11 +23,15 @@ S="${WORKDIR}/frobby_v${PV}"
src_prepare() {
epatch "${FILESDIR}/${PN}-cflags-no-strip.patch"
+ # CXXFLAGS are called CPPFLAGS
+ sed "s/CPPFLAGS/CXXFLAGS/" -i Makefile
}
src_compile() {
- emake
- emake library
+ # Makefile uses the value of CXX which may be defined in /etc/env,
+ # breaking cross-compile.
+ CXX=$(tc-getCXX) emake
+ CXX=$(tc-getCXX) emake library
if use doc; then
emake docPdf
fi