summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-08-13 12:53:00 +0000
committerThomas Kahle <tomka@gentoo.org>2011-08-13 12:53:00 +0000
commit84aea29508da1c907d2a29361a09993de2eeac9c (patch)
treeb4bf48ce12838aff56c9fb0c3f8bc49e7771abaf /sci-mathematics
parentdev-util/oprofile-0.9.7 released. Drop RC masking. (diff)
downloadgentoo-2-84aea29508da1c907d2a29361a09993de2eeac9c.tar.gz
gentoo-2-84aea29508da1c907d2a29361a09993de2eeac9c.tar.bz2
gentoo-2-84aea29508da1c907d2a29361a09993de2eeac9c.zip
bump to pl2
(Portage version: 2.1.10.10/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.3_p2.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 26a32e8996eb..f8cc3cfbfb38 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.65 2011/07/06 18:41:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.66 2011/08/13 12:53:00 tomka Exp $
+
+*coq-8.3_p2 (13 Aug 2011)
+
+ 13 Aug 2011; Thomas Kahle <tomka@gentoo.org> +coq-8.3_p2.ebuild:
+ bump to pl2
06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -coq-8.2_p1-r1.ebuild,
-coq-8.2_p2.ebuild, -files/coq-8.2_p2-camlp5-6-compat.patch,
diff --git a/sci-mathematics/coq/coq-8.3_p2.ebuild b/sci-mathematics/coq/coq-8.3_p2.ebuild
new file mode 100644
index 000000000000..38438f4fd8ce
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.3_p2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p2.ebuild,v 1.1 2011/08/13 12:53:00 tomka Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ >=dev-ml/camlp5-5.09[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ || ( dev-texlive/texlive-pictures app-text/ptex )
+ || ( dev-texlive/texlive-mathextra app-text/ptex )
+ || ( dev-texlive/texlive-latexextra app-text/ptex )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # configure has an error at line 640 leading to closing a
+ # string to early in the generated coq_config.ml. Here is a
+ # wild sed which replaces \"$LABLGTKLIB\" by $LABLGTKLIB. Note
+ # during pl2-bump: Hmm, my patch did not get applied upstream?
+ sed -i "s/\\\\\"\\\$LABLGTKLIB\\\\\"/\\\$LABLGTKLIB/" configure
+}
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --camlp5dir ${ocaml_lib}/camlp5
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 || die "make failed"
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && domenu "${FILESDIR}/coqide.desktop"
+}