summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-01-30 16:07:04 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-01-30 16:07:04 +0000
commit7ca99421e2fbc0fae8a11ab55c0985f7a58aadb8 (patch)
tree7ef4839921a872165f734d66a7b9c215a438aa36 /sci-mathematics
parentStable on ppc. (diff)
downloadgentoo-2-7ca99421e2fbc0fae8a11ab55c0985f7a58aadb8.tar.gz
gentoo-2-7ca99421e2fbc0fae8a11ab55c0985f7a58aadb8.tar.bz2
gentoo-2-7ca99421e2fbc0fae8a11ab55c0985f7a58aadb8.zip
added ~amd64 to -r6 and a patch which is required if USE=python. fixes #79773
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/snns/ChangeLog8
-rw-r--r--sci-mathematics/snns/files/4.2-fPIC-python.patch12
-rw-r--r--sci-mathematics/snns/snns-4.2-r4.ebuild4
-rw-r--r--sci-mathematics/snns/snns-4.2-r6.ebuild13
4 files changed, 29 insertions, 8 deletions
diff --git a/sci-mathematics/snns/ChangeLog b/sci-mathematics/snns/ChangeLog
index aaf428c38be5..37322330cdd9 100644
--- a/sci-mathematics/snns/ChangeLog
+++ b/sci-mathematics/snns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/snns
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.2 2004/12/28 21:00:28 swegener Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.3 2005/01/30 16:07:04 luckyduck Exp $
+
+ 30 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ +files/4.2-fPIC-python.patch, snns-4.2-r6.ebuild:
+ added ~amd64 to -r6 and a patch which is required if USE=python. fixes #79773
*snns-4.2-r4 (28 Dec 2004)
diff --git a/sci-mathematics/snns/files/4.2-fPIC-python.patch b/sci-mathematics/snns/files/4.2-fPIC-python.patch
new file mode 100644
index 000000000000..c16e9e867280
--- /dev/null
+++ b/sci-mathematics/snns/files/4.2-fPIC-python.patch
@@ -0,0 +1,12 @@
+diff -urpN configuration.orig/Makefile.din configuration/Makefile.din
+--- configuration.orig/Makefile.din 2005-01-30 16:40:54.430169528 +0100
++++ configuration/Makefile.din 2005-01-30 16:41:20.971134688 +0100
+@@ -114,7 +114,7 @@ SUBSTOBJECTS = @LIBOBJS@ @ALLOCA@
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+ .c.o:
+- $(CC) $(CPPFLAGS) $(CFLAGS) -c $<
++ $(CC) -fPIC $(CPPFLAGS) $(CFLAGS) -c $<
+
+ #*****************************************************************************
+ # End of common Makefile.defs
diff --git a/sci-mathematics/snns/snns-4.2-r4.ebuild b/sci-mathematics/snns/snns-4.2-r4.ebuild
index 806087da56ef..926fe0cc151d 100644
--- a/sci-mathematics/snns/snns-4.2-r4.ebuild
+++ b/sci-mathematics/snns/snns-4.2-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r4.ebuild,v 1.1 2004/12/28 15:31:38 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r4.ebuild,v 1.2 2005/01/30 16:07:04 luckyduck Exp $
inherit eutils
diff --git a/sci-mathematics/snns/snns-4.2-r6.ebuild b/sci-mathematics/snns/snns-4.2-r6.ebuild
index 89e3cf07d19e..667436ff59ba 100644
--- a/sci-mathematics/snns/snns-4.2-r6.ebuild
+++ b/sci-mathematics/snns/snns-4.2-r6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r6.ebuild,v 1.1 2004/12/28 15:31:38 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r6.ebuild,v 1.2 2005/01/30 16:07:04 luckyduck Exp $
inherit eutils python
@@ -16,7 +16,7 @@ SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
python? ( http://download.berlios.de/snns-dev/${MYPYTHONEXT}.tar.gz )"
LICENSE="SNNS-${PV}"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
SLOT="0"
IUSE="X doc python"
@@ -31,7 +31,12 @@ src_unpack() {
unpack ${MY_P}.tar.gz
unpack ${MYPATCH}.patch.gz
epatch ${MYPATCH}.patch
- use python && unpack ${MYPYTHONEXT}.tar.gz
+ if use python; then
+ unpack ${MYPYTHONEXT}.tar.gz
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-fPIC-python.patch
+ fi
}
src_compile() {