summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-10-14 02:26:26 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-10-14 02:26:26 +0000
commit74a089b38427b16adc3ec294d54525c7d1856ebd (patch)
treecb2c9ef18b61a8c0cd7ebb0cd21bf4d0f2d316bb /sci-mathematics
parentFilter CFLAGS and force default ABI when cross-compiling. (diff)
downloadgentoo-2-74a089b38427b16adc3ec294d54525c7d1856ebd.tar.gz
gentoo-2-74a089b38427b16adc3ec294d54525c7d1856ebd.tar.bz2
gentoo-2-74a089b38427b16adc3ec294d54525c7d1856ebd.zip
Initial import, thanks to Martin Corley <Martin.Corley@ed.ac.uk> for the ebuild, closes bug 83293.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/qtiplot/ChangeLog11
-rw-r--r--sci-mathematics/qtiplot/Manifest3
-rw-r--r--sci-mathematics/qtiplot/files/digest-qtiplot-0.6.91
-rw-r--r--sci-mathematics/qtiplot/metadata.xml15
-rw-r--r--sci-mathematics/qtiplot/qtiplot-0.6.9.ebuild44
5 files changed, 74 insertions, 0 deletions
diff --git a/sci-mathematics/qtiplot/ChangeLog b/sci-mathematics/qtiplot/ChangeLog
new file mode 100644
index 000000000000..c9a869b10ba7
--- /dev/null
+++ b/sci-mathematics/qtiplot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/qtiplot
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtiplot/ChangeLog,v 1.1 2005/10/14 02:26:26 cryos Exp $
+
+*qtiplot-0.6.9 (14 Oct 2005)
+
+ 14 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+ +qtiplot-0.6.9.ebuild:
+ Initial import, thanks to Martin Corley <Martin.Corley@ed.ac.uk> for the
+ ebuild, closes bug 83293.
+
diff --git a/sci-mathematics/qtiplot/Manifest b/sci-mathematics/qtiplot/Manifest
new file mode 100644
index 000000000000..8f3c48754dc3
--- /dev/null
+++ b/sci-mathematics/qtiplot/Manifest
@@ -0,0 +1,3 @@
+MD5 893bc4adeb75782d32a1a7725958b2fa files/digest-qtiplot-0.6.9 62
+MD5 be5373660391ac23dc1d97a654ca9e79 metadata.xml 604
+MD5 ef79989d3d2df00daa502971c65af377 qtiplot-0.6.9.ebuild 967
diff --git a/sci-mathematics/qtiplot/files/digest-qtiplot-0.6.9 b/sci-mathematics/qtiplot/files/digest-qtiplot-0.6.9
new file mode 100644
index 000000000000..c35252ae9035
--- /dev/null
+++ b/sci-mathematics/qtiplot/files/digest-qtiplot-0.6.9
@@ -0,0 +1 @@
+MD5 77f6554e7bb5f42b370f7407a75b8b5c qtiplot-0.6.9.zip 601001
diff --git a/sci-mathematics/qtiplot/metadata.xml b/sci-mathematics/qtiplot/metadata.xml
new file mode 100644
index 000000000000..118c096c505d
--- /dev/null
+++ b/sci-mathematics/qtiplot/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>cryos@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Data analysis and scientific plotting package. This is a clone of the
+ popular Origin software available on another well known platform implemented
+ in Qt with powerful 2D and 3D data plotting, ASCII import and powerful
+ spreadsheet data manipulation using column logic. Curve fitting and other
+ statistical tools are also available.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/qtiplot/qtiplot-0.6.9.ebuild b/sci-mathematics/qtiplot/qtiplot-0.6.9.ebuild
new file mode 100644
index 000000000000..e554bcaa4fcd
--- /dev/null
+++ b/sci-mathematics/qtiplot/qtiplot-0.6.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtiplot/qtiplot-0.6.9.ebuild,v 1.1 2005/10/14 02:26:26 cryos Exp $
+
+IUSE=""
+DESCRIPTION="Qt based clone of the Origin plotting package"
+
+MY_P=${P/_p/-}
+SRC_URI="http://soft.proindependent.com/src/${MY_P}.zip"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+S=${WORKDIR}/${A/.zip/}
+
+QTIPLOT_DIR=${S}/${A/.zip/}
+QTIPLOT_PRO=${A/.zip}.pro
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="=x11-libs/qt-3*
+ >=x11-libs/qwt-4.2.0
+ >=x11-libs/qwtplot3d-0.2.6
+ >=sci-libs/gsl-1.6"
+
+src_unpack () {
+ unpack ${A}
+ cd ${QTIPLOT_DIR}
+ mv ${QTIPLOT_PRO} qtiplot.pro
+ sed -e 's/INCLUDEPATH.*//' -i qtiplot.pro
+ echo >> qtiplot.pro "INCLUDEPATH += /usr/include/qwt"
+ echo >> qtiplot.pro "INCLUDEPATH += /usr/include/qwtplot3d"
+}
+
+src_compile () {
+ cd ${QTIPLOT_DIR}
+ qmake qtiplot.pro || die 'qmake failed.'
+ emake || die 'emake failed.'
+}
+
+src_install() {
+ cd ${S}
+ dobin qtiplot || die 'Binary installation failed.'
+# dohtml *.html (doesn't appear to be any documentation)
+}