summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2011-10-01 00:15:23 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2011-10-01 00:15:23 +0000
commit3f84bca4f0544838c9dd845db0ba977800e29688 (patch)
treefd18d0df4f1969d7ef2575721e02bd45ef08d750 /sci-mathematics
parentVersion bump. Was delayed by getting html/manpage tarballs on the alternative... (diff)
downloadgentoo-2-3f84bca4f0544838c9dd845db0ba977800e29688.tar.gz
gentoo-2-3f84bca4f0544838c9dd845db0ba977800e29688.tar.bz2
gentoo-2-3f84bca4f0544838c9dd845db0ba977800e29688.zip
Moved project to sourceforge and included random seed patch from Bug #224933.
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/snns/ChangeLog8
-rw-r--r--sci-mathematics/snns/snns-4.2-r9.ebuild123
2 files changed, 130 insertions, 1 deletions
diff --git a/sci-mathematics/snns/ChangeLog b/sci-mathematics/snns/ChangeLog
index 0f08c3469204..9260c1bc9ab3 100644
--- a/sci-mathematics/snns/ChangeLog
+++ b/sci-mathematics/snns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/snns
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.22 2011/08/02 05:49:20 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.23 2011/10/01 00:15:23 phosphan Exp $
+
+*snns-4.2-r9 (30 Sep 2011)
+
+ 30 Sep 2011; Patrick Kursawe <phosphan@gentoo.org>
+ +snns-4.2-r9.ebuild:
+ Moved project to sourceforge and included random seed patch from Bug #224933.
02 Aug 2011; Matt Turner <mattst88@gentoo.org> snns-4.2-r8.ebuild:
Renamed x11-libs/Xaw3d to x11-libs/libXaw3d.
diff --git a/sci-mathematics/snns/snns-4.2-r9.ebuild b/sci-mathematics/snns/snns-4.2-r9.ebuild
new file mode 100644
index 000000000000..4166a62f7606
--- /dev/null
+++ b/sci-mathematics/snns/snns-4.2-r9.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r9.ebuild,v 1.1 2011/10/01 00:15:23 phosphan Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+MY_P="SNNSv${PV}"
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://sourceforge.net/projects/snns/"
+SRC_URI="mirror://sourceforge/snns/${PN}-${PV}-patched.tar.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )
+ python? ( mirror://sourceforge/snns/python.patch.gz )"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="X doc python"
+
+RDEPEND="X? ( x11-libs/libXaw3d )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${PN}-${PV}-patched.tar.gz
+
+ if use python; then
+ unpack python.patch.gz
+ fi
+}
+
+src_prepare() {
+
+ if use python; then
+ epatch "${WORKDIR}/python.patch"
+ fi
+
+ cd xgui/sources
+ for file in *.c; do
+ sed -e "s:X11/Xaw/:X11/Xaw3d/:g" -i "${file}"
+ done
+}
+
+src_configure() {
+ local myconf="--enable-global"
+
+ if use X; then
+ myconf+=" --with-x"
+ else
+ myconf+=" --without-x"
+ fi
+
+ econf ${myconf}
+}
+
+src_compile() {
+ local compileopts="compile-kernel compile-tools"
+ if use X; then
+ compileopts+=" compile-xgui"
+ fi
+
+ # parallel make sometimes fails (phosphan)
+ emake -j1 ${compileopts} || die "make failed"
+
+ if use python; then
+ pushd python > /dev/null
+ distutils_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ mv "${D}/usr/bin/netperf" "${D}/usr/bin/snns-netperf"
+
+ if use X; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${PF}/ > "${D}"/etc/env.d/99snns
+
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ if use python; then
+ pushd python > /dev/null
+ distutils_src_install
+ cp -pPR examples "${D}"/usr/share/doc/${PF}/python-examples
+ chmod +x "${D}"/usr/share/doc/${PF}/python-examples/*.py
+ newdoc README README.python
+ popd > /dev/null
+ fi
+
+ insinto /usr/share/doc/${PF}
+ use doc && doins "${DISTDIR}"/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+
+ doman man/man*/*
+}
+
+pkg_postinst() {
+ if use python; then
+ distutils_pkg_postinst
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ distutils_pkg_postrm
+ fi
+}