summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-06-16 15:30:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-06-16 15:30:25 +0000
commita43329c55df0479bc9e96ed4006b43444fed2270 (patch)
tree885b39cf4df3100722f6554e49d03d2a6906bdd3 /sci-mathematics/qtoctave
parentx86 stable wrt bug #323169 (diff)
downloadgentoo-2-a43329c55df0479bc9e96ed4006b43444fed2270.tar.gz
gentoo-2-a43329c55df0479bc9e96ed4006b43444fed2270.tar.bz2
gentoo-2-a43329c55df0479bc9e96ed4006b43444fed2270.zip
Added patch from Fedora to avoid collision with libquicktime, bug #324217, thanks ssuominen
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/qtoctave')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog7
-rw-r--r--sci-mathematics/qtoctave/files/qtoctave-0.9.1-qtinfo.patch20
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.9.1.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
index 3e188da4a2e5..04d014ada941 100644
--- a/sci-mathematics/qtoctave/ChangeLog
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/qtoctave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.8 2010/06/16 05:56:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.9 2010/06/16 15:30:24 bicatali Exp $
+
+ 16 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ qtoctave-0.9.1.ebuild, +files/qtoctave-0.9.1-qtinfo.patch:
+ Added patch from Fedora to avoid collision with libquicktime, bug #324217,
+ thanks ssuominen
*qtoctave-0.9.1 (16 Jun 2010)
diff --git a/sci-mathematics/qtoctave/files/qtoctave-0.9.1-qtinfo.patch b/sci-mathematics/qtoctave/files/qtoctave-0.9.1-qtinfo.patch
new file mode 100644
index 000000000000..e6c632edd163
--- /dev/null
+++ b/sci-mathematics/qtoctave/files/qtoctave-0.9.1-qtinfo.patch
@@ -0,0 +1,20 @@
+--- qtoctave-0.9.1/qtinfo/CMakeLists.txt 2010-01-25 15:19:51.000000000 +0200
++++ qtoctave-0.9.1/qtinfo/CMakeLists.txt 2010-05-09 16:02:41.000000000 +0300
+@@ -33,6 +33,7 @@
+ PROPERTIES INSTALL_RPATH ":usr/lib"
+ BUILD_WITH_INSTALL_RPATH true
+ INSTALL_RPATH_USE_LINK_PATH true
++ OUTPUT_NAME qtoctave-info
+ )
+
+ TARGET_LINK_LIBRARIES(qtinfo
+--- qtoctave-0.9.1/qtoctave/src/scripts_octave/qtinfo.m 2010-01-25 15:19:50.000000000 +0200
++++ qtoctave-0.9.1/qtoctave/src/scripts_octave/qtinfo.m 2010-05-09 16:02:19.000000000 +0300
+@@ -1,5 +1,5 @@
+ function qtinfo()
+- command=sprintf("qtinfo %s > /dev/null", info_file);
++ command=sprintf("qtoctave-info %s > /dev/null", info_file);
+ printf("Starting info: %s\n", command);
+ system(command, 1, "async");
+ endfunction
+\ No newline at end of file
diff --git a/sci-mathematics/qtoctave/qtoctave-0.9.1.ebuild b/sci-mathematics/qtoctave/qtoctave-0.9.1.ebuild
index a684b7ac5950..1256fc25cf18 100644
--- a/sci-mathematics/qtoctave/qtoctave-0.9.1.ebuild
+++ b/sci-mathematics/qtoctave/qtoctave-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.9.1.ebuild,v 1.1 2010/06/16 05:56:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.9.1.ebuild,v 1.2 2010/06/16 15:30:24 bicatali Exp $
EAPI="2"
@@ -28,6 +28,7 @@ S="${WORKDIR}/${P}"
DOCS="readme.txt leeme.txt"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.1-qtinfo.patch
epatch "${FILESDIR}"/${PN}-0.9.1-qt-version.patch
epatch "${FILESDIR}"/${PN}-0.9.1-doc-path.patch
epatch "${FILESDIR}"/${PN}-0.8.1-gcc4.4.patch