summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-02-27 20:30:08 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-02-27 20:30:08 +0000
commitaa5fe32109e37e4085ffb50c43d970365ca4a5c7 (patch)
tree5dabe0993d0a657628840dbd355c7eb65f48d01f /sci-mathematics/octave
parents/noweb/web for net-analyzer/nagios-core (diff)
downloadgentoo-2-aa5fe32109e37e4085ffb50c43d970365ca4a5c7.tar.gz
gentoo-2-aa5fe32109e37e4085ffb50c43d970365ca4a5c7.tar.bz2
gentoo-2-aa5fe32109e37e4085ffb50c43d970365ca4a5c7.zip
Moved check for mpich2 useflag into its proper place.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog8
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r2.ebuild17
2 files changed, 14 insertions, 11 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index adf0519502e9..246ba2508ccd 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.52 2007/12/25 14:32:22 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.53 2008/02/27 20:30:08 markusle Exp $
+
+ 27 Feb 2008; Markus Dittrich <markusle@gentoo.org>
+ octave-2.1.73-r2.ebuild:
+ Moved check for mpich2 useflag into its proper place.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing metalgod from metadata.xml as per #99350.
diff --git a/sci-mathematics/octave/octave-2.1.73-r2.ebuild b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
index df4c4d8b7858..ff6107f295d8 100644
--- a/sci-mathematics/octave/octave-2.1.73-r2.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.5 2007/12/25 01:46:56 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.6 2008/02/27 20:30:08 markusle Exp $
inherit flag-o-matic fortran autotools xemacs-elisp-common
@@ -63,21 +63,20 @@ src_compile() {
# octave links agains -lmpi by default
# mpich needs -lmpich instead
if use mpi ; then
- if built_with_use sys-cluster/mpich2 cxx ; then
- elog "mpich2 must be built without C++ support!"
- die "please rebuild mpich2 with USE=-cxx..."
- else
CC="mpicc"
if has_version 'sys-cluster/mpich' ; then
- CXX="mpiCC"
- myconf="${myconf} --with-mpi=mpich"
+ CXX="mpiCC"
+ myconf="${myconf} --with-mpi=mpich"
elif has_version 'sys-cluster/mpich2' ; then
+ if built_with_use sys-cluster/mpich2 cxx ; then
+ elog "mpich2 must be built without C++ support!"
+ die "please rebuild mpich2 with USE=-cxx..."
+ fi
F77="mpif77"
myconf="${myconf} --with-mpi=mpich"
else
myconf="${myconf} --with-mpi=mpi"
fi
- fi
else
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"