summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 14:48:35 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 14:48:35 +0000
commit75372bb7d8c3552dc010f08407e78a485c4e92c1 (patch)
tree8a3bc6ce222e743e29b7146bd379618ac396bbdf /sci-mathematics/octave/files
parentMoving to sci-mathematics/octave (diff)
downloadgentoo-2-75372bb7d8c3552dc010f08407e78a485c4e92c1.tar.gz
gentoo-2-75372bb7d8c3552dc010f08407e78a485c4e92c1.tar.bz2
gentoo-2-75372bb7d8c3552dc010f08407e78a485c4e92c1.zip
Moved from app-sci/octave to sci-mathematics/octave.
Diffstat (limited to 'sci-mathematics/octave/files')
-rw-r--r--sci-mathematics/octave/files/digest-octave-2.1.36-r11
-rw-r--r--sci-mathematics/octave/files/digest-octave-2.1.501
-rw-r--r--sci-mathematics/octave/files/digest-octave-2.1.571
-rw-r--r--sci-mathematics/octave/files/digest-octave-2.1.57-r11
-rw-r--r--sci-mathematics/octave/files/digest-octave-2.1.641
-rw-r--r--sci-mathematics/octave/files/filebuf.diff41
-rw-r--r--sci-mathematics/octave/files/kill-dvips.diff62
7 files changed, 108 insertions, 0 deletions
diff --git a/sci-mathematics/octave/files/digest-octave-2.1.36-r1 b/sci-mathematics/octave/files/digest-octave-2.1.36-r1
new file mode 100644
index 000000000000..869e2d30fa34
--- /dev/null
+++ b/sci-mathematics/octave/files/digest-octave-2.1.36-r1
@@ -0,0 +1 @@
+MD5 2ae3b8e954b319a6e37a41c3c5c97583 octave-2.1.36.tar.bz2 3627899
diff --git a/sci-mathematics/octave/files/digest-octave-2.1.50 b/sci-mathematics/octave/files/digest-octave-2.1.50
new file mode 100644
index 000000000000..28007c673ad8
--- /dev/null
+++ b/sci-mathematics/octave/files/digest-octave-2.1.50
@@ -0,0 +1 @@
+MD5 480d48cd99828fb403ceee53dd1cad2f octave-2.1.50.tar.bz2 3715690
diff --git a/sci-mathematics/octave/files/digest-octave-2.1.57 b/sci-mathematics/octave/files/digest-octave-2.1.57
new file mode 100644
index 000000000000..083d5364fe75
--- /dev/null
+++ b/sci-mathematics/octave/files/digest-octave-2.1.57
@@ -0,0 +1 @@
+MD5 b781f5d0cd750cb9bb3ef23523f5f339 octave-2.1.57.tar.bz2 4202080
diff --git a/sci-mathematics/octave/files/digest-octave-2.1.57-r1 b/sci-mathematics/octave/files/digest-octave-2.1.57-r1
new file mode 100644
index 000000000000..083d5364fe75
--- /dev/null
+++ b/sci-mathematics/octave/files/digest-octave-2.1.57-r1
@@ -0,0 +1 @@
+MD5 b781f5d0cd750cb9bb3ef23523f5f339 octave-2.1.57.tar.bz2 4202080
diff --git a/sci-mathematics/octave/files/digest-octave-2.1.64 b/sci-mathematics/octave/files/digest-octave-2.1.64
new file mode 100644
index 000000000000..bf66a94cf4d9
--- /dev/null
+++ b/sci-mathematics/octave/files/digest-octave-2.1.64
@@ -0,0 +1 @@
+MD5 01ec8b13bd850123b190129be93adc1f octave-2.1.64.tar.bz2 4341798
diff --git a/sci-mathematics/octave/files/filebuf.diff b/sci-mathematics/octave/files/filebuf.diff
new file mode 100644
index 000000000000..23a12464b348
--- /dev/null
+++ b/sci-mathematics/octave/files/filebuf.diff
@@ -0,0 +1,41 @@
+diff -urN octave-2.1.36/src/c-file-ptr-stream.h octave-2.1.36-modified/src/c-file-ptr-stream.h
+--- octave-2.1.36/src/c-file-ptr-stream.h Thu Nov 1 23:12:00 2001
++++ octave-2.1.36-modified/src/c-file-ptr-stream.h Mon Jul 15 11:28:29 2002
+@@ -31,13 +31,23 @@
+ #include <fstream>
+ #include <cstdio>
+
++#if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 1)
++# include <ext/stdio_filebuf.h>
++#endif
++
+ class
+-c_file_ptr_buf : public std::filebuf
++#if defined __GNUC__ && (__GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 1))
++ c_file_ptr_buf : public __gnu_cxx::stdio_filebuf<char>
++#else
++ c_file_ptr_buf : public std::filebuf
++#endif
+ {
+ public:
+
+ #if !defined (CXX_ISO_COMPLIANT_LIBRARY)
+ typedef int int_type;
++#else
++ typedef std::filebuf::int_type int_type;
+ #endif
+
+ typedef int (*close_fcn) (FILE *);
+@@ -47,7 +57,11 @@
+ c_file_ptr_buf (FILE *f_arg, close_fcn cf_arg = ::fclose)
+ :
+ #if defined __GNUC__ && __GNUC__ >= 3
+- std::filebuf (f_arg, std::ios::in | std::ios::out),
++# if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 1)
++ __gnu_cxx::stdio_filebuf<char> (f_arg, std::ios::in | std::ios::out),
++# else
++ std::filebuf (f_arg, std::ios::in | std::ios::out),
++#endif
+ #else
+ std::filebuf (f_arg ? fileno (f_arg) : -1),
+ #endif
diff --git a/sci-mathematics/octave/files/kill-dvips.diff b/sci-mathematics/octave/files/kill-dvips.diff
new file mode 100644
index 000000000000..9d6ff5dead13
--- /dev/null
+++ b/sci-mathematics/octave/files/kill-dvips.diff
@@ -0,0 +1,62 @@
+diff -ru octave-2.1.36/doc/faq/Makefile octave-2.1.36-fixed/doc/faq/Makefile
+--- octave-2.1.36/doc/faq/Makefile 2002-09-30 20:37:06.000000000 -0500
++++ octave-2.1.36-fixed/doc/faq/Makefile 2002-09-30 21:18:21.000000000 -0500
+@@ -46,8 +46,6 @@
+ export TEXINPUTS; \
+ $(TEXI2DVI) $(srcdir)/Octave-FAQ.texi
+
+-Octave-FAQ.ps: Octave-FAQ.dvi
+- -dvips -o Octave-FAQ.ps Octave-FAQ.dvi
+
+ # These option forms are supported by texi2html 1.65 and probably also
+ # more recent versions.
+diff -ru octave-2.1.36/doc/interpreter/Makefile octave-2.1.36-fixed/doc/interpreter/Makefile
+--- octave-2.1.36/doc/interpreter/Makefile 2002-09-30 20:37:06.000000000 -0500
++++ octave-2.1.36-fixed/doc/interpreter/Makefile 2002-09-30 21:18:30.000000000 -0500
+@@ -88,8 +88,6 @@
+ export TEXINPUTS; \
+ $(TEXI2DVI) $<
+
+-octave.ps: octave.dvi
+- -dvips -o octave.ps octave.dvi
+
+ ../../INSTALL.OCTAVE: install.texi
+ rm -f INSTALL
+diff -ru octave-2.1.36/doc/liboctave/Makefile octave-2.1.36-fixed/doc/liboctave/Makefile
+--- octave-2.1.36/doc/liboctave/Makefile 2002-09-30 20:37:06.000000000 -0500
++++ octave-2.1.36-fixed/doc/liboctave/Makefile 2002-09-30 21:18:38.000000000 -0500
+@@ -50,8 +50,6 @@
+ export TEXINPUTS; \
+ $(TEXI2DVI) $(srcdir)/liboctave.texi
+
+-liboctave.ps: liboctave.dvi
+- -dvips -o liboctave.ps liboctave.dvi
+
+ # These option forms are supported by texi2html 1.65 and probably also
+ # more recent versions.
+diff -ru octave-2.1.36/doc/refcard/Makefile octave-2.1.36-fixed/doc/refcard/Makefile
+--- octave-2.1.36/doc/refcard/Makefile 2002-09-30 20:37:06.000000000 -0500
++++ octave-2.1.36-fixed/doc/refcard/Makefile 2002-09-30 21:19:08.000000000 -0500
+@@ -38,22 +38,16 @@
+ -TEXINPUTS="$(srcdir):$(TEXINPUTS):"; export TEXINPUTS; \
+ tex $(srcdir)/refcard-a4.tex
+
+-refcard-a4.ps: refcard-a4.dvi
+- -dvips -T 297mm,210mm -o refcard-a4.ps refcard-a4.dvi
+
+ refcard-legal.dvi: refcard-legal.tex refcard.tex
+ -TEXINPUTS="$(srcdir):$(TEXINPUTS):"; export TEXINPUTS; \
+ tex $(srcdir)/refcard-legal.tex
+
+-refcard-legal.ps: refcard-legal.dvi
+- -dvips -T 14in,8.5in -o refcard-legal.ps refcard-legal.dvi
+
+ refcard-letter.dvi: refcard-letter.tex refcard.tex
+ -TEXINPUTS="$(srcdir):$(TEXINPUTS):"; export TEXINPUTS; \
+ tex $(srcdir)/refcard-letter.tex
+
+-refcard-letter.ps: refcard-letter.dvi
+- -dvips -T 11in,8.5in -o refcard-letter.ps refcard-letter.dvi
+
+ check install install-strip uninstall:
+ .PHONY: check install install-strip uninstall