summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-04-27 15:09:41 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-04-27 15:09:41 +0000
commitea4f2451edcc18c8fb9de240f10d35812c61ef9e (patch)
tree8e56df421f1e45ce59d0f380bdc44061f79ae96f /sci-mathematics/octave-forge
parentVersion bump (diff)
downloadgentoo-2-ea4f2451edcc18c8fb9de240f10d35812c61ef9e.tar.gz
gentoo-2-ea4f2451edcc18c8fb9de240f10d35812c61ef9e.tar.bz2
gentoo-2-ea4f2451edcc18c8fb9de240f10d35812c61ef9e.zip
Added patch to enable compilation against gcc-4.3 (fixes bug #219392).
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-mathematics/octave-forge')
-rw-r--r--sci-mathematics/octave-forge/ChangeLog8
-rw-r--r--sci-mathematics/octave-forge/files/octave-forge-2006.03.17-gcc43.patch110
-rw-r--r--sci-mathematics/octave-forge/octave-forge-2006.03.17-r1.ebuild3
3 files changed, 119 insertions, 2 deletions
diff --git a/sci-mathematics/octave-forge/ChangeLog b/sci-mathematics/octave-forge/ChangeLog
index a9fefaaf53fb..521016ddc3b1 100644
--- a/sci-mathematics/octave-forge/ChangeLog
+++ b/sci-mathematics/octave-forge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/octave-forge
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/ChangeLog,v 1.26 2008/03/20 17:32:36 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/ChangeLog,v 1.27 2008/04/27 15:09:40 markusle Exp $
+
+ 27 Apr 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/octave-forge-2006.03.17-gcc43.patch,
+ octave-forge-2006.03.17-r1.ebuild:
+ Added patch to enable compilation against gcc-4.3 (fixes bug #219392).
+ Thanks much to Peter Alfredsen <peter.alfredsen@gmail.com> for it.
20 Mar 2008; Markus Dittrich <markusle@gentoo.org>
+files/octave-forge-2006.03.17-imagemagick.patch,
diff --git a/sci-mathematics/octave-forge/files/octave-forge-2006.03.17-gcc43.patch b/sci-mathematics/octave-forge/files/octave-forge-2006.03.17-gcc43.patch
new file mode 100644
index 000000000000..d9c4deed5b67
--- /dev/null
+++ b/sci-mathematics/octave-forge/files/octave-forge-2006.03.17-gcc43.patch
@@ -0,0 +1,110 @@
+diff -Naur octave-forge-2006.03.17/extra/graceplot/__grcmd__.cc octave-forge-2006.03.17.new/extra/graceplot/__grcmd__.cc
+--- octave-forge-2006.03.17/extra/graceplot/__grcmd__.cc 2005-05-24 23:43:38.000000000 -0400
++++ octave-forge-2006.03.17.new/extra/graceplot/__grcmd__.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -36,6 +36,7 @@
+ #include <errno.h>
+ #include <limits.h>
+ #include <string>
++#include <cstring>
+ #include <map>
+ #ifndef OPEN_MAX
+ # define OPEN_MAX 256
+diff -Naur octave-forge-2006.03.17/extra/mex/mex.cc octave-forge-2006.03.17.new/extra/mex/mex.cc
+--- octave-forge-2006.03.17/extra/mex/mex.cc 2004-07-08 00:56:03.000000000 -0400
++++ octave-forge-2006.03.17.new/extra/mex/mex.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -26,6 +26,7 @@
+ #include <iomanip>
+ #include <set>
+ #include <string>
++#include <cstring>
+ typedef void * Pix;
+ typedef std::set<Pix> MemSet;
+
+diff -Naur octave-forge-2006.03.17/extra/pdb/creadpdb.cc octave-forge-2006.03.17.new/extra/pdb/creadpdb.cc
+--- octave-forge-2006.03.17/extra/pdb/creadpdb.cc 2006-01-08 00:47:57.000000000 -0500
++++ octave-forge-2006.03.17.new/extra/pdb/creadpdb.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -20,6 +20,7 @@
+ #include <sys/mman.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <cstring>
+ #include <fcntl.h>
+
+ #define BUFLEN 80
+diff -Naur octave-forge-2006.03.17/FIXES/oct-sort.cc octave-forge-2006.03.17.new/FIXES/oct-sort.cc
+--- octave-forge-2006.03.17/FIXES/oct-sort.cc 2004-01-25 10:17:25.000000000 -0500
++++ octave-forge-2006.03.17.new/FIXES/oct-sort.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -85,6 +85,7 @@
+ #include <octave/lo-mappers.h>
+ #include <octave/config.h>
+ #include <octave/quit.h>
++#include <cstring>
+ #include "oct-sort.h"
+
+ #define IFLT(a,b) if (compare == NULL ? ((a) < (b)) : compare ((a), (b)))
+diff -Naur octave-forge-2006.03.17/FIXES/sort.cc octave-forge-2006.03.17.new/FIXES/sort.cc
+--- octave-forge-2006.03.17/FIXES/sort.cc 2004-04-28 04:55:14.000000000 -0400
++++ octave-forge-2006.03.17.new/FIXES/sort.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -27,6 +27,7 @@
+ #include <octave/lo-ieee.h>
+ #include <octave/data-conv.h>
+ #include <octave/ov-cx-mat.h>
++#include <cstring>
+ #include "oct-sort.cc"
+
+ // ======= Cruft to support ancient versions of Octave =========
+diff -Naur octave-forge-2006.03.17/main/comm/gf.cc octave-forge-2006.03.17.new/main/comm/gf.cc
+--- octave-forge-2006.03.17/main/comm/gf.cc 2005-10-12 14:47:48.000000000 -0400
++++ octave-forge-2006.03.17.new/main/comm/gf.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -49,6 +49,7 @@
+ #include "galois.h"
+ #include "ov-galois.h"
+ #include <octave/utils.h>
++#include <cstring>
+ #include <octave/variables.h>
+
+ #ifndef OCTAVE_LOCAL_BUFFER
+diff -Naur octave-forge-2006.03.17/main/fixed/fixedComplex.cc octave-forge-2006.03.17.new/main/fixed/fixedComplex.cc
+--- octave-forge-2006.03.17/main/fixed/fixedComplex.cc 2004-07-06 16:55:23.000000000 -0400
++++ octave-forge-2006.03.17.new/main/fixed/fixedComplex.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -25,6 +25,7 @@
+
+ #include <complex>
+ #include <cmath>
++#include <cstdlib>
+ #include "int/fixed.h"
+ #include "fixedComplex.h"
+
+diff -Naur octave-forge-2006.03.17/main/miscellaneous/listen.cc octave-forge-2006.03.17.new/main/miscellaneous/listen.cc
+--- octave-forge-2006.03.17/main/miscellaneous/listen.cc 2005-11-16 16:41:07.000000000 -0500
++++ octave-forge-2006.03.17.new/main/miscellaneous/listen.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -11,6 +11,7 @@
+ #include <cstdlib>
+ #include <unistd.h>
+ #include <cerrno>
++#include <cstring>
+ // #include <string.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+diff -Naur octave-forge-2006.03.17/main/miscellaneous/mfilename.cc octave-forge-2006.03.17.new/main/miscellaneous/mfilename.cc
+--- octave-forge-2006.03.17/main/miscellaneous/mfilename.cc 2005-12-21 15:42:40.000000000 -0500
++++ octave-forge-2006.03.17.new/main/miscellaneous/mfilename.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -22,6 +22,7 @@
+ //#ifdef HAVE_CONFIG_H
+ #include <config.h>
+ //#endif
++#include <algorithm>
+
+ #include "defun-dld.h"
+ #include "error.h"
+diff -Naur octave-forge-2006.03.17/main/plot/graphics.cc octave-forge-2006.03.17.new/main/plot/graphics.cc
+--- octave-forge-2006.03.17/main/plot/graphics.cc 2004-01-12 02:39:09.000000000 -0500
++++ octave-forge-2006.03.17.new/main/plot/graphics.cc 2008-04-27 10:43:59.000000000 -0400
+@@ -11,6 +11,7 @@
+ */
+
+ #include <string>
++#include <cstring>
+
+ #include <octave/oct.h>
+ #include <octave/toplev.h>
diff --git a/sci-mathematics/octave-forge/octave-forge-2006.03.17-r1.ebuild b/sci-mathematics/octave-forge/octave-forge-2006.03.17-r1.ebuild
index 38d4ca1c7b18..af77d8618161 100644
--- a/sci-mathematics/octave-forge/octave-forge-2006.03.17-r1.ebuild
+++ b/sci-mathematics/octave-forge/octave-forge-2006.03.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/octave-forge-2006.03.17-r1.ebuild,v 1.5 2008/03/20 17:32:36 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/octave-forge-2006.03.17-r1.ebuild,v 1.6 2008/04/27 15:09:40 markusle Exp $
inherit eutils
@@ -34,6 +34,7 @@ src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${PN}-config-fix.patch
epatch "${FILESDIR}"/${P}-imagemagick.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {