summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-07-12 17:20:38 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-07-12 17:20:38 +0000
commit249b5f0c926e735c556f5db58904c75dd2730dbf (patch)
tree6ab8ea6f47dd24c712308615b3f2979788206b33 /sci-mathematics/glpk
parentStable on amd64 wrt bug #322857 (diff)
downloadgentoo-2-249b5f0c926e735c556f5db58904c75dd2730dbf.tar.gz
gentoo-2-249b5f0c926e735c556f5db58904c75dd2730dbf.tar.bz2
gentoo-2-249b5f0c926e735c556f5db58904c75dd2730dbf.zip
Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/ChangeLog7
-rw-r--r--sci-mathematics/glpk/glpk-4.44.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index 2f496c7deac0..b2b717ba955d 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.44 2010/04/12 16:46:00 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.45 2010/07/12 17:20:38 bicatali Exp $
+
+*glpk-4.44 (12 Jul 2010)
+
+ 12 Jul 2010; Sébastien Fabbro <bicatali@gentoo.org> +glpk-4.44.ebuild:
+ Bump
*glpk-4.43 (12 Apr 2010)
diff --git a/sci-mathematics/glpk/glpk-4.44.ebuild b/sci-mathematics/glpk/glpk-4.44.ebuild
new file mode 100644
index 000000000000..491f237df019
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.44.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.44.ebuild,v 1.1 2010/07/12 17:20:38 bicatali Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples gmp odbc mysql"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf="--disable-dl"
+ if use mysql || use odbc; then
+ myconf="--enable-dl"
+ fi
+
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $(pkg-config --cflags libiodbc)
+
+ econf \
+ --with-zlib \
+ $(use_with gmp) \
+ $(use_enable odbc) \
+ $(use_enable mysql) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || \
+ die "failed to install docs"
+
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ emake distclean
+ doins -r examples || die "failed to install examples"
+ fi
+ if use doc; then
+ cd "${S}"/doc
+ doins *.pdf notes/*.pdf || die "failed to instal djvu and pdf"
+ dodoc *.txt || die "failed to install manual files"
+ fi
+}