summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-04-08 14:40:31 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-04-08 14:40:31 +0000
commit4b14b708d8c9efc180f2e6a01a9529116ca64e74 (patch)
treee8d986ec5095ed1d5e5d8eb6f8e107827c91f045 /sci-mathematics/drgeo/drgeo-1.0.0.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-4b14b708d8c9efc180f2e6a01a9529116ca64e74.tar.gz
gentoo-2-4b14b708d8c9efc180f2e6a01a9529116ca64e74.tar.bz2
gentoo-2-4b14b708d8c9efc180f2e6a01a9529116ca64e74.zip
Version bump with a few ebuild clean ups.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-mathematics/drgeo/drgeo-1.0.0.ebuild')
-rw-r--r--sci-mathematics/drgeo/drgeo-1.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/drgeo/drgeo-1.0.0.ebuild b/sci-mathematics/drgeo/drgeo-1.0.0.ebuild
new file mode 100644
index 000000000000..cc67c74914c5
--- /dev/null
+++ b/sci-mathematics/drgeo/drgeo-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.0.0.ebuild,v 1.1 2005/04/08 14:40:31 cryos Exp $
+
+DOCN="${PN}-doc"
+DOCV="1.5"
+DOC="${DOCN}-${DOCV}"
+
+DESCRIPTION="Interactive geometry package"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.ofset.org/drgeo"
+SRC_URI="mirror://sourceforge/ofset/${P}.tar.gz
+ mirror://sourceforge/ofset/${DOC}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="nls no-helpbrowser"
+
+DEPEND=">=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=dev-libs/libxml2-2
+ >=dev-util/guile-1.4
+ !no-helpbrowser? ( www-client/dillo )"
+
+src_compile() {
+ econf || die "econf failed."
+ emake || die "emake failed."
+ # Can't make the documentation as it depends on Hyperlatex which isn't
+ # yet in portage. Fortunately HTML is already compiled for us in the
+ # tarball and so can be installed. Just create the make install target.
+ cd ${WORKDIR}/${DOC}
+ econf || die "docs econf failed."
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed."
+ dodoc AUTHORS ChangeLog README NEWS TODO
+ if use nls; then
+ cd ${WORKDIR}/${DOC}
+ else
+ cd ${WORKDIR}/${DOC}/c
+ fi
+ make install DESTDIR=${D} || die "docs make installation failed."
+}