summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-07-13 10:52:18 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-07-13 10:52:18 +0000
commit23079848ab551d8095ad8a3e4b2ec8d404ac7744 (patch)
treec3c5952b98ff356425e4a88b7f32a641869aa26f /sci-mathematics/axiom
parentStable on amd64, bug #226183 (diff)
downloadgentoo-2-23079848ab551d8095ad8a3e4b2ec8d404ac7744.tar.gz
gentoo-2-23079848ab551d8095ad8a3e4b2ec8d404ac7744.tar.bz2
gentoo-2-23079848ab551d8095ad8a3e4b2ec8d404ac7744.zip
Switched linux-info based brk randomization check to a run-time check via sysctl (see bug #186926).
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-SENTINEL-4 i686)
Diffstat (limited to 'sci-mathematics/axiom')
-rw-r--r--sci-mathematics/axiom/ChangeLog7
-rw-r--r--sci-mathematics/axiom/axiom-200805.ebuild33
2 files changed, 30 insertions, 10 deletions
diff --git a/sci-mathematics/axiom/ChangeLog b/sci-mathematics/axiom/ChangeLog
index 75375c11710f..eac339026e3c 100644
--- a/sci-mathematics/axiom/ChangeLog
+++ b/sci-mathematics/axiom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/axiom
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.19 2008/07/12 16:04:44 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.20 2008/07/13 10:52:18 markusle Exp $
+
+ 13 Jul 2008; Markus Dittrich <markusle@gentoo.org> axiom-200805.ebuild:
+ Switched linux-info based brk randomization check to a run-time
+ check via sysctl (see bug #186926). Thanks much to Martin Väth
+ <vaeth@mathematik.uni-wuerzburg.de> for suggesting this.
*axiom-200805 (12 Jul 2008)
diff --git a/sci-mathematics/axiom/axiom-200805.ebuild b/sci-mathematics/axiom/axiom-200805.ebuild
index d02ff51f1d52..7557ecff633f 100644
--- a/sci-mathematics/axiom/axiom-200805.ebuild
+++ b/sci-mathematics/axiom/axiom-200805.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/axiom-200805.ebuild,v 1.1 2008/07/12 14:37:32 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/axiom-200805.ebuild,v 1.2 2008/07/13 10:52:18 markusle Exp $
-inherit eutils multilib flag-o-matic linux-info
+inherit eutils multilib flag-o-matic
DESCRIPTION="Axiom is a general purpose Computer Algebra system"
HOMEPAGE="http://axiom.axiom-developer.org/"
@@ -18,17 +18,32 @@ IUSE=""
RESTRICT="strip"
DEPEND="virtual/latex-base
- x11-libs/libXaw"
+ x11-libs/libXaw
+ sys-process/procps"
S="${WORKDIR}"/${PN}
pkg_setup() {
- # for 2.6.25 kernels and higher we need to have CONFIG_COMPAT_BRK
- # enabled, otherwise gcl fails to compile (see bug #186926).
- get_running_version
- if [[ "${KV_MINOR}" == "6" && "${KV_PATCH}" > "24" ]]; then
- local CONFIG_CHECK="COMPAT_BRK"
- check_extra_config
+ # for 2.6.25 kernels and higher we need to have
+ # /proc/sys/kernel/randomize_va_space set to somthing other
+ # than 2, otherwise gcl fails to compile (see bug #186926).
+ local current_setting=$(/sbin/sysctl kernel.randomize_va_space 2>/dev/null | cut -d' ' -f3)
+ if [[ ${current_setting} == 2 ]]; then
+ echo
+ eerror "You kernel has brk randomization enabled. This will"
+ eerror "cause compilation to fail (see bug #186926). You can"
+ eerror "issue:"
+ eerror
+ eerror " /sbin/sysctl -w kernel.randomize_va_space=1"
+ eerror
+ eerror "as root to turn brk randomization off temporarily."
+ eerror "Please remember to turn it back on via"
+ eerror
+ eerror " /sbin/sysctl -w kernel.randomize_va_space=2"
+ eerror
+ eerror "once axiom is done compiling since turning brk"
+ eerror "randomization off results in a less secure kernel."
+ die "Kernel brk randomization detected"
fi
}