summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-15 21:18:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-15 21:18:16 +0000
commite3ec855eef1322b8469c725e8775e1aff49ab005 (patch)
tree15ed2c5168764bc3451b4c25b665caea304e19c9 /sci-libs
parentppc/ppc64 stable wrt #359059 (diff)
downloadgentoo-2-e3ec855eef1322b8469c725e8775e1aff49ab005.tar.gz
gentoo-2-e3ec855eef1322b8469c725e8775e1aff49ab005.tar.bz2
gentoo-2-e3ec855eef1322b8469c725e8775e1aff49ab005.zip
Version bump
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libticables2/ChangeLog8
-rw-r--r--sci-libs/libticables2/libticables2-1.3.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/sci-libs/libticables2/ChangeLog b/sci-libs/libticables2/ChangeLog
index 1fbde966c634..e576335ecdae 100644
--- a/sci-libs/libticables2/ChangeLog
+++ b/sci-libs/libticables2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libticables2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables2/ChangeLog,v 1.3 2011/03/02 20:05:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables2/ChangeLog,v 1.4 2011/03/15 21:18:16 bicatali Exp $
+
+*libticables2-1.3.1 (15 Mar 2011)
+
+ 15 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +libticables2-1.3.1.ebuild:
+ Version bump
02 Mar 2011; Justin Lecher <jlec@gentoo.org> libticables2-1.2.0.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-libs/libticables2/libticables2-1.3.1.ebuild b/sci-libs/libticables2/libticables2-1.3.1.ebuild
new file mode 100644
index 000000000000..f3d5b336dae4
--- /dev/null
+++ b/sci-libs/libticables2/libticables2-1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables2/libticables2-1.3.1.ebuild,v 1.1 2011/03/15 21:18:16 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Library to handle different link cables for TI calculators"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc nls static-libs usb"
+
+RDEPEND="dev-libs/glib:2
+ usb? ( dev-libs/libusb )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS LOGO NEWS README ChangeLog docs/api.txt
+ use doc && dohtml docs/html/*
+}
+
+pkg_postinst() {
+ elog "Please read README in /usr/share/doc/${PF}"
+ elog "if you encounter any problem with a link cable"
+}