summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 18:17:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 18:17:10 +0000
commitcc076820416761cfc63995daefcb1332887d1e93 (patch)
tree0b8aaf450fb1f6510c6caed62947b30c4202ec86 /sci-libs
parentRemoved older versions. Marked 3.4.5-r1 stable. Added 3.4.6 which fixes the... (diff)
downloadgentoo-2-cc076820416761cfc63995daefcb1332887d1e93.tar.gz
gentoo-2-cc076820416761cfc63995daefcb1332887d1e93.tar.bz2
gentoo-2-cc076820416761cfc63995daefcb1332887d1e93.zip
Fix broken autotools handling.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog8
-rw-r--r--sci-libs/fftw/fftw-2.1.5-r2.ebuild24
-rw-r--r--sci-libs/fftw/fftw-3.0.1-r2.ebuild13
3 files changed, 26 insertions, 19 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index 5c5b613fe2c5..1203997a6b0a 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/fftw
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.43 2006/11/03 14:59:37 ribosome Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.44 2007/01/04 18:17:10 flameeyes Exp $
+
+ 04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> fftw-2.1.5-r2.ebuild,
+ fftw-3.0.1-r2.ebuild:
+ Fix broken autotools handling.
*fftw-2.1.5-r2 (03 Nov 2006)
diff --git a/sci-libs/fftw/fftw-2.1.5-r2.ebuild b/sci-libs/fftw/fftw-2.1.5-r2.ebuild
index efc99d2af3a1..f5ce05b0aa88 100644
--- a/sci-libs/fftw/fftw-2.1.5-r2.ebuild
+++ b/sci-libs/fftw/fftw-2.1.5-r2.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r2.ebuild,v 1.1 2006/11/03 14:59:37 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r2.ebuild,v 1.2 2007/01/04 18:17:10 flameeyes Exp $
-inherit flag-o-matic multilib libtool
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit flag-o-matic multilib libtool autotools
IUSE="mpi"
@@ -42,12 +45,13 @@ src_unpack() {
#since some sed'ing is done during the build (?if --enable-type-prefix is set?)
unpack "${P}.tar.gz"
- cd "${WORKDIR}"
- mv ${P} ${P}-single
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ eautoreconf
- unpack "${P}.tar.gz"
cd "${WORKDIR}"
- mv ${P} ${P}-double
+ cp -R ${P} ${P}-double
+ mv ${P} ${P}-single
}
@@ -65,8 +69,6 @@ src_compile() {
#it might be needed if it is decided that lam is an optional dependence
cd "${S}-single"
- epatch "${FILESDIR}/${P}-as-needed.patch"
- libtoolize --copy --force
econf \
--enable-shared \
--enable-threads \
@@ -78,8 +80,6 @@ src_compile() {
#the only difference here is no --enable-float
cd "${S}-double"
- epatch "${FILESDIR}/${P}-as-needed.patch"
- libtoolize --copy --force
econf \
--enable-shared \
--enable-threads \
@@ -103,7 +103,7 @@ src_install () {
for infofile in doc/fftw*info*; do
echo "INFO-DIR-SECTION Libraries" >>${infofile}
echo "START-INFO-DIR-ENTRY" >>${infofile}
- echo "* fftw: (fftw). C subroutine library for computing the Discrete Fourier Transform (DFT)" >>${infofile}
+ echo "* fftw: (fftw). C subroutine library for computing the Discrete Fourier Transform (DFT)" >>${infofile}
echo "END-INFO-DIR-ENTRY" >>${infofile}
done
make DESTDIR=${D} install || die
diff --git a/sci-libs/fftw/fftw-3.0.1-r2.ebuild b/sci-libs/fftw/fftw-3.0.1-r2.ebuild
index 8052ce286e74..c02226bfa5ad 100644
--- a/sci-libs/fftw/fftw-3.0.1-r2.ebuild
+++ b/sci-libs/fftw/fftw-3.0.1-r2.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.0.1-r2.ebuild,v 1.13 2006/07/17 02:49:10 psi29a Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.0.1-r2.ebuild,v 1.14 2007/01/04 18:17:10 flameeyes Exp $
-inherit flag-o-matic eutils toolchain-funcs
+WANT_AUTOMAKE="1.9"
+WANT_AUTOCONF="latest"
+
+inherit flag-o-matic eutils toolchain-funcs autotools
DESCRIPTION="C subroutine library for computing the Discrete Fourier Transform (DFT)"
HOMEPAGE="http://www.fftw.org/"
@@ -28,8 +31,8 @@ src_unpack() {
-i ${infofile} || die "failed to fix info files"
done
- autoreconf
- libtoolize --copy --force
+ eautoreconf
+
cd "${WORKDIR}"
use ppc-macos && epatch ${FILESDIR}/${PN}-ppc-macos.patch
mv ${P} ${P}-single