summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-15 22:43:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-15 22:43:53 +0000
commitb87fff775a77d3ab911597c67e79196d628edbdd (patch)
tree5056b35d8b47d8ba61797aa3fa031e039d2bd8bc /sci-libs
parentTransfer Prefix keywords (diff)
downloadgentoo-2-b87fff775a77d3ab911597c67e79196d628edbdd.tar.gz
gentoo-2-b87fff775a77d3ab911597c67e79196d628edbdd.tar.bz2
gentoo-2-b87fff775a77d3ab911597c67e79196d628edbdd.zip
Bump, thanks to Oliver Borm. Fixes #301012 and #297656
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scotch/ChangeLog10
-rw-r--r--sci-libs/scotch/files/Makefile.inc_5.1.720
-rw-r--r--sci-libs/scotch/files/shared-libs_5.1.7.patch45
-rw-r--r--sci-libs/scotch/scotch-5.1.7.ebuild75
4 files changed, 148 insertions, 2 deletions
diff --git a/sci-libs/scotch/ChangeLog b/sci-libs/scotch/ChangeLog
index a8d254463afb..1350a8daa082 100644
--- a/sci-libs/scotch/ChangeLog
+++ b/sci-libs/scotch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/scotch
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/ChangeLog,v 1.1 2009/09/03 16:58:50 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/ChangeLog,v 1.2 2010/01/15 22:43:52 patrick Exp $
+
+*scotch-5.1.7 (15 Jan 2010)
+
+ 15 Jan 2010; Patrick Lauer <pal@gentoo.org> +scotch-5.1.7.ebuild,
+ +files/Makefile.inc_5.1.7, +files/shared-libs_5.1.7.patch:
+ Bump, thanks to Oliver Borm. Fixes #301012 and #297656
*scotch-5.1.6 (03 Sep 2009)
diff --git a/sci-libs/scotch/files/Makefile.inc_5.1.7 b/sci-libs/scotch/files/Makefile.inc_5.1.7
new file mode 100644
index 000000000000..9121528e7835
--- /dev/null
+++ b/sci-libs/scotch/files/Makefile.inc_5.1.7
@@ -0,0 +1,20 @@
+EXE =
+LIB = .a
+OBJ = .o
+
+MAKE = make
+AR = ar
+ARFLAGS = -ruv
+CAT = cat
+CCS = gcc
+CCP = mpicc
+CCD = gcc
+CFLAGS = -O3 -fPIC -Drestrict=__restrict -DCOMMON_FILE_COMPRESS_GZ -DCOMMON_PTHREAD -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_PTHREAD -DSCOTCH_RENAME
+LDFLAGS = -lz -lm -lrt
+CP = cp
+LEX = flex
+LN = ln
+MKDIR = mkdir
+MV = mv
+RANLIB = ranlib
+YACC = bison -y
diff --git a/sci-libs/scotch/files/shared-libs_5.1.7.patch b/sci-libs/scotch/files/shared-libs_5.1.7.patch
new file mode 100644
index 000000000000..edc60a16efc1
--- /dev/null
+++ b/sci-libs/scotch/files/shared-libs_5.1.7.patch
@@ -0,0 +1,45 @@
+--- scotch-5.1.6.dfsg/src/libscotch/Makefile~ 2008-05-29 09:01:12.000000000 +0000
++++ scotch-5.1.6.dfsg/src/libscotch/Makefile 2008-07-21 14:34:37.000000000 +0000
+@@ -55,8 +55,8 @@
+ $(MAKE) CC="$(CCS)" CCD="$(CCS)" SCOTCHLIB=scotch \
+ scotch.h \
+ scotchf.h \
+- libscotch$(LIB) \
+ libscotcherr$(LIB) \
++ libscotch$(LIB) \
+ libscotcherrexit$(LIB)
+
+ ptscotch : clean
+@@ -2275,6 +2275,8 @@
+ vmesh_separate_zr$(OBJ) \
+ vmesh_separate_st$(OBJ) \
+ vmesh_store$(OBJ)
++ $(CC) -shared -Wl,-soname,lib$(SCOTCHLIB)-5.1.so -L. -lscotcherr -lz -lpthread -lm -lrt -o lib$(SCOTCHLIB)-5.1.so $^
++ ln -s lib$(SCOTCHLIB)-5.1.so lib$(SCOTCHLIB).so
+ $(AR) $(ARFLAGS) lib$(SCOTCHLIB)$(LIB) $(?)
+ -$(RANLIB) lib$(SCOTCHLIB)$(LIB)
+
+@@ -2438,9 +2440,13 @@
+ -$(RANLIB) $(@)
+
+ libscotcherr$(LIB) : library_error$(OBJ)
++ $(CC) -shared -Wl,-soname,libscotcherr-5.1.so -o libscotcherr-5.1.so $^
++ ln -s libscotcherr-5.1.so libscotcherr.so
+ $(AR) $(ARFLAGS) $(@) $(?)
+ -$(RANLIB) $(@)
+
+ libscotcherrexit$(LIB) : library_error_exit$(OBJ)
++ $(CC) -shared -Wl,-soname,libscotcherrexit-5.1.so -o libscotcherrexit-5.1.so $^
++ ln -s libscotcherrexit-5.1.so libscotcherrexit.so
+ $(AR) $(ARFLAGS) $(@) $(?)
+ -$(RANLIB) $(@)
+--- scotch-5.0.6.dfsg/src/libscotchmetis/Makefile~ 2008-05-07 16:23:07.000000000 +0000
++++ scotch-5.0.6.dfsg/src/libscotchmetis/Makefile 2008-07-18 19:45:15.000000000 +0000
+@@ -136,5 +136,7 @@
+ metis_graph_order_f$(OBJ) \
+ metis_graph_part$(OBJ) \
+ metis_graph_part_f$(OBJ)
++ $(CC) -shared -Wl,-soname,libscotchmetis-5.1.so -L../libscotch -lscotch -o libscotchmetis-5.1.so $^
++ ln -s libscotchmetis-5.1.so libscotchmetis.so
+ $(AR) $(ARFLAGS) $(@) $(^)
+ -$(RANLIB) $(@)
diff --git a/sci-libs/scotch/scotch-5.1.7.ebuild b/sci-libs/scotch/scotch-5.1.7.ebuild
new file mode 100644
index 000000000000..a2cb7475df72
--- /dev/null
+++ b/sci-libs/scotch/scotch-5.1.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/scotch-5.1.7.ebuild,v 1.1 2010/01/15 22:43:52 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Software package and libraries for graph partitioning, static mapping, and sparse matrix block ordering"
+HOMEPAGE="http://www.labri.u-bordeaux.fr/perso/pelegrin/scotch/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/23390/${PN}_${PV}.tgz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mpi"
+
+DEPEND="sys-devel/bison
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}"/scotch_5.1/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/shared-libs_${PV}.patch
+ epatch "${FILESDIR}"/metis-header.patch
+}
+
+src_configure() {
+ cp "${FILESDIR}"/Makefile.inc_${PV} ./Makefile.inc
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+ use mpi && (emake -j1 ptscotch || die "make failed")
+}
+
+src_install() {
+ dodir "/usr"
+ emake prefix="${D}/usr" install
+
+ use mpi && dobin "${S}"/../bin/{dgord,dgscat,dgtst}
+
+ for file in `ls "${D}"/usr/bin`
+ do
+ mv "${D}/usr/bin/$file" "${D}/usr/bin/scotch_$file"
+ done
+
+ for file in `ls "${D}"/usr/share/man/man1`
+ do
+ mv "${D}/usr/share/man/man1/$file" "${D}/usr/share/man/man1/scotch_$file"
+ done
+
+ dolib.so "${S}"/{libscotch,libscotchmetis}/*.so
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv "${D}"/usr/lib/* "${D}"/usr/$(get_libdir)
+ rm -rf "${D}"/usr/lib
+ fi
+
+ insinto /usr/include/scotch
+ doins "${S}"/libscotch/*.h
+
+ insinto /usr/include/scotchmetis
+ doins "${S}"/libscotchmetis/*.h
+
+ mv "${D}"/usr/include/*scotch*.h "${D}"/usr/include/scotch/
+
+ insinto "/usr/share/${PN}/tgt"
+ doins "${S}"/../tgt/*
+ insinto "/usr/share/${PN}/grf"
+ doins "${S}"/../grf/*
+
+ cd "${S}/../doc"
+ dodoc *.pdf
+}