summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-09-26 17:48:57 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-09-26 17:48:57 +0000
commitaf1f03e76ea72f951d9ea7036d68ba22293a2565 (patch)
treef4bfe1fcb76379af0d263576bb1c0d5c5f6b6072 /sci-libs
parentEbuild for jboss-logging - JBoss' logging framework (diff)
downloadgentoo-2-af1f03e76ea72f951d9ea7036d68ba22293a2565.tar.gz
gentoo-2-af1f03e76ea72f951d9ea7036d68ba22293a2565.tar.bz2
gentoo-2-af1f03e76ea72f951d9ea7036d68ba22293a2565.zip
removed old (bug #478608)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog8
-rw-r--r--sci-libs/fftw/fftw-3.2.2-r2.ebuild130
-rw-r--r--sci-libs/fftw/fftw-3.2.2.ebuild125
-rw-r--r--sci-libs/fftw/fftw-3.3.3-r1.ebuild150
-rw-r--r--sci-libs/fftw/fftw-3.3.3.ebuild143
-rw-r--r--sci-libs/fftw/files/fftw-3.2.1-as-needed.patch82
-rw-r--r--sci-libs/fftw/files/fftw-3.2.2-pc-threads.patch19
-rw-r--r--sci-libs/fftw/metadata.xml1
8 files changed, 7 insertions, 651 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index 279ae9da198c..227f087991de 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/fftw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.153 2013/09/26 17:32:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.154 2013/09/26 17:48:57 ottxor Exp $
+
+ 26 Sep 2013; Christoph Junghans <ottxor@gentoo.org> -fftw-3.2.2-r2.ebuild,
+ -fftw-3.2.2.ebuild, -fftw-3.3.3-r1.ebuild, -fftw-3.3.3.ebuild,
+ -files/fftw-3.2.1-as-needed.patch, -files/fftw-3.2.2-pc-threads.patch,
+ metadata.xml:
+ removed old (bug #478608)
26 Sep 2013; Agostino Sarubbo <ago@gentoo.org> fftw-3.3.3-r2.ebuild:
Stable for arm, wrt bug #477182
diff --git a/sci-libs/fftw/fftw-3.2.2-r2.ebuild b/sci-libs/fftw/fftw-3.2.2-r2.ebuild
deleted file mode 100644
index 09bf267563fb..000000000000
--- a/sci-libs/fftw/fftw-3.2.2-r2.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2-r2.ebuild,v 1.4 2013/02/22 10:11:14 jlec Exp $
-
-EAPI=2
-
-FORTRAN_NEEDED=fortran
-
-inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-SRC_URI="http://www.fftw.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="altivec doc fortran openmp paired-single sse sse2 threads zbus"
-
-pkg_setup() {
- use openmp && FORTRAN_NEED_OPENMP="1"
- fortran-2_pkg_setup
- FFTW_THREADS="--disable-threads --disable-openmp"
- if use openmp; then
- FFTW_THREADS="--disable-threads --enable-openmp"
- elif use threads; then
- FFTW_THREADS="--enable-threads --disable-openmp"
- fi
- if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
- ewarn "If you want to build fftw with OpenMP, abort now,"
- ewarn "and switch CC to an OpenMP capable compiler"
- ewarn "Otherwise, we will build using POSIX threads."
- epause 5
- FFTW_THREADS="--enable-threads --disable-openmp"
- fi
- FFTW_DIRS="single double longdouble"
- use openmp && [[ $(tc-getCC)$ == icc* ]] && append-ldflags $(no-as-needed)
-}
-
-src_prepare() {
- use threads && epatch "${FILESDIR}"/${P}-pc-threads.patch
- epatch "${FILESDIR}"/${PN}-3.2.1-as-needed.patch
-
- # fix info file for category directory
- sed -i \
- -e 's/Texinfo documentation system/Libraries/' \
- doc/fftw3.info || die "failed to fix info file"
-
- rm m4/lt* m4/libtool.m4
-
- AT_M4DIR=m4 eautoreconf
- for x in ${FFTW_DIRS}; do
- mkdir "${S}-${x}" || die
- done
-}
-
-src_configure() {
- # filter -Os according to docs
- replace-flags -Os -O2
-
- local myconfcommon="--enable-shared
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- ${FFTW_THREADS}"
-
- local myconfsingle="${myconfcommon} --enable-single"
- local myconfdouble="${myconfcommon}"
- local myconflongdouble="${myconfcommon} --enable-long-double"
- if use sse2; then
- myconfsingle="${myconfsingle} --enable-sse"
- myconfdouble="${myconfdouble} --enable-sse2"
- elif use sse; then
- myconfsingle="${myconfsingle} --enable-sse"
- fi
- # altivec only helps singles, not doubles
- if use altivec; then
- myconfsingle="${myconfsingle} --enable-altivec"
- fi
- if use paired-single; then
- myconfsingle="${myconfsingle} --enable-mips-ps"
- fi
-
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}"
- einfo "Configuring for ${x} precision"
- local p=myconf${x}
- ECONF_SOURCE="${S}" econf ${!p}
- done
-}
-
-src_compile() {
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}"
- einfo "Compiling for ${x} precision"
- emake || die "emake for ${x} precision failed"
- done
-}
-
-src_test () {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- #local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}/tests"
- einfo "Testing ${x} precision"
- emake -j1 check || die "emake test ${x} failed"
- done
-}
-
-src_install () {
- # all builds are installed in the same place
- # libs have distinuguished names; include files, docs etc. identical.
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}"
- emake DESTDIR="${D}" install || die "emake install for ${x} failed"
- done
-
- cd "${S}"
- dodoc AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS
- if use doc; then
- cd doc
- insinto /usr/share/doc/${PF}
- doins -r html fftw3.pdf || die "doc install failed"
- insinto /usr/share/doc/${PF}/faq
- doins FAQ/fftw-faq.html/*
- fi
-}
diff --git a/sci-libs/fftw/fftw-3.2.2.ebuild b/sci-libs/fftw/fftw-3.2.2.ebuild
deleted file mode 100644
index fd45cc4fd129..000000000000
--- a/sci-libs/fftw/fftw-3.2.2.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2.ebuild,v 1.19 2013/02/22 10:11:14 jlec Exp $
-
-EAPI=2
-
-FORTRAN_NEEDED=fortran
-
-inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-SRC_URI="http://www.fftw.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="altivec doc fortran openmp sse sse2 threads"
-
-pkg_setup() {
- use openmp && FORTRAN_NEED_OPENMP="1"
- fortran-2_pkg_setup
- FFTW_THREADS="--disable-threads --disable-openmp"
- if use openmp; then
- FFTW_THREADS="--disable-threads --enable-openmp"
- elif use threads; then
- FFTW_THREADS="--enable-threads --disable-openmp"
- fi
- if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
- ewarn "If you want to build fftw with OpenMP, abort now,"
- ewarn "and switch CC to an OpenMP capable compiler"
- ewarn "Otherwise, we will build using POSIX threads."
- epause 5
- FFTW_THREADS="--enable-threads --disable-openmp"
- fi
- FFTW_DIRS="single double longdouble"
- use openmp && [[ $(tc-getCC)$ == icc* ]] && append-ldflags $(no-as-needed)
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2.1-as-needed.patch
-
- # fix info file for category directory
- sed -i \
- -e 's/Texinfo documentation system/Libraries/' \
- doc/fftw3.info || die "failed to fix info file"
-
- rm m4/lt* m4/libtool.m4
-
- AT_M4DIR=m4 eautoreconf
- for x in ${FFTW_DIRS}; do
- mkdir "${S}-${x}" || die
- done
-}
-
-src_configure() {
- # filter -Os according to docs
- replace-flags -Os -O2
-
- local myconfcommon="--enable-shared
- $(use_enable fortran)
- ${FFTW_THREADS}"
-
- local myconfsingle="${myconfcommon} --enable-single"
- local myconfdouble="${myconfcommon}"
- local myconflongdouble="${myconfcommon} --enable-long-double"
- if use sse2; then
- myconfsingle="${myconfsingle} --enable-sse"
- myconfdouble="${myconfdouble} --enable-sse2"
- elif use sse; then
- myconfsingle="${myconfsingle} --enable-sse"
- fi
- # altivec only helps singles, not doubles
- if use altivec; then
- myconfsingle="${myconfsingle} --enable-altivec"
- fi
-
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}"
- einfo "Configuring for ${x} precision"
- local p=myconf${x}
- ECONF_SOURCE="${S}" econf ${!p}
- done
-}
-
-src_compile() {
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}"
- einfo "Compiling for ${x} precision"
- emake || die "emake for ${x} precision failed"
- done
-}
-
-src_test () {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- #local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}/tests"
- einfo "Testing ${x} precision"
- emake -j1 check || die "emake test ${x} failed"
- done
-}
-
-src_install () {
- # all builds are installed in the same place
- # libs have distinuguished names; include files, docs etc. identical.
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}"
- emake DESTDIR="${D}" install || die "emake install for ${x} failed"
- done
-
- cd "${S}"
- dodoc AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS
- if use doc; then
- cd doc
- insinto /usr/share/doc/${PF}
- doins -r html fftw3.pdf || die "doc install failed"
- insinto /usr/share/doc/${PF}/faq
- doins FAQ/fftw-faq.html/*
- fi
-}
diff --git a/sci-libs/fftw/fftw-3.3.3-r1.ebuild b/sci-libs/fftw/fftw-3.3.3-r1.ebuild
deleted file mode 100644
index 9c192d6e6606..000000000000
--- a/sci-libs/fftw/fftw-3.3.3-r1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.3-r1.ebuild,v 1.5 2013/06/27 14:30:29 aballier Exp $
-
-EAPI=5
-
-#AUTOTOOLS_AUTORECONF=1
-FORTRAN_NEEDED=fortran
-
-inherit autotools-multilib eutils flag-o-matic fortran-2 toolchain-funcs versionator
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-SRC_URI="http://www.fftw.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs test threads zbus"
-
-# there is no abi_x86_32 port of virtual/mpi right now
-REQUIRED_USE="amd64? ( abi_x86_32? ( !mpi !quad ) )"
-
-RDEPEND="mpi? ( virtual/mpi )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2
- !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/perl )"
-
-pkg_setup() {
- if use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
- fortran-2_pkg_setup
- FFTW_DIRS="single double longdouble"
- if use quad; then
- if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
- ewarn "quad precision only available for gcc >= 4.6"
- die "need quad precision capable gcc"
- fi
- FFTW_DIRS+=" quad"
- fi
-}
-
-src_prepare() {
- # fix info file for category directory
- sed -i \
- -e 's/Texinfo documentation system/Libraries/' \
- doc/fftw3.info || die "failed to fix info file"
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local x
-
- # filter -Os according to docs
- replace-flags -Os -O2
-
- for x in ${FFTW_DIRS}; do
- myeconfargs=(
- $(use_enable fma)
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- $(use_enable threads)
- $(use_enable openmp)
- )
- if [[ $x == single ]]; then
- #altivec, sse, single-paired only work for single
- myeconfargs+=(
- --enable-single
- $(use_enable altivec)
- $(use_enable avx)
- $(use_enable sse)
- $(use_enable mpi)
- $(use_enable neon)
- )
- elif [[ $x == double ]]; then
- myeconfargs+=(
- $(use_enable avx)
- $(use_enable sse2)
- $(use_enable mpi)
- )
- elif [[ $x == longdouble ]]; then
- myeconfargs+=(
- --enable-long-double
- $(use_enable mpi)
- )
- elif [[ $x == quad ]]; then
- #quad does not support mpi
- myeconfargs+=( --enable-quad-precision )
- else
- die "${x} precision not implemented in this ebuild"
- fi
-
- einfo "Configuring for ${x} precision"
- BUILD_DIR="${S}-${x}" \
- autotools-multilib_src_configure
- done
-}
-
-src_compile() {
- for x in ${FFTW_DIRS}; do
- einfo "Compiling for ${x} precision"
- BUILD_DIR="${S}-${x}" \
- autotools-multilib_src_compile
- done
-}
-
-src_test () {
- do_smalltest() { cd "${BUILD_DIR}" && emake -C tests smallcheck; }
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- #local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
- for x in ${FFTW_DIRS}; do
- einfo "Testing ${x} precision"
- BUILD_DIR="${S}-${x}" \
- multilib_foreach_abi do_smalltest
- done
-}
-
-src_install () {
- local u x
- DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
- HTML_DOCS=( doc/html/ )
- for x in ${FFTW_DIRS}; do
- BUILD_DIR="${S}-${x}" \
- autotools-multilib_src_install
- done
-
- if use doc; then
- dodoc doc/*.pdf
- insinto /usr/share/doc/${PF}/faq
- doins -r doc/FAQ/fftw-faq.html/*
- else
- rm -r "${ED}"/usr/share/doc/${PF}/html
- fi
-
- for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
- done
- done
-}
diff --git a/sci-libs/fftw/fftw-3.3.3.ebuild b/sci-libs/fftw/fftw-3.3.3.ebuild
deleted file mode 100644
index 1a9518a28649..000000000000
--- a/sci-libs/fftw/fftw-3.3.3.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.3.ebuild,v 1.2 2012/12/08 22:18:24 ottxor Exp $
-
-EAPI=4
-
-#AUTOTOOLS_AUTORECONF=1
-FORTRAN_NEEDED=fortran
-
-inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs versionator
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-SRC_URI="http://www.fftw.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs threads zbus"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
- fortran-2_pkg_setup
- FFTW_DIRS="single double longdouble"
- if use quad; then
- if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
- ewarn "quad precision only available for gcc >= 4.6"
- die "need quad precision capable gcc"
- fi
- FFTW_DIRS+=" quad"
- fi
-}
-
-src_prepare() {
- # fix info file for category directory
- sed -i \
- -e 's/Texinfo documentation system/Libraries/' \
- doc/fftw3.info || die "failed to fix info file"
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local x
-
- # filter -Os according to docs
- replace-flags -Os -O2
-
- for x in ${FFTW_DIRS}; do
- myeconfargs=(
- $(use_enable fma)
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- $(use_enable threads)
- $(use_enable openmp)
- )
- if [[ $x == single ]]; then
- #altivec, sse, single-paired only work for single
- myeconfargs+=(
- --enable-single
- $(use_enable altivec)
- $(use_enable avx)
- $(use_enable sse)
- $(use_enable mpi)
- $(use_enable neon)
- )
- elif [[ $x == double ]]; then
- myeconfargs+=(
- $(use_enable avx)
- $(use_enable sse2)
- $(use_enable mpi)
- )
- elif [[ $x == longdouble ]]; then
- myeconfargs+=(
- --enable-long-double
- $(use_enable mpi)
- )
- elif [[ $x == quad ]]; then
- #quad does not support mpi
- myeconfargs+=( --enable-quad-precision )
- else
- die "${x} precision not implemented in this ebuild"
- fi
-
- einfo "Configuring for ${x} precision"
- BUILD_DIR="${S}-${x}" \
- autotools-utils_src_configure
- done
-}
-
-src_compile() {
- for x in ${FFTW_DIRS}; do
- einfo "Compiling for ${x} precision"
- BUILD_DIR="${S}-${x}" \
- autotools-utils_src_compile
- done
-}
-
-src_test () {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- #local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}/tests"
- einfo "Testing ${x} precision"
- emake smallcheck
- done
-}
-
-src_install () {
- local u x
- DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
- HTML_DOCS=( doc/html/ )
- for x in ${FFTW_DIRS}; do
- BUILD_DIR="${S}-${x}" \
- autotools-utils_src_install
- done
-
- if use doc; then
- dodoc doc/*.pdf
- insinto /usr/share/doc/${PF}/faq
- doins -r doc/FAQ/fftw-faq.html/*
- else
- rm -r "${ED}"/usr/share/doc/${PF}/html
- fi
-
- for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
- done
- done
-}
diff --git a/sci-libs/fftw/files/fftw-3.2.1-as-needed.patch b/sci-libs/fftw/files/fftw-3.2.1-as-needed.patch
deleted file mode 100644
index ee9c12a4df59..000000000000
--- a/sci-libs/fftw/files/fftw-3.2.1-as-needed.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-diff -Nur fftw-3.2.1.orig/configure.ac fftw-3.2.1/configure.ac
---- fftw-3.2.1.orig/configure.ac 2009-02-20 19:28:55.832163268 +0000
-+++ fftw-3.2.1/configure.ac 2009-02-26 15:02:37.533259854 +0000
-@@ -440,14 +440,15 @@
- AC_ARG_WITH(combined-threads, [AC_HELP_STRING([--with-combined-threads],[combine threads into main libfftw3])], with_combined_threads=$withval, with_combined_threads=no)
-
- if test "$enable_openmp"x != nox; then
-- AX_OPENMP([THREADLIBS=" "
-+ AX_OPENMP([THREADLIBS="$OPENMP_LIBS"
- AC_DEFINE(USING_OPENMP_THREADS, 1, [Define if we have and are using OpenMP multithreading directives])
- CFLAGS="$CFLAGS $OPENMP_CFLAGS"],
-- [AC_MSG_ERROR([don't know how to enable OpenMP])])
-+ [AC_MSG_WARN([don't know how to enable OpenMP, reverting to POSIX threads])])
-+else
-+ THREADLIBS=""
- fi
-
- dnl Check for threads library...
--THREADLIBS=""
- if test "$enable_threads" = "yes"; then
- # POSIX threads, the default choice:
- if test -z "$THREADLIBS"; then
-diff -Nur fftw-3.2.1.orig/m4/ax_openmp.m4 fftw-3.2.1/m4/ax_openmp.m4
---- fftw-3.2.1.orig/m4/ax_openmp.m4 2009-02-20 19:28:55.792160754 +0000
-+++ fftw-3.2.1/m4/ax_openmp.m4 2009-02-26 15:02:08.887255943 +0000
-@@ -54,13 +54,18 @@
- done
- []_AC_LANG_PREFIX[]FLAGS=$save[]_AC_LANG_PREFIX[]FLAGS
- ])
-+OPENMP_LIBS=" "
- if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" = "xunknown"; then
- m4_default([$2],:)
- else
- if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" != "xnone"; then
- OPENMP_[]_AC_LANG_PREFIX[]FLAGS=$ax_cv_[]_AC_LANG_ABBREV[]_openmp
-+ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" = "x-fopenmp"; then
-+ OPENMP_LIBS="-lgomp"
-+ fi
- fi
- m4_default([$1], [AC_DEFINE(HAVE_OPENMP,1,[Define if OpenMP is enabled])])
- fi
- AC_SUBST(OPENMP_[]_AC_LANG_PREFIX[]FLAGS)
-+AC_SUBST(OPENMP_LIBS)
- ])dnl AX_OPENMP
-diff -Nur fftw-3.2.1.orig/Makefile.am fftw-3.2.1/Makefile.am
---- fftw-3.2.1.orig/Makefile.am 2009-02-20 19:28:56.040169973 +0000
-+++ fftw-3.2.1/Makefile.am 2009-02-26 15:02:08.887255943 +0000
-@@ -36,6 +36,13 @@
- if SMP
- if COMBINED_THREADS
- COMBINED_THREADLIBS=threads/libfftw3@PREC_SUFFIX@_threads.la
-+else
-+lib_LTLIBRARIES += libfftw3@PREC_SUFFIX@_threads.la
-+libfftw3@PREC_SUFFIX@_threads_la_SOURCES =
-+libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
-+libfftw3@PREC_SUFFIX@_threads_la_LIBADD = \
-+ libfftw3@PREC_SUFFIX@.la \
-+ threads/libfftw3@PREC_SUFFIX@_threads.la
- endif
- endif
-
-diff -Nur fftw-3.2.1.orig/threads/Makefile.am fftw-3.2.1/threads/Makefile.am
---- fftw-3.2.1.orig/threads/Makefile.am 2009-02-20 19:28:55.832163268 +0000
-+++ fftw-3.2.1/threads/Makefile.am 2009-02-26 15:02:08.887255943 +0000
-@@ -2,11 +2,7 @@
- -I$(top_srcdir)/rdft -I$(top_srcdir)/api
-
- if SMP
--if COMBINED_THREADS
- noinst_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
--else
--lib_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
--endif
- endif
-
- # pkgincludedir = $(includedir)/fftw3@PREC_SUFFIX@
-@@ -16,4 +12,5 @@
- openmp.c threads.h dft-vrank-geq1.c ct.c rdft-vrank-geq1.c hc2hc.c \
- vrank-geq1-rdft2.c f77api.c f77funcs.h
-
-+libfftw3@PREC_SUFFIX@_threads_la_LIBADD = $(THREADLIBS)
- libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
diff --git a/sci-libs/fftw/files/fftw-3.2.2-pc-threads.patch b/sci-libs/fftw/files/fftw-3.2.2-pc-threads.patch
deleted file mode 100644
index d3fe6aa47260..000000000000
--- a/sci-libs/fftw/files/fftw-3.2.2-pc-threads.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index 0231ab8..2e26035 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -61,9 +61,12 @@ libfftw3@PREC_SUFFIX@_la_LDFLAGS = -no-undefined -version-info \
-
- fftw3@PREC_SUFFIX@.pc: fftw.pc
- cp -f fftw.pc fftw3@PREC_SUFFIX@.pc
-+fftw3@PREC_SUFFIX@_threads.pc: fftw.pc
-+ cp -f fftw.pc fftw3@PREC_SUFFIX@_threads.pc
-+ sed 's|-lfftw3@PREC_SUFFIX@|-lfftw3@PREC_SUFFIX@_threads|g' \
-+ -i fftw3@PREC_SUFFIX@_threads.pc
- pkgconfigdir = $(libdir)/pkgconfig
--pkgconfig_DATA = fftw3@PREC_SUFFIX@.pc
--
-+pkgconfig_DATA = fftw3@PREC_SUFFIX@.pc fftw3@PREC_SUFFIX@_threads.pc
- WISDOM_DIR = /etc/fftw
- WISDOM = wisdom@PREC_SUFFIX@
-
diff --git a/sci-libs/fftw/metadata.xml b/sci-libs/fftw/metadata.xml
index ec2aafe5eb8a..c7ae6003bbab 100644
--- a/sci-libs/fftw/metadata.xml
+++ b/sci-libs/fftw/metadata.xml
@@ -16,7 +16,6 @@
<flag name="float">Link default library to single precision instead of
double (symlinks only and fftw-2.1)</flag>
<flag name="fma">Use the Fused Multiply Add instruction set (fma3/fma4 either one)</flag>
- <flag name="paired-single">Adds support for pair-single optimizations of mips</flag>
<flag name="quad">Build quadruple precision lib</flag>
<flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>
</use>