summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-01-09 19:54:40 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-01-09 19:54:40 +0000
commit15c4f2cb7767141dd3219c668491d604ae3ae6aa (patch)
tree5a9b0d1894b653115a09d55074f6c9171494355c /sci-libs
parentAdded big fat warning for sparc wrt #96229 and #118114 (diff)
downloadgentoo-2-15c4f2cb7767141dd3219c668491d604ae3ae6aa.tar.gz
gentoo-2-15c4f2cb7767141dd3219c668491d604ae3ae6aa.tar.bz2
gentoo-2-15c4f2cb7767141dd3219c668491d604ae3ae6aa.zip
New atlas3.6.0-shared-libs.1.patch fixes insecure RUNPATH issues. This closes bug #114587.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog11
-rw-r--r--sci-libs/blas-atlas/Manifest14
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild171
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r12
4 files changed, 190 insertions, 8 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 12d55e11f19f..c480754b5885 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/blas-atlas
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.8 2005/09/10 12:11:53 pbienst Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.9 2006/01/09 19:54:40 markusle Exp $
+
+*blas-atlas-3.6.0-r1 (09 Jan 2006)
+
+ 09 Jan 2006; Markus Dittrich <markusle@gentoo.org>
+ +blas-atlas-3.6.0-r1.ebuild:
+ New atlas3.6.0-shared-libs.1.patch fixes insecure RUNPATH issues.
+ This closes bug #114587.
10 Sep 2005; Peter Bienstman <pbienst@gentoo.org> blas-atlas-3.6.0.ebuild,
blas-atlas-3.7.10.ebuild:
diff --git a/sci-libs/blas-atlas/Manifest b/sci-libs/blas-atlas/Manifest
index 9c0350bfcb1f..2aea6f64c9dc 100644
--- a/sci-libs/blas-atlas/Manifest
+++ b/sci-libs/blas-atlas/Manifest
@@ -1,12 +1,14 @@
+MD5 3537475cb03601872791bdeb62ebcbbd ChangeLog 4398
+MD5 2f87fdbe884c26e288885d1f68fad984 blas-atlas-3.6.0-r1.ebuild 4267
MD5 a03adf0e7bb8af668f84c7fc7b2b9760 blas-atlas-3.6.0.ebuild 4255
MD5 8c1cc8c544ae94b121fba5560e828448 blas-atlas-3.7.10.ebuild 4167
-MD5 5486c4eb94a0b0d694c14787e05d3654 ChangeLog 4182
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 13d26350d75e6993f1b3ec48ca97f14e files/war 545
MD5 73bb69e091e5629e3d47ec813d560223 files/c-ATLAS 497
-MD5 646c8df3efa24d6573a870dbb0f5fc8d files/f77-ATLAS 457
MD5 869c65bd1672b6bea4f03520e7e1cdf9 files/c-threaded-ATLAS 563
-MD5 c0a79db6ec6fb95a56ce677107f08c01 files/f77-threaded-ATLAS 492
+MD5 c1c57e922c1763ddde357504442e94c4 files/digest-blas-atlas-3.6.0 139
+MD5 e49de689884ec7c24e160930c9080466 files/digest-blas-atlas-3.6.0-r1 141
MD5 e092f2baac7a6c4e34591acb77552017 files/digest-blas-atlas-3.7.10 140
+MD5 646c8df3efa24d6573a870dbb0f5fc8d files/f77-ATLAS 457
+MD5 c0a79db6ec6fb95a56ce677107f08c01 files/f77-threaded-ATLAS 492
MD5 e362a664ac2e543545706b85664af921 files/unbuffered.patch 497
-MD5 c1c57e922c1763ddde357504442e94c4 files/digest-blas-atlas-3.6.0 139
+MD5 13d26350d75e6993f1b3ec48ca97f14e files/war 545
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
diff --git a/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild b/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..b398e974b1dd
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild,v 1.1 2006/01/09 19:54:40 markusle Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/atlas${PV}-shared-libs.1.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~ppc64 ~sparc ~alpha"
+IUSE="doc"
+
+DEPEND="sci-libs/blas-config
+ >=sys-devel/libtool-1.5"
+
+RDEPEND=""
+
+PROVIDE="virtual/blas"
+
+S=${WORKDIR}/ATLAS
+
+# Libraries will be installed in ${RPATH}/atlas
+# and ${RPATH}/threaded-atlas:
+RPATH="${DESTTREE}/lib/blas"
+
+
+pkg_setup() {
+ if [ -z `which g77` ]; then
+ eerror "No fortran compiler found on the system!"
+ eerror "Please add fortran to your USE flags and reemerge gcc!"
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ epatch ${FILESDIR}/unbuffered.patch
+ epatch ${DISTDIR}/atlas3.6.0-shared-libs.1.patch.bz2
+ sed -i -e "s:ASM:ASM VOLATILE:" include/contrib/camm_dpa.h || die "sed failed to fix clobbering"
+ cp ${FILESDIR}/war ${S}
+ chmod a+x ${S}/war
+}
+
+atlas_fail() {
+ eerror
+ eerror "ATLAS auto-config failed."
+ eerror "Please run 'interactive=1 emerge blas-atlas' to configure manually."
+ eerror
+ die "ATLAS auto-config failed."
+}
+
+# Added to allow compilation on sparc architecture. The default CCFLAG0
+# and MMFLAGS are *bad*.
+# Danny van Dyk <kugelfang@gentoo.org> 2004/07/02
+#
+reconfigure() {
+ case "`uname -p`" in
+ "sun4m")
+ MY_CCFLAGS="-O3 -mcpu=v8"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=v8"
+ MY_LDFLAGS=""
+ ;;
+ "sun4u")
+ MY_CCFLAGS="-O3 -mcpu=ultrasparc"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=ultrasparc"
+ MY_LDFLAGS=""
+ ;;
+ *)
+ MY_CCFLAGS="${CFLAGS}"
+ MY_CXXFLAGS="${CXXFLAGS}"
+ MY_MMFLAGS="${CFLAGS}"
+ MY_LDFLAGS="${LDFLAGS}"
+ ;;
+ esac
+
+ MY_FILE="`find -name Make.Linux*`"
+
+ sed -i -e "s/CCFLAG0 =.*/CCFLAG0 = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CCFLAGS =.*/CCFLAGS = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CLINKFLAGS =.*/CLINKFLAGS =\$(CDEFS) ${MY_LDFLAGS}/" \
+ -e "s/XCCFLAGS =.*/XCCFLAGS =\$(CDEFS) ${MY_CXXFLAGS}/" \
+ -e "s/MMFLAGS =.*/MMFLAGS = ${MY_MMFLAGS}/" \
+ ${MY_FILE} || die "sed didnt complete"
+
+}
+
+src_compile() {
+ if [ -n "${interactive}" ]
+ then
+ echo "${interactive}"
+ make config CC="$(tc-getCC) -DUSE_LIBTOOL -DINTERACTIVE" || die
+ else
+ # Use ATLAS defaults for all questions:
+ (echo | make config CC="$(tc-getCC) -DUSE_LIBTOOL") || atlas_fail
+ fi
+
+ reconfigure
+
+ TMPSTR=$(ls Make.Linux*)
+ ATLAS_ARCH=${TMPSTR#'Make.'}
+
+ make install arch=${ATLAS_ARCH} || die
+
+ make shared-strip arch=${ATLAS_ARCH} RPATH=${RPATH}/atlas || die
+
+ # Build shared versions of the threaded libs.
+ # ATLAS only compiles threaded libs on multiprocessor machines.
+ if [ -d gentoo/libptf77blas.a ]
+ then
+ make ptshared-strip \
+ arch=${ATLAS_ARCH} RPATH=${RPATH}/threaded-atlas || die
+ fi
+}
+
+src_install () {
+ dodir ${RPATH}/atlas
+ cd ${S}/gentoo/libs
+ cp -P libatlas* ${D}/${DESTTREE}/lib
+ cp -P *blas* ${D}/${RPATH}/atlas #the rest really
+
+ insinto ${RPATH}
+ doins ${FILESDIR}/c-ATLAS ${FILESDIR}/f77-ATLAS
+
+ if [ -d ${S}/gentoo/threaded-libs ]
+ then
+ dodir ${RPATH}/threaded-atlas
+ cd ${S}/gentoo/threaded-libs
+ cp -P * ${D}/${RPATH}/threaded-atlas
+ doins ${FILESDIR}/c-threaded-ATLAS ${FILESDIR}/f77-threaded-ATLAS
+ fi
+
+ insinto ${DESTTREE}/include/atlas
+ doins ${S}/include/cblas.h ${S}/include/atlas_misc.h
+ doins ${S}/include/atlas_enum.h
+
+ # These headers contain the architecture-specific optimizations determined
+ # by ATLAS. The atlas-lapack build is much shorter if they are available,
+ # so save them:
+ doins ${S}/include/${ATLAS_ARCH}/*.h
+
+ #some docs
+ cd ${S}
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ if [ -d ${RPATH}/threaded-atlas ]
+ then
+ ${DESTTREE}/bin/blas-config threaded-ATLAS
+ else
+ ${DESTTREE}/bin/blas-config ATLAS
+ fi
+
+ einfo
+ einfo "Fortran users link using -lblas"
+ einfo
+ einfo "C users compile against the header /usr/include/atlas/cblas.h and"
+ einfo "link using -lcblas"
+ einfo
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r1 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r1
new file mode 100644
index 000000000000..785233e84879
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.6.0-r1
@@ -0,0 +1,2 @@
+MD5 d2940721d6592f43a5d2e7740d13076d atlas3.6.0-shared-libs.1.patch.bz2 5148
+MD5 df2ee2eb65d1c08ee93d04370172c262 atlas3.6.0.tar.bz2 1687723