summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-30 07:38:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-30 07:38:42 +0000
commit0cb52da1e3afcb68ceb2e53617aa1b8027b588de (patch)
tree9fce325af7c51cfb3ce9c7fcb69285bf729b1cdd /sci-libs
parentObsolete reiserfsprogs mask. (diff)
downloadgentoo-2-0cb52da1e3afcb68ceb2e53617aa1b8027b588de.tar.gz
gentoo-2-0cb52da1e3afcb68ceb2e53617aa1b8027b588de.tar.bz2
gentoo-2-0cb52da1e3afcb68ceb2e53617aa1b8027b588de.zip
Fix building with GCC 4.4 wrt #275916.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/files/itpp-4.0.6-gcc44.patch60
-rw-r--r--sci-libs/itpp/itpp-4.0.6.ebuild9
3 files changed, 73 insertions, 4 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index c18a08e29fae..7268b7d22a1d 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/itpp
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.87 2008/11/26 16:54:23 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.88 2009/07/30 07:38:42 ssuominen Exp $
+
+ 30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> itpp-4.0.6.ebuild,
+ +files/itpp-4.0.6-gcc44.patch:
+ Fix building with GCC 4.4 wrt #275916.
26 Nov 2008; Brent Baude <ranger@gentoo.org> itpp-4.0.5.ebuild:
stable ppc64, bug 244832
diff --git a/sci-libs/itpp/files/itpp-4.0.6-gcc44.patch b/sci-libs/itpp/files/itpp-4.0.6-gcc44.patch
new file mode 100644
index 000000000000..6514363a4b48
--- /dev/null
+++ b/sci-libs/itpp/files/itpp-4.0.6-gcc44.patch
@@ -0,0 +1,60 @@
+diff -ur itpp-4.0.6.orig/itpp/base/timing.cpp itpp-4.0.6/itpp/base/timing.cpp
+--- itpp-4.0.6.orig/itpp/base/timing.cpp 2008-10-08 14:52:24.000000000 +0300
++++ itpp-4.0.6/itpp/base/timing.cpp 2009-07-30 10:32:45.000000000 +0300
+@@ -27,6 +27,8 @@
+ * -------------------------------------------------------------------------
+ */
+
++#include <cstdio>
++
+ #ifndef _MSC_VER
+ # include <itpp/config.h>
+ #else
+diff -ur itpp-4.0.6.orig/itpp/base/vec.cpp itpp-4.0.6/itpp/base/vec.cpp
+--- itpp-4.0.6.orig/itpp/base/vec.cpp 2008-10-08 14:52:24.000000000 +0300
++++ itpp-4.0.6/itpp/base/vec.cpp 2009-07-30 10:35:45.000000000 +0300
+@@ -27,6 +27,8 @@
+ * -------------------------------------------------------------------------
+ */
+
++#include <cstdio>
++
+ #include <itpp/base/vec.h>
+ #include <itpp/base/converters.h>
+ #include <limits>
+diff -ur itpp-4.0.6.orig/itpp/fixed/cfix.cpp itpp-4.0.6/itpp/fixed/cfix.cpp
+--- itpp-4.0.6.orig/itpp/fixed/cfix.cpp 2008-10-08 14:52:24.000000000 +0300
++++ itpp-4.0.6/itpp/fixed/cfix.cpp 2009-07-30 10:37:21.000000000 +0300
+@@ -27,6 +27,8 @@
+ * -------------------------------------------------------------------------
+ */
+
++#include <cstdio>
++
+ #include <itpp/fixed/cfix.h>
+ #include <itpp/base/itassert.h>
+ #include <iostream>
+diff -ur itpp-4.0.6.orig/itpp/fixed/fix.cpp itpp-4.0.6/itpp/fixed/fix.cpp
+--- itpp-4.0.6.orig/itpp/fixed/fix.cpp 2008-10-08 14:52:24.000000000 +0300
++++ itpp-4.0.6/itpp/fixed/fix.cpp 2009-07-30 10:37:39.000000000 +0300
+@@ -27,6 +27,8 @@
+ * -------------------------------------------------------------------------
+ */
+
++#include <cstdio>
++
+ #include <itpp/fixed/fix.h>
+ #include <itpp/base/itassert.h>
+ #include <iostream>
+diff -ur itpp-4.0.6.orig/itpp/fixed/fixed.cpp itpp-4.0.6/itpp/fixed/fixed.cpp
+--- itpp-4.0.6.orig/itpp/fixed/fixed.cpp 2008-10-08 14:52:24.000000000 +0300
++++ itpp-4.0.6/itpp/fixed/fixed.cpp 2009-07-30 10:37:03.000000000 +0300
+@@ -27,6 +27,8 @@
+ * -------------------------------------------------------------------------
+ */
+
++#include <cstdio>
++
+ #include <itpp/fixed/fixed.h>
+
+
diff --git a/sci-libs/itpp/itpp-4.0.6.ebuild b/sci-libs/itpp/itpp-4.0.6.ebuild
index d699f0e9a7c1..e95890fc4b63 100644
--- a/sci-libs/itpp/itpp-4.0.6.ebuild
+++ b/sci-libs/itpp/itpp-4.0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.1 2008/10/08 22:50:58 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.2 2009/07/30 07:38:42 ssuominen Exp $
inherit fortran flag-o-matic
@@ -31,6 +31,11 @@ pkg_setup() {
fi
}
+src_unpack() {
+ fortran_src_unpack
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
src_compile() {
# turn off performance critical debug code
append-flags -DNDEBUG