summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-06-17 08:51:50 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-06-17 08:51:50 +0000
commited02be5f0cac89f9c6163b180b3580a8de281ce9 (patch)
tree902746a8038e50d4625c87ef136172cf98a75a82 /sci-libs/votca-tools
parentVersion bump to the latest. Drop older. (diff)
downloadgentoo-2-ed02be5f0cac89f9c6163b180b3580a8de281ce9.tar.gz
gentoo-2-ed02be5f0cac89f9c6163b180b3580a8de281ce9.tar.bz2
gentoo-2-ed02be5f0cac89f9c6163b180b3580a8de281ce9.zip
[sci-libs/votca-tools] version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/ChangeLog7
-rw-r--r--sci-libs/votca-tools/votca-tools-1.2.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index 1032b4b7ef0f..41c0d3bb24f4 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/votca-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.4 2011/04/04 19:56:40 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.5 2011/06/17 08:51:50 ottxor Exp $
+
+*votca-tools-1.2 (17 Jun 2011)
+
+ 17 Jun 2011; Christoph Junghans <ottxor@gentoo.org> +votca-tools-1.2.ebuild:
+ Version bump
*votca-tools-1.1.2 (04 Apr 2011)
diff --git a/sci-libs/votca-tools/votca-tools-1.2.ebuild b/sci-libs/votca-tools/votca-tools-1.2.ebuild
new file mode 100644
index 000000000000..0e8f17eafc45
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.2.ebuild,v 1.1 2011/06/17 08:51:50 ottxor Exp $
+
+EAPI="3"
+
+inherit eutils cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="boost? ( http://votca.googlecode.com/files/${PF}_pristine.tar.gz )
+ !boost? ( http://votca.googlecode.com/files/${PF}.tar.gz )"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://tools.votca.googlecode.com/hg"
+ EHG_REVISION="default"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="-boost doc +fftw +gsl sqlite"
+
+RDEPEND="fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/expat
+ gsl? ( sci-libs/gsl )
+ boost? ( dev-libs/boost )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[-nodot] )
+ >=app-text/txt2tags-2.5
+ dev-util/pkgconfig"
+
+src_prepare() {
+ use gsl || ewarn "Disabling gsl will lead to reduced functionality"
+ use fftw || ewarn "Disabling fftw will lead to reduced functionality"
+
+ #remove bundled libs
+ if use boost; then
+ rm -rf src/libboost
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use boost EXTERNAL_BOOST)
+ $(cmake-utils_use_with gsl GSL)
+ $(cmake-utils_use_with fftw FFTW)
+ $(cmake-utils_use_with sqlite SQLITE3)
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure || die
+}
+
+src_install() {
+ DOCS=(${CMAKE_BUILD_DIR}/CHANGELOG NOTICE)
+ cmake-utils_src_install || die
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}" || die
+ cd share/doc || die
+ doxygen || die
+ dohtml -r html/* || die
+ fi
+}