summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-01 18:25:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-01 18:25:37 +0000
commit938ace475b80af04d0bd8a1df47a1ee34976d231 (patch)
tree24d04d0c6508aac038670d652efd0c92723aae79 /sci-libs/qrupdate
parentStable for HPPA too. (diff)
downloadgentoo-2-938ace475b80af04d0bd8a1df47a1ee34976d231.tar.gz
gentoo-2-938ace475b80af04d0bd8a1df47a1ee34976d231.tar.bz2
gentoo-2-938ace475b80af04d0bd8a1df47a1ee34976d231.zip
restored qrupdate for stable arches
(Portage version: 2.1.9.25/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-libs/qrupdate')
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/qrupdate/qrupdate-1.1.0.ebuild b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
new file mode 100644
index 000000000000..7a6b7f20a669
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.0.ebuild,v 1.9 2010/12/01 18:25:37 bicatali Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A library for fast updating of QR and Cholesky decompositions"
+HOMEPAGE="http://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/qrupdate/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-makefile.patch
+
+ local BLAS_LIBS="$(pkg-config --libs blas)"
+ local LAPACK_LIBS="$(pkg-config --libs lapack)"
+
+ sed -i Makeconf \
+ -e "s:gfortran:$(tc-getFC):g" \
+ -e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
+ -e "s:BLAS=.*:BLAS=${BLAS_LIBS}:" \
+ -e "s:LAPACK=.*:LAPACK=${LAPACK_LIBS}:" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib || die "emake failed"
+}
+
+src_install() {
+ dolib.so libqrupdate.so \
+ || die "Failed to install libqrupdate.so"
+
+ dodoc README ChangeLog || die "dodoc failed"
+}