summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-20 16:56:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-20 16:56:52 +0000
commit02e0311168b20f7d65f91e3d5a67b1056ea18592 (patch)
treee8ed14f78e678a511cb141bfd4f3288e0ac13ce8 /sci-libs/nlopt
parentold (diff)
downloadgentoo-2-02e0311168b20f7d65f91e3d5a67b1056ea18592.tar.gz
gentoo-2-02e0311168b20f7d65f91e3d5a67b1056ea18592.tar.bz2
gentoo-2-02e0311168b20f7d65f91e3d5a67b1056ea18592.zip
Switched to autotools-utils
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/nlopt')
-rw-r--r--sci-libs/nlopt/ChangeLog7
-rw-r--r--sci-libs/nlopt/nlopt-2.2.4.ebuild35
2 files changed, 21 insertions, 21 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index a7a67101fc44..f12d5cda71a0 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/nlopt
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.9 2011/07/28 23:51:13 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.10 2012/01/20 16:56:52 bicatali Exp $
+
+ 20 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> nlopt-2.2.4.ebuild:
+ Switched to autotools-utils
*nlopt-2.2.4 (28 Jul 2011)
diff --git a/sci-libs/nlopt/nlopt-2.2.4.ebuild b/sci-libs/nlopt/nlopt-2.2.4.ebuild
index 392d903431c9..c846c1109df1 100644
--- a/sci-libs/nlopt/nlopt-2.2.4.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.4.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.1 2011/07/28 23:51:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.2 2012/01/20 16:56:52 bicatali Exp $
-EAPI=3
+EAPI=4
SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="python? *"
RESTRICT_PYTHON_ABIS="3.*"
-inherit eutils python
+inherit python autotools-utils
DESCRIPTION="Non-linear optimization library"
HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
@@ -41,21 +41,21 @@ src_configure() {
else
export MKOCTFILE=None
fi
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_with cxx) \
- $(use_with guile) \
- $(use_with octave) \
+ myeconfargs+=(
+ $(use_with cxx)
+ $(use_with guile)
+ $(use_with octave)
$(use_with python)
+ )
use python && python_copy_sources swig
+ autotools-utils_src_configure
}
src_compile() {
- default
+ autotools-utils_src_compile
if use python; then
compilation() {
- emake \
+ autotools-utils_src_compile \
PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
PYTHON_LDFLAGS="$(python_get_library -l)" \
PYTHON_SITE_PKG="$(python_get_sitedir)" \
@@ -67,20 +67,17 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ autotools-utils_src_install
if use python; then
installation() {
- emake \
- DESTDIR="${D}" \
+ autotools-utils_src_install \
pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install
+ pythondir="$(python_get_sitedir)"
}
python_execute_function -s --source-dir swig installation
python_clean_installation_image
fi
-
- dodoc AUTHORS ChangeLog NEWS README || die
+ local r
for r in */README; do newdoc ${r} README.$(dirname ${r}); done
}