summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-01-10 18:55:41 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-01-10 18:55:41 +0000
commitf89aa6cd540e6a00a33392f09c1642fdd11b599b (patch)
tree797a42c09812b1b1a6d00340cd01c08cdcb9dd6d /sci-libs/netcdf-cxx
parentNew pretest version. Upstream now provides a tar.xz archive. (diff)
downloadgentoo-2-f89aa6cd540e6a00a33392f09c1642fdd11b599b.tar.gz
gentoo-2-f89aa6cd540e6a00a33392f09c1642fdd11b599b.tar.bz2
gentoo-2-f89aa6cd540e6a00a33392f09c1642fdd11b599b.zip
Fixed pkg-config file and ncxx4-config script to include netcdf C libraries for as-needed problems
(Portage version: 2.2.01.21476-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/netcdf-cxx')
-rw-r--r--sci-libs/netcdf-cxx/ChangeLog12
-rw-r--r--sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch28
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2-r1.ebuild (renamed from sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild)6
3 files changed, 42 insertions, 4 deletions
diff --git a/sci-libs/netcdf-cxx/ChangeLog b/sci-libs/netcdf-cxx/ChangeLog
index cbd3c7f956e4..ee79b4e54d8f 100644
--- a/sci-libs/netcdf-cxx/ChangeLog
+++ b/sci-libs/netcdf-cxx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/netcdf-cxx
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/ChangeLog,v 1.2 2012/08/02 21:17:56 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/ChangeLog,v 1.3 2013/01/10 18:55:41 bicatali Exp $
+
+*netcdf-cxx-4.2-r1 (10 Jan 2013)
+
+ 10 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/netcdf-cxx-4.2-config.patch, +netcdf-cxx-4.2-r1.ebuild,
+ -netcdf-cxx-4.2.ebuild:
+ Fixed pkg-config file and ncxx4-config script to include netcdf C libraries
+ for as-needed problems
02 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> netcdf-cxx-4.2.ebuild:
Keyword amd64-linux x86-linux
diff --git a/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch b/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch
new file mode 100644
index 000000000000..9de8442516b5
--- /dev/null
+++ b/sci-libs/netcdf-cxx/files/netcdf-cxx-4.2-config.patch
@@ -0,0 +1,28 @@
+--- ncxx4-config.in.orig 2013-01-10 10:47:00.595224631 -0800
++++ ncxx4-config.in 2013-01-10 10:49:22.856926765 -0800
+@@ -5,7 +5,7 @@
+
+ prefix=@prefix@
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
++libdir=@libdir@
+ includedir=${prefix}/include
+
+ cc="@CC@"
+@@ -13,7 +13,7 @@
+ fc="@FC@"
+ cflags=" -I${includedir} @CPPFLAGS@"
+ fflags="@FFLAGS@ @MOD_FLAG@${includedir}"
+-libs="-L${libdir} @NC_LIBS@"
++libs="-L${libdir} @NC_LIBS@ $(nc-config --libs)"
+ flibs="-L${libdir} @NC_FLIBS@"
+ has_dap="@HAS_DAP@"
+ has_nc2="@HAS_NC2@"
+--- netcdf-cxx4.pc.in.orig 2013-01-10 10:46:50.995177250 -0800
++++ netcdf-cxx4.pc.in 2013-01-10 10:49:45.030036161 -0800
+@@ -10,4 +10,4 @@
+ Version: @PACKAGE_VERSION@
+ Libs: -L${libdir} @NC_LIBS@
+ Cflags: -I${includedir}
+-
++Requires: netcdf
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r1.ebuild
index 826098f6d8c4..8550c68b9e04 100644
--- a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild,v 1.2 2012/08/02 21:17:56 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/netcdf-cxx-4.2-r1.ebuild,v 1.1 2013/01/10 18:55:41 bicatali Exp $
EAPI=4
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MYP}"
+PATCHES=( "${FILESDIR}"/${P}-config.patch )
+
src_install() {
autotools-utils_src_install
if use examples; then