summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-12-16 09:55:08 +0000
committerThomas Kahle <tomka@gentoo.org>2010-12-16 09:55:08 +0000
commit63ac68f03162bd11f7073690224dd790efd58ef5 (patch)
tree481aebdb2db65860a1b8938d7df172af42aafe44 /sci-libs/mpir
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-63ac68f03162bd11f7073690224dd790efd58ef5.tar.gz
gentoo-2-63ac68f03162bd11f7073690224dd790efd58ef5.tar.bz2
gentoo-2-63ac68f03162bd11f7073690224dd790efd58ef5.zip
bump to 2.2.0
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'sci-libs/mpir')
-rw-r--r--sci-libs/mpir/ChangeLog8
-rw-r--r--sci-libs/mpir/files/mpir-2.2.0-yasm.patch54
-rw-r--r--sci-libs/mpir/mpir-2.2.0.ebuild65
3 files changed, 126 insertions, 1 deletions
diff --git a/sci-libs/mpir/ChangeLog b/sci-libs/mpir/ChangeLog
index 57e7cfc6ea01..175ed916efe3 100644
--- a/sci-libs/mpir/ChangeLog
+++ b/sci-libs/mpir/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/mpir
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/ChangeLog,v 1.2 2010/11/13 12:51:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/ChangeLog,v 1.3 2010/12/16 09:55:08 tomka Exp $
+
+*mpir-2.2.0 (16 Dec 2010)
+
+ 16 Dec 2010; Thomas Kahle <tomka@gentoo.org> +mpir-2.2.0.ebuild,
+ +files/mpir-2.2.0-yasm.patch:
+ bump to 2.2.0
13 Nov 2010; Justin Lecher <jlec@gentoo.org> mpir-2.1.3.ebuild:
Some QA
diff --git a/sci-libs/mpir/files/mpir-2.2.0-yasm.patch b/sci-libs/mpir/files/mpir-2.2.0-yasm.patch
new file mode 100644
index 000000000000..e717891a4e64
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.2.0-yasm.patch
@@ -0,0 +1,54 @@
+diff -U 3 -dHrN mpir-2.2.0.orig/configure.in mpir-2.2.0/configure.in
+--- mpir-2.2.0.orig/configure.in 2010-12-16 10:16:19.000000000 +0100
++++ mpir-2.2.0/configure.in 2010-12-16 10:16:53.000000000 +0100
+@@ -1455,8 +1455,6 @@
+ ;;
+ esac
+
+-AM_CONDITIONAL(BUILD_YASM, test "$want_yasm" = "yes")
+-
+ CFLAGS_or_unset=${CFLAGS-'(unset)'}
+ CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
+
+@@ -1848,7 +1846,7 @@
+ GMP_CHECK_LIBM_FOR_BUILD
+
+
+-MPIR_AS="/yasm/yasm"
++MPIR_AS="yasm"
+
+ # How to assemble, used with CFLAGS etc, see mpn/Makeasm.am.
+ # Using the compiler is a lot easier than figuring out how to invoke the
+@@ -3161,9 +3159,6 @@
+ # FIXME: Upcoming version of autoconf/automake don't like broken lines.
+ # Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
+
+-# allways configure all subdirectorys , even if there are not going to be built ,
+-AC_CONFIG_SUBDIRS([yasm])
+-
+ case $host in
+ *-w64-mingw*)
+ if test $enable_fat = yes; then
+diff -U 3 -dHrN mpir-2.2.0.orig/Makefile.am mpir-2.2.0/Makefile.am
+--- mpir-2.2.0.orig/Makefile.am 2010-12-16 10:16:21.000000000 +0100
++++ mpir-2.2.0/Makefile.am 2010-12-16 10:17:19.000000000 +0100
+@@ -95,10 +95,6 @@
+
+ SUBDIRS = tests
+
+-if BUILD_YASM
+-SUBDIRS += yasm
+-endif
+-
+ SUBDIRS += mpn mpz mpq mpf printf scanf cxx tune doc
+
+ EXTRA_DIST = configfsf.guess configfsf.sub .gdbinit INSTALL.autoconf
+diff -U 3 -dHrN mpir-2.2.0.orig/mpn/Makeasm.am mpir-2.2.0/mpn/Makeasm.am
+--- mpir-2.2.0.orig/mpn/Makeasm.am 2010-12-16 10:16:18.000000000 +0100
++++ mpir-2.2.0/mpn/Makeasm.am 2010-12-16 10:16:35.000000000 +0100
+@@ -112,4 +112,4 @@
+ # .as assembler, assembled with Yasm
+
+ .as.lo:
+- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(top_builddir)$(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
++ $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
diff --git a/sci-libs/mpir/mpir-2.2.0.ebuild b/sci-libs/mpir/mpir-2.2.0.ebuild
new file mode 100644
index 000000000000..673e770d6eca
--- /dev/null
+++ b/sci-libs/mpir/mpir-2.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/mpir-2.2.0.ebuild,v 1.1 2010/12/16 09:55:08 tomka Exp $
+
+EAPI="3"
+
+inherit eutils autotools
+
+DESCRIPTION="Library for arbitrary precision integer arithmetic derived from version 4.2.1 of gmp"
+HOMEPAGE="http://www.mpir.org/"
+SRC_URI="http://www.mpir.org/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cxx cpudetection"
+
+DEPEND="x86? ( dev-lang/yasm )
+ amd64? ( dev-lang/yasm )"
+RDEPEND=""
+
+src_prepare(){
+ epatch \
+ "${FILESDIR}/${PN}-${PV}-yasm.patch" \
+ "${FILESDIR}/${PN}-1.3.0-ABI-multilib.patch"
+ # In the same way there was QA regarding executable stacks
+ # with GMP we have some here as well. We cannot apply the
+ # GMP solution as yasm is used, at least on x86/amd64.
+ # Furthermore we are able to patch config.ac.
+
+ ebegin "Patching assembler files to remove executable sections"
+
+ for i in $(find . -type f -name '*.asm') ; do
+ cat >> $i <<-EOF
+ #if defined(__linux__) && defined(__ELF__)
+ .section .note.GNU-stack,"",%progbits
+ #endif
+ EOF
+ done
+
+ for i in $(find . -type f -name '*.as') ; do
+ cat >> $i <<-EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+ EOF
+ done
+
+ eend
+
+ eautoreconf
+}
+
+src_configure() {
+# beware that cpudetection aka fat binaries is x86/amd64 only.
+# Place mpir in profiles/arch/$arch/package.use.mask when making it available on $arch.
+ econf \
+ $(use_enable cxx) \
+ $(use_enable cpudetection fat)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README NEWS || die
+}