summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 15:39:09 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-16 15:39:09 +0000
commit2b9e70ceae93584fdd671e98a4e484a19cc4521f (patch)
tree91f5b43d756c875b3a8f660b8e78f291c6222a22 /sci-libs/mmtk
parentAdd new 3.0 development branch ebuild, remove catalyst_3 branch ebuild (diff)
downloadgentoo-2-2b9e70ceae93584fdd671e98a4e484a19cc4521f.tar.gz
gentoo-2-2b9e70ceae93584fdd671e98a4e484a19cc4521f.tar.bz2
gentoo-2-2b9e70ceae93584fdd671e98a4e484a19cc4521f.zip
sci-libs/mmtk: Version Bump and bump to distutils-r1.eclass
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/mmtk')
-rw-r--r--sci-libs/mmtk/ChangeLog10
-rw-r--r--sci-libs/mmtk/metadata.xml2
-rw-r--r--sci-libs/mmtk/mmtk-2.7.9.ebuild57
3 files changed, 66 insertions, 3 deletions
diff --git a/sci-libs/mmtk/ChangeLog b/sci-libs/mmtk/ChangeLog
index cb34c9028cd0..6acdf440faa4 100644
--- a/sci-libs/mmtk/ChangeLog
+++ b/sci-libs/mmtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/mmtk
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.11 2012/11/04 10:00:55 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/ChangeLog,v 1.12 2013/06/16 15:39:08 jlec Exp $
+
+*mmtk-2.7.9 (16 Jun 2013)
+
+ 16 Jun 2013; Justin Lecher <jlec@gentoo.org> +mmtk-2.7.9.ebuild,
+ metadata.xml:
+ Version Bump and bump to distutils-r1.eclass
*mmtk-2.7.5 (04 Nov 2012)
diff --git a/sci-libs/mmtk/metadata.xml b/sci-libs/mmtk/metadata.xml
index e42d0af60f42..51fdedab1b38 100644
--- a/sci-libs/mmtk/metadata.xml
+++ b/sci-libs/mmtk/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>
diff --git a/sci-libs/mmtk/mmtk-2.7.9.ebuild b/sci-libs/mmtk/mmtk-2.7.9.ebuild
new file mode 100644
index 000000000000..0d57b1d4dba8
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mmtk/mmtk-2.7.9.ebuild,v 1.1 2013/06/16 15:39:09 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="4324"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+PYTHON_MODNAME="${MY_PN}"
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scientificpython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ export MMTK_USE_CYTHON="1"
+ sed \
+ -e "/ext_package/d" \
+ -e "/^if sphinx/s|:| == 3:|g" \
+ -e "s:import sphinx:sphinx = None:g" \
+ -i "${S}"/setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ DOCS=( README* Doc/CHANGELOG )
+ HTML_DOCS=( Doc/HTML/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r Examples
+ fi
+}